summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/mysql++/mysql++-1.7.9-r1.ebuild4
-rw-r--r--dev-db/postgis/postgis-0.7.5.ebuild15
-rw-r--r--dev-db/tora/tora-1.3.10.ebuild57
-rw-r--r--dev-db/tora/tora-1.3.8.ebuild63
-rw-r--r--dev-db/tora/tora-1.3.9.2.ebuild58
5 files changed, 99 insertions, 98 deletions
diff --git a/dev-db/mysql++/mysql++-1.7.9-r1.ebuild b/dev-db/mysql++/mysql++-1.7.9-r1.ebuild
index eee34c9b3be2..ef98646489ff 100644
--- a/dev-db/mysql++/mysql++-1.7.9-r1.ebuild
+++ b/dev-db/mysql++/mysql++-1.7.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-1.7.9-r1.ebuild,v 1.6 2003/08/05 16:01:17 vapier Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-1.7.9-r1.ebuild,v 1.7 2003/08/05 18:46:00 vapier Exp $
inherit gcc eutils
diff --git a/dev-db/postgis/postgis-0.7.5.ebuild b/dev-db/postgis/postgis-0.7.5.ebuild
index 313950d3402e..c120757e6690 100644
--- a/dev-db/postgis/postgis-0.7.5.ebuild
+++ b/dev-db/postgis/postgis-0.7.5.ebuild
@@ -1,20 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/postgis-0.7.5.ebuild,v 1.1 2003/07/12 23:18:05 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/postgis-0.7.5.ebuild,v 1.2 2003/08/05 18:46:45 vapier Exp $
-IUSE=""
-
-S="${WORKDIR}/${P}"
MY_PGSQL="postgresql-7.3.3"
-
DESCRIPTION="adds support for geographic objects to PostgreSQL"
+HOMEPAGE="http://postgis.refractions.net/"
SRC_URI="http://postgis.refractions.net/${P}.tar.gz
ftp://ftp8.us.postgresql.org/pub/pgsql/source/v7.3.3/${MY_PGSQL}.tar.gz"
-HOMEPAGE="http://postgis.refractions.net"
LICENSE="GPL-2"
-KEYWORDS="~x86"
SLOT="0"
+KEYWORDS="~x86"
DEPEND="~postgresql-7.3.3
dev-libs/proj
@@ -59,8 +55,7 @@ src_compile() {
make || die
}
-src_install () {
-
+src_install() {
cd ${WORKDIR}/${MY_PGSQL}/contrib/${P}
make \
diff --git a/dev-db/tora/tora-1.3.10.ebuild b/dev-db/tora/tora-1.3.10.ebuild
index add81db56f55..b60303a2119b 100644
--- a/dev-db/tora/tora-1.3.10.ebuild
+++ b/dev-db/tora/tora-1.3.10.ebuild
@@ -1,26 +1,43 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.10.ebuild,v 1.1 2003/07/25 14:47:03 rizzo Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.10.ebuild,v 1.2 2003/08/05 18:50:06 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="TOra - Toolkit For Oracle"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
HOMEPAGE="http://www.globecom.se/tora/"
-DEPEND=">=x11-libs/qt-3.0.0
- dev-lang/perl
- kde? ( >=kde-base/kdebase-3.1 )"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-LICENSE="GPL-2"
+
+DEPEND=">=x11-libs/qt-3.0.0
+ dev-lang/perl
+ kde? ( >=kde-base/kdebase-3.1 )"
+
+pkg_setup() {
+ if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
+ einfo "ORACLE_HOME variable is not set."
+ einfo ""
+ einfo "You must install Oracle >= 8i client for Linux in"
+ einfo "order to compile TOra with Oracle support."
+ einfo ""
+ einfo "Otherwise specify -oci8 in your USE variable."
+ einfo ""
+ einfo "You can download the Oracle software from"
+ einfo "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
src_compile() {
local myconf
- use kde && myconf="$myconf --with-kde" \
- || myconf="$myconf --without-kde"
- use oci8 || myconf="$myconf --without-oracle"
+ use kde \
+ && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use oci8 || myconf="$myconf --without-oracle"
- ./configure --prefix=/usr --with-mono $myconf
+ ./configure --prefix=/usr --with-mono $myconf || die "conf failed"
emake || die "emake failed"
}
@@ -28,19 +45,3 @@ src_install() {
dodir ${D}/usr/bin
einstall ROOT=${D}
}
-
-pkg_setup () {
-
- if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
- einfo "ORACLE_HOME variable is not set."
- einfo ""
- einfo "You must install Oracle >= 8i client for Linux in"
- einfo "order to compile TOra with Oracle support."
- einfo ""
- einfo "Otherwise specify -oci8 in your USE variable."
- einfo ""
- einfo "You can download the Oracle software from"
- einfo "http://otn.oracle.com/software/content.html"
- die
- fi
-}
diff --git a/dev-db/tora/tora-1.3.8.ebuild b/dev-db/tora/tora-1.3.8.ebuild
index 9f329c74dd55..86fdc080412a 100644
--- a/dev-db/tora/tora-1.3.8.ebuild
+++ b/dev-db/tora/tora-1.3.8.ebuild
@@ -1,29 +1,48 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.8.ebuild,v 1.3 2003/07/11 21:04:18 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.8.ebuild,v 1.4 2003/08/05 18:50:06 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="TOra - Toolkit For Oracle"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
HOMEPAGE="http://www.globecom.se/tora/"
-DEPEND=">=x11-libs/qt-3.0.0
- mysql? ( >=dev-db/mysql-3.23 )
- postgres? ( >=dev-db/postgresql-7.1 )"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-LICENSE="GPL-2"
+
+DEPEND=">=x11-libs/qt-3.0.0
+ mysql? ( >=dev-db/mysql-3.23 )
+ postgres? ( >=dev-db/postgresql-7.1 )"
+
+pkg_setup() {
+ if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
+ einfo "ORACLE_HOME variable is not set."
+ einfo ""
+ einfo "You must install Oracle >= 8i client for Linux in"
+ einfo "order to compile TOra with Oracle support."
+ einfo ""
+ einfo "Otherwise specify -oci8 in your USE variable."
+ einfo ""
+ einfo "You can download the Oracle software from"
+ einfo "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
src_compile() {
local myconf
- use kde && myconf="$myconf --with-kde" \
- || myconf="$myconf --without-kde"
- use mysql && myconf="$myconf" \
- || myconf="$myconf --without-mysql"
+ use kde \
+ && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use mysql \
+ && myconf="$myconf" \
+ || myconf="$myconf --without-mysql"
# use postgres && myconf="$myconf" \
# || myconf="$myconf --without-postgres"
- use oci8 && myconf="$myconf" \
- || myconf="$myconf --without-oracle"
+ use oci8 \
+ && myconf="$myconf" \
+ || myconf="$myconf --without-oracle"
#patch -p0 < ${FILESDIR}/tora-${PV}.patch
@@ -40,19 +59,3 @@ src_install() {
ROOT=${D} \
install || die "make install failed"
}
-
-pkg_setup () {
-
- if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
- einfo "ORACLE_HOME variable is not set."
- einfo ""
- einfo "You must install Oracle >= 8i client for Linux in"
- einfo "order to compile TOra with Oracle support."
- einfo ""
- einfo "Otherwise specify -oci8 in your USE variable."
- einfo ""
- einfo "You can download the Oracle software from"
- einfo "http://otn.oracle.com/software/content.html"
- die
- fi
-}
diff --git a/dev-db/tora/tora-1.3.9.2.ebuild b/dev-db/tora/tora-1.3.9.2.ebuild
index d14d3210bb4b..34e6578bf419 100644
--- a/dev-db/tora/tora-1.3.9.2.ebuild
+++ b/dev-db/tora/tora-1.3.9.2.ebuild
@@ -1,26 +1,44 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.9.2.ebuild,v 1.4 2003/07/25 14:39:02 rizzo Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.9.2.ebuild,v 1.5 2003/08/05 18:50:06 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="TOra - Toolkit For Oracle"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
HOMEPAGE="http://www.globecom.se/tora/"
-DEPEND=">=x11-libs/qt-3.0.0
- dev-lang/perl
- kde? ( >=kde-base/kdebase-2.2 )"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-LICENSE="GPL-2"
+
+DEPEND=">=x11-libs/qt-3.0.0
+ dev-lang/perl
+ kde? ( >=kde-base/kdebase-2.2 )"
+
+pkg_setup() {
+ if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
+ einfo "ORACLE_HOME variable is not set."
+ einfo ""
+ einfo "You must install Oracle >= 8i client for Linux in"
+ einfo "order to compile TOra with Oracle support."
+ einfo ""
+ einfo "Otherwise specify -oci8 in your USE variable."
+ einfo ""
+ einfo "You can download the Oracle software from"
+ einfo "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
src_compile() {
local myconf
- use kde && myconf="$myconf --with-kde" \
- || myconf="$myconf --without-kde"
- use oci8 || myconf="$myconf --without-oracle"
+ use kde \
+ && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use oci8 \
+ || myconf="$myconf --without-oracle"
- ./configure --prefix=/usr --with-mono $myconf
+ ./configure --prefix=/usr --with-mono $myconf || die "conf failed"
emake || die "emake failed"
}
@@ -28,19 +46,3 @@ src_install() {
dodir ${D}/usr/bin
einstall ROOT=${D}
}
-
-pkg_setup () {
-
- if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
- einfo "ORACLE_HOME variable is not set."
- einfo ""
- einfo "You must install Oracle >= 8i client for Linux in"
- einfo "order to compile TOra with Oracle support."
- einfo ""
- einfo "Otherwise specify -oci8 in your USE variable."
- einfo ""
- einfo "You can download the Oracle software from"
- einfo "http://otn.oracle.com/software/content.html"
- die
- fi
-}