summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/tora/tora-1.3.9.2.ebuild')
-rw-r--r--dev-db/tora/tora-1.3.9.2.ebuild58
1 files changed, 30 insertions, 28 deletions
diff --git a/dev-db/tora/tora-1.3.9.2.ebuild b/dev-db/tora/tora-1.3.9.2.ebuild
index d14d3210bb4b..34e6578bf419 100644
--- a/dev-db/tora/tora-1.3.9.2.ebuild
+++ b/dev-db/tora/tora-1.3.9.2.ebuild
@@ -1,26 +1,44 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.9.2.ebuild,v 1.4 2003/07/25 14:39:02 rizzo Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.9.2.ebuild,v 1.5 2003/08/05 18:50:06 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="TOra - Toolkit For Oracle"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
HOMEPAGE="http://www.globecom.se/tora/"
-DEPEND=">=x11-libs/qt-3.0.0
- dev-lang/perl
- kde? ( >=kde-base/kdebase-2.2 )"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-LICENSE="GPL-2"
+
+DEPEND=">=x11-libs/qt-3.0.0
+ dev-lang/perl
+ kde? ( >=kde-base/kdebase-2.2 )"
+
+pkg_setup() {
+ if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
+ einfo "ORACLE_HOME variable is not set."
+ einfo ""
+ einfo "You must install Oracle >= 8i client for Linux in"
+ einfo "order to compile TOra with Oracle support."
+ einfo ""
+ einfo "Otherwise specify -oci8 in your USE variable."
+ einfo ""
+ einfo "You can download the Oracle software from"
+ einfo "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
src_compile() {
local myconf
- use kde && myconf="$myconf --with-kde" \
- || myconf="$myconf --without-kde"
- use oci8 || myconf="$myconf --without-oracle"
+ use kde \
+ && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use oci8 \
+ || myconf="$myconf --without-oracle"
- ./configure --prefix=/usr --with-mono $myconf
+ ./configure --prefix=/usr --with-mono $myconf || die "conf failed"
emake || die "emake failed"
}
@@ -28,19 +46,3 @@ src_install() {
dodir ${D}/usr/bin
einstall ROOT=${D}
}
-
-pkg_setup () {
-
- if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
- einfo "ORACLE_HOME variable is not set."
- einfo ""
- einfo "You must install Oracle >= 8i client for Linux in"
- einfo "order to compile TOra with Oracle support."
- einfo ""
- einfo "Otherwise specify -oci8 in your USE variable."
- einfo ""
- einfo "You can download the Oracle software from"
- einfo "http://otn.oracle.com/software/content.html"
- die
- fi
-}