summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/tora/tora-1.3.8.ebuild')
-rw-r--r--dev-db/tora/tora-1.3.8.ebuild63
1 files changed, 33 insertions, 30 deletions
diff --git a/dev-db/tora/tora-1.3.8.ebuild b/dev-db/tora/tora-1.3.8.ebuild
index 9f329c74dd55..86fdc080412a 100644
--- a/dev-db/tora/tora-1.3.8.ebuild
+++ b/dev-db/tora/tora-1.3.8.ebuild
@@ -1,29 +1,48 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.8.ebuild,v 1.3 2003/07/11 21:04:18 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.8.ebuild,v 1.4 2003/08/05 18:50:06 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="TOra - Toolkit For Oracle"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
HOMEPAGE="http://www.globecom.se/tora/"
-DEPEND=">=x11-libs/qt-3.0.0
- mysql? ( >=dev-db/mysql-3.23 )
- postgres? ( >=dev-db/postgresql-7.1 )"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-LICENSE="GPL-2"
+
+DEPEND=">=x11-libs/qt-3.0.0
+ mysql? ( >=dev-db/mysql-3.23 )
+ postgres? ( >=dev-db/postgresql-7.1 )"
+
+pkg_setup() {
+ if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
+ einfo "ORACLE_HOME variable is not set."
+ einfo ""
+ einfo "You must install Oracle >= 8i client for Linux in"
+ einfo "order to compile TOra with Oracle support."
+ einfo ""
+ einfo "Otherwise specify -oci8 in your USE variable."
+ einfo ""
+ einfo "You can download the Oracle software from"
+ einfo "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
src_compile() {
local myconf
- use kde && myconf="$myconf --with-kde" \
- || myconf="$myconf --without-kde"
- use mysql && myconf="$myconf" \
- || myconf="$myconf --without-mysql"
+ use kde \
+ && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use mysql \
+ && myconf="$myconf" \
+ || myconf="$myconf --without-mysql"
# use postgres && myconf="$myconf" \
# || myconf="$myconf --without-postgres"
- use oci8 && myconf="$myconf" \
- || myconf="$myconf --without-oracle"
+ use oci8 \
+ && myconf="$myconf" \
+ || myconf="$myconf --without-oracle"
#patch -p0 < ${FILESDIR}/tora-${PV}.patch
@@ -40,19 +59,3 @@ src_install() {
ROOT=${D} \
install || die "make install failed"
}
-
-pkg_setup () {
-
- if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
- einfo "ORACLE_HOME variable is not set."
- einfo ""
- einfo "You must install Oracle >= 8i client for Linux in"
- einfo "order to compile TOra with Oracle support."
- einfo ""
- einfo "Otherwise specify -oci8 in your USE variable."
- einfo ""
- einfo "You can download the Oracle software from"
- einfo "http://otn.oracle.com/software/content.html"
- die
- fi
-}