summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-10-06 16:44:02 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-10-06 16:44:02 +0000
commit93edc958c77b220bcd93ecf29e71759d48504693 (patch)
tree5b33829fdc488a8805629d8ec1c0d758c8adb90f /sys-apps
parentmissed bonobo-conf (diff)
downloadhistorical-93edc958c77b220bcd93ecf29e71759d48504693.tar.gz
historical-93edc958c77b220bcd93ecf29e71759d48504693.tar.bz2
historical-93edc958c77b220bcd93ecf29e71759d48504693.zip
fixums
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/apcupsd/apcupsd-3.8.1.ebuild71
-rw-r--r--sys-apps/apcupsd/files/apcupsd33
-rwxr-xr-xsys-apps/apcupsd/files/halt2
-rw-r--r--sys-apps/at/at-3.1.8-r6.ebuild3
-rw-r--r--sys-apps/bash/bash-2.04-r3.ebuild6
-rw-r--r--sys-apps/bash/bash-2.04-r4.ebuild59
-rw-r--r--sys-apps/bash/bash-2.05.ebuild85
-rw-r--r--sys-apps/busybox/busybox-0.50.ebuild64
-rw-r--r--sys-apps/bzip2/bzip2-1.0.1-r3.ebuild69
-rw-r--r--sys-apps/bzip2/bzip2-1.0.1-r4.ebuild87
-rw-r--r--sys-apps/cpio/cpio-2.4.2-r4.ebuild29
11 files changed, 126 insertions, 382 deletions
diff --git a/sys-apps/apcupsd/apcupsd-3.8.1.ebuild b/sys-apps/apcupsd/apcupsd-3.8.1.ebuild
index 713eb8e6eeb6..2637dec8e347 100644
--- a/sys-apps/apcupsd/apcupsd-3.8.1.ebuild
+++ b/sys-apps/apcupsd/apcupsd-3.8.1.ebuild
@@ -1,52 +1,45 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Holger Brueckner <darks@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/apcupsd/apcupsd-3.8.1.ebuild,v 1.4 2001/08/31 03:23:39 pm Exp $
+# Maintainer: System Team <system@gentoo.org>
+# Author: Holger Brueckner <darks@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/apcupsd/apcupsd-3.8.1.ebuild,v 1.5 2001/10/06 16:44:02 drobbins Exp $
+# WARNING: THIS EBUILD HAS ONLY BEEN PARTIALLY CONVERTED TO THE NEW RC6 INITSCRIPTS
-A=${P}.tar.gz
S=${WORKDIR}/${P}
-DESCRIPTION="apc ups daemon with integrated tcp/ip remote shutdown"
-SRC_URI="http://www.sibbald.com/apcupsd/download/oldversions/${A}"
+DESCRIPTION="APC UPS daemon with integrated tcp/ip remote shutdown"
+SRC_URI="http://www.sibbald.com/apcupsd/download/oldversions/${P}.tar.gz"
HOMEPAGE="http://www.sibbald.com/apcupsd/"
DEPEND="virtual/glibc"
src_compile() {
- try ./configure
- try make
+ ./configure || die
+ make || die
}
src_install () {
- dosbin apcupsd apcaccess apcnetd
- cd ${S}/etc
- dodir etc/apcupsd
- insinto etc/apcupsd
- doins *.conf
- exeinto etc/apcupsd
- doexe changeme commfailure commok mainsback onbattery
- doexe ${FILESDIR}/apccontrol
- dodir var/log/apcupsd
- sed -e "s:/etc/apcupsd:/var/log/apcupsd:g" ${D}/etc/apcupsd/apcupsd.conf > ${D}/etc/apcupsd/apcupsd.conf.tmp
- mv ${D}/etc/apcupsd/apcupsd.conf.tmp ${D}/etc/apcupsd/apcupsd.conf
- cd ${S}/doc
- dodoc *
- docinto developers
- dodoc developers/*
- docinto manual
- dodoc manual/*
- mv ${S}/doc/apcupsd.man ${S}/doc/apcupsd.8
- doman apcupsd.8
- dodir /etc/rc.d/init.d
- exeinto /etc/rc.d/init.d
- doexe ${FILESDIR}/apcupsd
- doexe ${FILESDIR}/halt
-}
-
-pkg_postinst () {
- rc-update add apcupsd
-}
-
-pkg_prerm() {
- rc-update del apcupsd
+ dosbin apcupsd apcaccess apcnetd
+ cd ${S}/etc
+ dodir etc/apcupsd
+ insinto etc/apcupsd
+ doins *.conf
+ exeinto etc/apcupsd
+ doexe changeme commfailure commok mainsback onbattery
+ doexe ${FILESDIR}/apccontrol
+ dodir var/log/apcupsd
+ sed -e "s:/etc/apcupsd:/var/log/apcupsd:g" ${D}/etc/apcupsd/apcupsd.conf > ${D}/etc/apcupsd/apcupsd.conf.tmp
+ mv ${D}/etc/apcupsd/apcupsd.conf.tmp ${D}/etc/apcupsd/apcupsd.conf
+ cd ${S}/doc
+ dodoc *
+ docinto developers
+ dodoc developers/*
+ docinto manual
+ dodoc manual/*
+ mv ${S}/doc/apcupsd.man ${S}/doc/apcupsd.8
+ doman apcupsd.8
+ dodir /etc/init.d
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/apcupsd
+ doexe ${FILESDIR}/halt
}
diff --git a/sys-apps/apcupsd/files/apcupsd b/sys-apps/apcupsd/files/apcupsd
index aca9c397350a..4a75bd6b1e2e 100644
--- a/sys-apps/apcupsd/files/apcupsd
+++ b/sys-apps/apcupsd/files/apcupsd
@@ -1,32 +1,17 @@
-#!/bin/sh
-#RCUPDATE:2 3 4:80:This line is required for script management
-
-. /etc/rc.d/config/functions
+#!/sbin/runscript
SERVICE=apcupsd
-DESC="apcupsd"
EXE=/usr/sbin/apcupsd
-opts="start stop restart"
start() {
- rm -f /etc/apcupsd/powerfail
- ebegin "Starting ${DESC}"
- start-stop-daemon --start --quiet --exec ${EXE} -- 1>&2
- eend $? "Error starting ${DESC}."
+ rm -f /etc/apcupsd/powerfail
+ ebegin "Starting ${EXE}"
+ start-stop-daemon --start --quiet --exec ${EXE} -- 1>&2
+ eend $? "Error starting ${EXE}."
}
stop() {
- ebegin "Stopping ${DESC}"
- start-stop-daemon --stop --quiet --exec ${EXE} -- 1>&2
- eend $? "Error stopping ${DESC}."
-}
-
-restart() {
-
- stop
- start
-
-}
-
-
-doservice ${@}
+ ebegin "Stopping ${EXE}"
+ start-stop-daemon --stop --quiet --exec ${EXE} -- 1>&2
+ eend $? "Error stopping ${EXE}."
+}
diff --git a/sys-apps/apcupsd/files/halt b/sys-apps/apcupsd/files/halt
index 3d2a9422e266..be982cf792ca 100755
--- a/sys-apps/apcupsd/files/halt
+++ b/sys-apps/apcupsd/files/halt
@@ -3,7 +3,7 @@
# halt Execute the halt command.
#
# Version: @(#)halt 2.75 19-May-1998 miquels@cistron.nl
-# modified by Holger Brueckner <darksi@gentoo.org>
+# modified by Holger Brueckner <darks@gentoo.org>
# for apcupsd 28-June-2001
PATH=/sbin:/bin:/usr/sbin:/usr/bin
diff --git a/sys-apps/at/at-3.1.8-r6.ebuild b/sys-apps/at/at-3.1.8-r6.ebuild
index 462f9b234277..8bcf753cce34 100644
--- a/sys-apps/at/at-3.1.8-r6.ebuild
+++ b/sys-apps/at/at-3.1.8-r6.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/at/at-3.1.8-r6.ebuild,v 1.1 2001/09/02 03:39:24 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/at/at-3.1.8-r6.ebuild,v 1.2 2001/10/06 16:44:02 drobbins Exp $
-A="${P}.tar.bz2 ${P}.dif"
S=${WORKDIR}/${P}
DESCRIPTION="queues jobs for later execution"
SRC_URI="ftp://jurix.jura.uni-sb.de/pub/jurix/source/chroot/appl/at/${P}.tar.bz2
diff --git a/sys-apps/bash/bash-2.04-r3.ebuild b/sys-apps/bash/bash-2.04-r3.ebuild
index 1d3d4cda14c1..f58081e81592 100644
--- a/sys-apps/bash/bash-2.04-r3.ebuild
+++ b/sys-apps/bash/bash-2.04-r3.ebuild
@@ -1,13 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.04-r3.ebuild,v 1.2 2001/02/27 23:03:15 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.04-r3.ebuild,v 1.3 2001/10/06 16:44:02 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="The standard GNU Bourne again shell"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bash/${A}
- ftp://ftp.gnu.org/gnu/bash/${A}"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bash/${P}.tar.gz ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
diff --git a/sys-apps/bash/bash-2.04-r4.ebuild b/sys-apps/bash/bash-2.04-r4.ebuild
index 299a5c3c9910..271a475681a5 100644
--- a/sys-apps/bash/bash-2.04-r4.ebuild
+++ b/sys-apps/bash/bash-2.04-r4.ebuild
@@ -1,65 +1,34 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.04-r4.ebuild,v 1.3 2001/09/15 19:27:22 danarmak Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.04-r4.ebuild,v 1.4 2001/10/06 16:44:02 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="The standard GNU Bourne again shell"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bash/${A}
- ftp://ftp.gnu.org/gnu/bash/${A}"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bash/${P}.tar.gz ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
DEPEND=">=sys-libs/ncurses-5.2-r2
readline? ( >=sys-libs/readline-4.1-r2 )"
-# tex? ( app-text/tetex )
RDEPEND="virtual/glibc"
src_compile() {
-
local myconf
- if [ "`use readline`" ]
- then
- myconf="--with-installed-readline"
- fi
-
- if [ -z "`use nls`" ]
- then
- myconf="${myconf} --disable-nls"
- fi
-
- try ./configure --prefix=/ --mandir=/usr/share/man \
- --infodir=/usr/share/info --host=${CHOST} \
- --disable-profiling --with-curses \
- --enable-static-link ${myconf}
-
- try pmake
-
-# if [ "`use tex`" ] && [ -z "`use build`" ] && [ -z "`use bootcd`" ]
-# then
-# cd support
-# cp texi2html texi2html.orig
-# sed -e "s:/usr/local/bin/perl:/usr/bin/perl:" \
-# texi2html.orig > texi2html
-# cd ../doc
-# try make
-# fi
-
+ [ "`use readline`" ] && myconf="--with-installed-readline"
+ [ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
+ ./configure --prefix=/ --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST} --disable-profiling --with-curses --enable-static-link ${myconf} || die
+ emake || die
}
-
-
src_install() {
-
- make prefix=${D}/usr mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
dodir /bin
mv ${D}/usr/bin/bash ${D}/bin
dosym bash /bin/sh
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ if [ -z "`use build`" ]
then
doman doc/*.1
@@ -70,15 +39,7 @@ src_install() {
dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
dodoc doc/FAQ doc/INTRO
- if [ "`use tex`" ]
- then
- docinto html
- dodoc doc/*.html
- docinto ps
- dodoc doc/*.ps
- fi
else
rm -rf ${D}/usr
fi
-
}
diff --git a/sys-apps/bash/bash-2.05.ebuild b/sys-apps/bash/bash-2.05.ebuild
deleted file mode 100644
index e807caa6dc01..000000000000
--- a/sys-apps/bash/bash-2.05.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05.ebuild,v 1.2 2001/09/15 19:29:14 danarmak Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="The standard GNU Bourne again shell"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bash/${A}
- ftp://ftp.gnu.org/gnu/bash/${A}"
-
-HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-4.2 )"
-# tex? ( app-text/tetex )
-
-RDEPEND="virtual/glibc"
-
-src_compile() {
-
- local myconf
- if [ "`use readline`" ]
- then
- myconf="--with-installed-readline"
- fi
-
- if [ -z "`use nls`" ]
- then
- myconf="${myconf} --disable-nls"
- fi
-
- try ./configure --prefix=/ --mandir=/usr/share/man \
- --infodir=/usr/share/info --host=${CHOST} \
- --disable-profiling --with-curses \
- --enable-static-link ${myconf}
-
- try pmake
-
- if [ "`use tex`" ] && [ -z "`use build`" ]
- then
- cd support
- cp texi2html texi2html.orig
- sed -e "s:/usr/local/bin/perl:/usr/bin/perl:" \
- texi2html.orig > texi2html
- cd ../doc
- try make
- fi
-
-}
-
-
-
-src_install() {
-
- make prefix=${D}/usr mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install
- dodir /bin
- mv ${D}/usr/bin/bash ${D}/bin
- dosym bash /bin/sh
-
- if [ -z "`use build`" ]
- then
- doman doc/*.1
-
- if [ -z "`use readline`" ]
- then
- doman doc/*.3
- fi
- dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
- dodoc doc/FAQ doc/INTRO
-
- if [ "`use tex`" ]
- then
- docinto html
- dodoc doc/*.html
- docinto ps
- dodoc doc/*.ps
- fi
- else
- rm -rf ${D}/usr
- fi
-
-}
-
diff --git a/sys-apps/busybox/busybox-0.50.ebuild b/sys-apps/busybox/busybox-0.50.ebuild
index e776897de818..a5db39fdf7b3 100644
--- a/sys-apps/busybox/busybox-0.50.ebuild
+++ b/sys-apps/busybox/busybox-0.50.ebuild
@@ -1,52 +1,46 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.50.ebuild,v 1.4 2001/08/11 05:30:57 drobbins Exp $
+# Author: Achim Gottinger <achim@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.50.ebuild,v 1.5 2001/10/06 16:44:02 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Utilities for rescue and embedded systems"
-SRC_URI="ftp://oss.lineo.com/busybox/${A}"
+SRC_URI="ftp://oss.lineo.com/busybox/${P}.tar.gz"
HOMEPAGE="http://busybox.lineo.com/"
DEPEND="virtual/glibc"
src_unpack() {
- unpack ${A}
- cp ${FILESDIR}/Config.h ${S}/Config.h
+ unpack ${A}
+ cp ${FILESDIR}/Config.h ${S}/Config.h
}
src_compile() {
-
- export OPT="`echo $CFLAGS|sed 's:.*\(-O.\).*:\1:'`"
- export CFLAGS_EXTRA=${CFLAGS/-O?/}
- unset CFLAGS
- echo $CFLAGS_EXTRA $OPT
- try make CFLAGS_EXTRA="${CFLAGS_EXTRA}" OPTIMIZATION=$OPT
-
+ export OPT="`echo $CFLAGS|sed 's:.*\(-O.\).*:\1:'`"
+ export CFLAGS_EXTRA=${CFLAGS/-O?/}
+ unset CFLAGS
+ echo $CFLAGS_EXTRA $OPT
+ make CFLAGS_EXTRA="${CFLAGS_EXTRA}" OPTIMIZATION=$OPT || die
}
src_install () {
-
- into /
- dobin busybox
- into /usr
- dodoc AUTHORS Changelog LICENSE README TODO
- cd docs
- doman *.1
- docinto txt
- dodoc *.txt
- docinto sgml
- dodoc *.sgml
- docinto pod
- dodoc *.pod
-
- cd busybox.lineo.com
- docinto html
- dodoc *.html
- docinto html/images
- dodoc images/*
-
-
+ into /
+ dobin busybox
+ into /usr
+ dodoc AUTHORS Changelog LICENSE README TODO
+ cd docs
+ doman *.1
+ docinto txt
+ dodoc *.txt
+ docinto sgml
+ dodoc *.sgml
+ docinto pod
+ dodoc *.pod
+
+ cd busybox.lineo.com
+ docinto html
+ dodoc *.html
+ docinto html/images
+ dodoc images/*
}
diff --git a/sys-apps/bzip2/bzip2-1.0.1-r3.ebuild b/sys-apps/bzip2/bzip2-1.0.1-r3.ebuild
deleted file mode 100644
index 2f729927833c..000000000000
--- a/sys-apps/bzip2/bzip2-1.0.1-r3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bzip2/bzip2-1.0.1-r3.ebuild,v 1.1 2001/02/27 16:19:27 achim Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo"
-SRC_URI="ftp://sourceware.cygnus.com/pub/bzip2/v100/${A}
- ftp://ftp.freesoftware.com/pub/sourceware/bzip2/v100/${A}"
-
-HOMEPAGE="http://sourceware.cygnus.com/bzip2/"
-
-DEPEND="virtual/glibc"
-
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- patch -p0 < ${FILESDIR}/bzip2-1.0.1-Makefile-gentoo.diff
- cp ${FILESDIR}/Makefile.dietlibc .
-}
-
-src_compile() {
-
- if [ -z "`use build`" ]
- then
- try pmake -f Makefile-libbz2_so all
- fi
- if [ -z "`use static`" ]
- then
- try pmake all
- else
- if [ "`use diet`" ]
- then
- try pmake LDFLAGS=-static -f Makefile.dietlibc all
- else
- try pmake LDFLAGS=-static all
- fi
- fi
-
-}
-src_install() {
-
- if [ -z "`use build`" ]
- then
- try make DESTDIR=${D} install
- try make DESTDIR=${D} -f Makefile-libbz2_so install
-
- mv ${D}/usr/bin ${D}
-
- dodoc README LICENSE CHANGES Y2K_INFO
- docinto txt
- dodoc bzip2.txt
- docinto ps
- dodoc manual.ps
- docinto html
- dodoc manual_*.html
- else
- into /
- dobin bzip2
- cd ${D}/bin
- ln -s bzip2 bunzip2
- fi
-
-}
-
-
diff --git a/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild b/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild
index 2933690d6232..04fe8ca32b35 100644
--- a/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild
+++ b/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild
@@ -1,72 +1,47 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild,v 1.1 2001/08/04 18:22:45 pete Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild,v 1.2 2001/10/06 16:44:02 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo"
-SRC_URI="ftp://sourceware.cygnus.com/pub/bzip2/v100/${A}
- ftp://ftp.freesoftware.com/pub/sourceware/bzip2/v100/${A}"
-
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
+SRC_URI="ftp://sourceware.cygnus.com/pub/bzip2/v100/${P}.tar.gz ftp://ftp.freesoftware.com/pub/sourceware/bzip2/v100/${P}.tar.gz"
HOMEPAGE="http://sourceware.cygnus.com/bzip2/"
-
DEPEND="virtual/glibc"
src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- patch -p0 < ${FILESDIR}/bzip2-1.0.1-Makefile-gentoo.diff
- cp ${FILESDIR}/Makefile.dietlibc .
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/bzip2-1.0.1-Makefile-gentoo.diff
+ cp ${FILESDIR}/Makefile.dietlibc .
}
src_compile() {
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- try pmake -f Makefile-libbz2_so all
- fi
- if [ -z "`use static`" ]
- then
- try pmake all
- else
- if [ "`use diet`" ]
- then
- try pmake LDFLAGS=-static -f Makefile.dietlibc all
- else
- try pmake LDFLAGS=-static all
- fi
- fi
+ if [ -z "`use build`" ]
+ then
+ emake -f Makefile-libbz2_so all || die
+ fi
+ emake all || die
}
src_install() {
-
- if [ -z "`use build`" ]
- then
- try make DESTDIR=${D} install
- mv ${D}/usr/bin ${D}
-
- if [ -z "`use bootcd`" ]
- then
- try make DESTDIR=${D} -f Makefile-libbz2_so install
-
- dodoc README LICENSE CHANGES Y2K_INFO
- docinto txt
- dodoc bzip2.txt
- docinto ps
- dodoc manual.ps
- docinto html
- dodoc manual_*.html
- else
- rm -rf ${D}/usr
- fi
+ if [ -z "`use build`" ]
+ then
+ make DESTDIR=${D} install || die
+ mv ${D}/usr/bin ${D}
+ make DESTDIR=${D} -f Makefile-libbz2_so install || die
+ dodoc README LICENSE CHANGES Y2K_INFO
+ docinto txt
+ dodoc bzip2.txt
+ docinto ps
+ dodoc manual.ps
+ docinto html
+ dodoc manual_*.html
else
- into /
- dobin bzip2
- cd ${D}/bin
- ln -s bzip2 bunzip2
- fi
-
+ into /
+ dobin bzip2
+ cd ${D}/bin
+ ln -s bzip2 bunzip2
+ fi
}
diff --git a/sys-apps/cpio/cpio-2.4.2-r4.ebuild b/sys-apps/cpio/cpio-2.4.2-r4.ebuild
index fa54c49a230c..b4f1650eb0fd 100644
--- a/sys-apps/cpio/cpio-2.4.2-r4.ebuild
+++ b/sys-apps/cpio/cpio-2.4.2-r4.ebuild
@@ -1,33 +1,27 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpio/cpio-2.4.2-r4.ebuild,v 1.1 2001/03/04 04:58:10 drobbins Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpio/cpio-2.4.2-r4.ebuild,v 1.2 2001/10/06 16:44:02 drobbins Exp $
-
-A="${P}.tar.gz"
S=${WORKDIR}/${P}
DESCRIPTION="A file archival tool which can also read and write tar files"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/cpio/${A}
- ftp://prep.ai.mit.edu/gnu/cpio/${A}"
-
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/cpio/${P}.tar.gz ftp://prep.ai.mit.edu/gnu/cpio/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/cpio/cpio.html"
-
DEPEND="virtual/glibc"
-
RDEPEND="virtual/glibc"
src_compile() {
- try ./configure --host=${CHOST} --prefix=/usr
- try pmake
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
}
src_unpack() {
- unpack ${A}
- cd ${S}
- mv rmt.c rmt.c.orig
- sed -e "78d" rmt.c.orig > rmt.c
- mv userspec.c userspec.c.orig
- sed -e "85d" userspec.c.orig > userspec.c
+ unpack ${A}
+ cd ${S}
+ mv rmt.c rmt.c.orig
+ sed -e "78d" rmt.c.orig > rmt.c
+ mv userspec.c userspec.c.orig
+ sed -e "85d" userspec.c.orig > userspec.c
}
src_install() {
@@ -36,6 +30,5 @@ src_install() {
doman cpio.1
doinfo cpio.info
dodoc COPYING* ChangeLog NEWS README
-
}