summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/busybox/busybox-0.50.ebuild')
-rw-r--r--sys-apps/busybox/busybox-0.50.ebuild64
1 files changed, 29 insertions, 35 deletions
diff --git a/sys-apps/busybox/busybox-0.50.ebuild b/sys-apps/busybox/busybox-0.50.ebuild
index e776897de818..a5db39fdf7b3 100644
--- a/sys-apps/busybox/busybox-0.50.ebuild
+++ b/sys-apps/busybox/busybox-0.50.ebuild
@@ -1,52 +1,46 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.50.ebuild,v 1.4 2001/08/11 05:30:57 drobbins Exp $
+# Author: Achim Gottinger <achim@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.50.ebuild,v 1.5 2001/10/06 16:44:02 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Utilities for rescue and embedded systems"
-SRC_URI="ftp://oss.lineo.com/busybox/${A}"
+SRC_URI="ftp://oss.lineo.com/busybox/${P}.tar.gz"
HOMEPAGE="http://busybox.lineo.com/"
DEPEND="virtual/glibc"
src_unpack() {
- unpack ${A}
- cp ${FILESDIR}/Config.h ${S}/Config.h
+ unpack ${A}
+ cp ${FILESDIR}/Config.h ${S}/Config.h
}
src_compile() {
-
- export OPT="`echo $CFLAGS|sed 's:.*\(-O.\).*:\1:'`"
- export CFLAGS_EXTRA=${CFLAGS/-O?/}
- unset CFLAGS
- echo $CFLAGS_EXTRA $OPT
- try make CFLAGS_EXTRA="${CFLAGS_EXTRA}" OPTIMIZATION=$OPT
-
+ export OPT="`echo $CFLAGS|sed 's:.*\(-O.\).*:\1:'`"
+ export CFLAGS_EXTRA=${CFLAGS/-O?/}
+ unset CFLAGS
+ echo $CFLAGS_EXTRA $OPT
+ make CFLAGS_EXTRA="${CFLAGS_EXTRA}" OPTIMIZATION=$OPT || die
}
src_install () {
-
- into /
- dobin busybox
- into /usr
- dodoc AUTHORS Changelog LICENSE README TODO
- cd docs
- doman *.1
- docinto txt
- dodoc *.txt
- docinto sgml
- dodoc *.sgml
- docinto pod
- dodoc *.pod
-
- cd busybox.lineo.com
- docinto html
- dodoc *.html
- docinto html/images
- dodoc images/*
-
-
+ into /
+ dobin busybox
+ into /usr
+ dodoc AUTHORS Changelog LICENSE README TODO
+ cd docs
+ doman *.1
+ docinto txt
+ dodoc *.txt
+ docinto sgml
+ dodoc *.sgml
+ docinto pod
+ dodoc *.pod
+
+ cd busybox.lineo.com
+ docinto html
+ dodoc *.html
+ docinto html/images
+ dodoc images/*
}