summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/bash/bash-2.04-r4.ebuild')
-rw-r--r--sys-apps/bash/bash-2.04-r4.ebuild59
1 files changed, 10 insertions, 49 deletions
diff --git a/sys-apps/bash/bash-2.04-r4.ebuild b/sys-apps/bash/bash-2.04-r4.ebuild
index 299a5c3c9910..271a475681a5 100644
--- a/sys-apps/bash/bash-2.04-r4.ebuild
+++ b/sys-apps/bash/bash-2.04-r4.ebuild
@@ -1,65 +1,34 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.04-r4.ebuild,v 1.3 2001/09/15 19:27:22 danarmak Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.04-r4.ebuild,v 1.4 2001/10/06 16:44:02 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="The standard GNU Bourne again shell"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bash/${A}
- ftp://ftp.gnu.org/gnu/bash/${A}"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bash/${P}.tar.gz ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
DEPEND=">=sys-libs/ncurses-5.2-r2
readline? ( >=sys-libs/readline-4.1-r2 )"
-# tex? ( app-text/tetex )
RDEPEND="virtual/glibc"
src_compile() {
-
local myconf
- if [ "`use readline`" ]
- then
- myconf="--with-installed-readline"
- fi
-
- if [ -z "`use nls`" ]
- then
- myconf="${myconf} --disable-nls"
- fi
-
- try ./configure --prefix=/ --mandir=/usr/share/man \
- --infodir=/usr/share/info --host=${CHOST} \
- --disable-profiling --with-curses \
- --enable-static-link ${myconf}
-
- try pmake
-
-# if [ "`use tex`" ] && [ -z "`use build`" ] && [ -z "`use bootcd`" ]
-# then
-# cd support
-# cp texi2html texi2html.orig
-# sed -e "s:/usr/local/bin/perl:/usr/bin/perl:" \
-# texi2html.orig > texi2html
-# cd ../doc
-# try make
-# fi
-
+ [ "`use readline`" ] && myconf="--with-installed-readline"
+ [ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
+ ./configure --prefix=/ --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST} --disable-profiling --with-curses --enable-static-link ${myconf} || die
+ emake || die
}
-
-
src_install() {
-
- make prefix=${D}/usr mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
dodir /bin
mv ${D}/usr/bin/bash ${D}/bin
dosym bash /bin/sh
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ if [ -z "`use build`" ]
then
doman doc/*.1
@@ -70,15 +39,7 @@ src_install() {
dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
dodoc doc/FAQ doc/INTRO
- if [ "`use tex`" ]
- then
- docinto html
- dodoc doc/*.html
- docinto ps
- dodoc doc/*.ps
- fi
else
rm -rf ${D}/usr
fi
-
}