aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2024-06-10 02:28:03 -0400
committerJoe Kappus <joe@wt.gd>2024-06-10 02:29:29 -0400
commitf6942cfedbd9d7e70fdf948d9e66f8e2b20c2ee5 (patch)
tree854eb5765a43bbac01fb55a9cf795e539ce593a4 /net-nntp/pan
parentprofiles: Remove dev-python/wrapio (diff)
downloadguru-f6942cfedbd9d7e70fdf948d9e66f8e2b20c2ee5.tar.gz
guru-f6942cfedbd9d7e70fdf948d9e66f8e2b20c2ee5.tar.bz2
guru-f6942cfedbd9d7e70fdf948d9e66f8e2b20c2ee5.zip
net-nntp/pan: correct test restriction, relax clang linking
Am aware of https://wiki.gentoo.org/wiki/Project:Quality_Assurance/-Wl,-z,defs_and_-Wl,--no-allow-shlib-undefined Will try to get this properly fixed soon, workaround now for clang users. Bug: https://bugs.gentoo.org/933860 Signed-off-by: Joe Kappus <joe@wt.gd>
Diffstat (limited to 'net-nntp/pan')
-rw-r--r--net-nntp/pan/pan-0.159-r1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/net-nntp/pan/pan-0.159-r1.ebuild b/net-nntp/pan/pan-0.159-r1.ebuild
index 0e4f95094..fc1cbd592 100644
--- a/net-nntp/pan/pan-0.159-r1.ebuild
+++ b/net-nntp/pan/pan-0.159-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake gnome2
+inherit cmake gnome2 toolchain-funcs
DESCRIPTION="A newsreader for GNOME"
HOMEPAGE="https://gitlab.gnome.org/GNOME/pan/"
@@ -14,6 +14,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="dbus gnome-keyring libnotify spell ssl"
+# currently broken due to cmake migration
+RESTRICT="test"
DEPEND="
>=dev-libs/glib-2.26:2
@@ -42,6 +44,11 @@ BDEPEND="
src_prepare() {
cmake_src_prepare
+
+ # Relax linker restriction on clang. Not ideal, but it's this or block clang.
+ if tc-is-clang; then
+ append-ldflags "-Wl,--allow-shlib-undefined"
+ fi
}
src_configure() {
@@ -66,10 +73,4 @@ src_install() {
dolib.so "${BUILD_DIR}/pan/tasks/libtasks.so"
dolib.so "${BUILD_DIR}/pan/usenet-utils/libusenet-utils.so"
-
-}
-
-src_test() {
- # not doing tests. Bug #933860
- einfo "Skipping tests..."
}