aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp/pan/pan-0.159-r1.ebuild')
-rw-r--r--net-nntp/pan/pan-0.159-r1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/net-nntp/pan/pan-0.159-r1.ebuild b/net-nntp/pan/pan-0.159-r1.ebuild
index 0e4f95094..fc1cbd592 100644
--- a/net-nntp/pan/pan-0.159-r1.ebuild
+++ b/net-nntp/pan/pan-0.159-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake gnome2
+inherit cmake gnome2 toolchain-funcs
DESCRIPTION="A newsreader for GNOME"
HOMEPAGE="https://gitlab.gnome.org/GNOME/pan/"
@@ -14,6 +14,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="dbus gnome-keyring libnotify spell ssl"
+# currently broken due to cmake migration
+RESTRICT="test"
DEPEND="
>=dev-libs/glib-2.26:2
@@ -42,6 +44,11 @@ BDEPEND="
src_prepare() {
cmake_src_prepare
+
+ # Relax linker restriction on clang. Not ideal, but it's this or block clang.
+ if tc-is-clang; then
+ append-ldflags "-Wl,--allow-shlib-undefined"
+ fi
}
src_configure() {
@@ -66,10 +73,4 @@ src_install() {
dolib.so "${BUILD_DIR}/pan/tasks/libtasks.so"
dolib.so "${BUILD_DIR}/pan/usenet-utils/libusenet-utils.so"
-
-}
-
-src_test() {
- # not doing tests. Bug #933860
- einfo "Skipping tests..."
}