summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/paxctl/paxctl-0.2.ebuild')
-rw-r--r--sys-apps/paxctl/paxctl-0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/paxctl/paxctl-0.2.ebuild b/sys-apps/paxctl/paxctl-0.2.ebuild
new file mode 100644
index 000000000000..cd901c2eef0b
--- /dev/null
+++ b/sys-apps/paxctl/paxctl-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.2.ebuild,v 1.1 2004/02/18 07:58:03 solar Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Manages various PaX related program header flags for Elf32, Elf64, binaries."
+SRC_URI="http://pax.grsecurity.net/paxctl-${PV}.tar.gz"
+HOMEPAGE="http://pax.grsecurity.net"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~hppa ~ia64" ; # "~mips"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc >=sys-devel/binutils-2.14.90.0.8-r1"
+
+#S=${WORKDIR}/${P}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+ dodoc README ChangeLog
+}