summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-02-18 07:58:03 +0000
committerNed Ludd <solar@gentoo.org>2004-02-18 07:58:03 +0000
commit043a7eba993cf21be9e2b8a94450740db9583d6f (patch)
tree84458ae021145afbadb425ca9442aa12372f6e82 /sys-apps/paxctl/paxctl-0.2.ebuild
parentLittle fixes, see bug 41146 (diff)
downloadhistorical-043a7eba993cf21be9e2b8a94450740db9583d6f.tar.gz
historical-043a7eba993cf21be9e2b8a94450740db9583d6f.tar.bz2
historical-043a7eba993cf21be9e2b8a94450740db9583d6f.zip
This is paxctl for controlling PaX flags on a per binary basis. PaX
is an intrusion prevention system that provides the best protection mechanisms against memory corruption bugs. Some applications are not compatible with certain features (due to design or bad engineering) and therefore they have to be exempted from certain enforcements. It is also possible to use PaX in soft mode where none of the protection mechanisms are active by default - here paxctl can be used to turn them on for selected programs (e.g., network daemons, programs that process network data such as mail clients, web browsers, etc). PaX and paxctl work on ELF executables, both of the standard ET_EXEC and the newer ET_DYN kind (older PaX releases referred to the latter as ET_DYN executables, these days they are called Position Independent Executables or PIEs for short).
Diffstat (limited to 'sys-apps/paxctl/paxctl-0.2.ebuild')
-rw-r--r--sys-apps/paxctl/paxctl-0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/paxctl/paxctl-0.2.ebuild b/sys-apps/paxctl/paxctl-0.2.ebuild
new file mode 100644
index 000000000000..cd901c2eef0b
--- /dev/null
+++ b/sys-apps/paxctl/paxctl-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.2.ebuild,v 1.1 2004/02/18 07:58:03 solar Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Manages various PaX related program header flags for Elf32, Elf64, binaries."
+SRC_URI="http://pax.grsecurity.net/paxctl-${PV}.tar.gz"
+HOMEPAGE="http://pax.grsecurity.net"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~hppa ~ia64" ; # "~mips"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc >=sys-devel/binutils-2.14.90.0.8-r1"
+
+#S=${WORKDIR}/${P}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+ dodoc README ChangeLog
+}