summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/abook/abook-0.4.17.ebuild5
-rw-r--r--app-misc/glastree/glastree-0.57.ebuild5
-rw-r--r--app-misc/muttprint/muttprint-0.62b.ebuild8
-rw-r--r--app-misc/scmxx/scmxx-0.6.0.ebuild5
-rw-r--r--app-misc/smtm/smtm-1.4.0.ebuild9
-rw-r--r--app-misc/splitvt/splitvt-1.6.5.ebuild3
-rw-r--r--app-misc/sqeed/sqeed-0.2.2.ebuild10
-rw-r--r--app-misc/todo-manager-bronze/todo-manager-bronze-20020711.ebuild3
-rw-r--r--app-misc/toshiba-utils/toshiba-utils-2.0.1-r1.ebuild3
-rw-r--r--app-misc/uptimed/uptimed-0.2.0-r1.ebuild3
-rw-r--r--app-misc/vlock/vlock-1.3-r1.ebuild7
-rw-r--r--app-misc/vlock/vlock-1.3.ebuild7
-rw-r--r--app-misc/worker/worker-2.3.1.ebuild3
-rw-r--r--app-misc/xclip/xclip-0.05.ebuild13
-rw-r--r--app-misc/xclip/xclip-0.08.ebuild8
-rw-r--r--app-misc/xlockmore/xlockmore-5.04.ebuild3
-rw-r--r--app-misc/xplore/xplore-1.1-r1.ebuild9
-rw-r--r--app-misc/xplore/xplore-1.1e.ebuild5
-rw-r--r--app-misc/xsnap/xsnap-1.3.ebuild5
-rw-r--r--app-misc/xtrlock/xtrlock-2.0.ebuild5
-rw-r--r--app-misc/zisofs-tools/zisofs-tools-1.0.3.ebuild3
21 files changed, 60 insertions, 62 deletions
diff --git a/app-misc/abook/abook-0.4.17.ebuild b/app-misc/abook/abook-0.4.17.ebuild
index eb66116a607a..d321a0281d45 100644
--- a/app-misc/abook/abook-0.4.17.ebuild
+++ b/app-misc/abook/abook-0.4.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/abook/abook-0.4.17.ebuild,v 1.1 2002/08/18 21:11:49 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/abook/abook-0.4.17.ebuild,v 1.2 2002/10/17 00:27:13 vapier Exp $
DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client."
HOMEPAGE="http://abook.sourceforge.net/"
@@ -9,6 +9,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${P}
@@ -23,6 +24,6 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
}
diff --git a/app-misc/glastree/glastree-0.57.ebuild b/app-misc/glastree/glastree-0.57.ebuild
index 1c79bd2b4815..62b803ca83b1 100644
--- a/app-misc/glastree/glastree-0.57.ebuild
+++ b/app-misc/glastree/glastree-0.57.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/glastree/glastree-0.57.ebuild,v 1.3 2002/10/04 04:55:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/glastree/glastree-0.57.ebuild,v 1.4 2002/10/17 00:27:13 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="glastree is a poor mans snapshot utility using hardlinks written in perl"
HOMEPAGE="http://www.igmus.org/code/"
SRC_URI="http://www.igmus.org/files/${P}.tar.gz"
DEPEND="sys-devel/perl dev-perl/Date-Calc"
+RDEPEND="${DEPEND}"
SLOT="0"
KEYWORDS="x86"
LICENSE="public-domain"
-src_install () {
+src_install() {
dodir /usr/share/man/man1
make INSTROOT=${D}/usr INSTMAN=share/man install || die
dodoc README CHANGES THANKS TODO
diff --git a/app-misc/muttprint/muttprint-0.62b.ebuild b/app-misc/muttprint/muttprint-0.62b.ebuild
index d027e8f1345e..619dc543051b 100644
--- a/app-misc/muttprint/muttprint-0.62b.ebuild
+++ b/app-misc/muttprint/muttprint-0.62b.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/muttprint/muttprint-0.62b.ebuild,v 1.2 2002/09/14 21:12:53 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/muttprint/muttprint-0.62b.ebuild,v 1.3 2002/10/17 00:27:13 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="pretty printing of your mails"
-HOMEPAGE="http://muttprint.sf.net"
+HOMEPAGE="http://muttprint.sf.net/"
SRC_URI="mirror://sourceforge/muttprint/${P}.tar.gz"
SLOT="0"
@@ -12,9 +12,9 @@ LICENSE="GPL-2"
KEYWORDS="x86"
DEPEND="app-text/tetex"
+RDEPEND="${DEPEND}"
-src_install () {
+src_install() {
# understanding the install part of the Makefiles.
make prefix=${D}/usr docdir=${D}/usr/share/doc/ install || die
}
-
diff --git a/app-misc/scmxx/scmxx-0.6.0.ebuild b/app-misc/scmxx/scmxx-0.6.0.ebuild
index f433ef3167c5..ee999a11d694 100644
--- a/app-misc/scmxx/scmxx-0.6.0.ebuild
+++ b/app-misc/scmxx/scmxx-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/scmxx/scmxx-0.6.0.ebuild,v 1.4 2002/10/04 04:57:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/scmxx/scmxx-0.6.0.ebuild,v 1.5 2002/10/17 00:24:16 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Exchange data with Siemens phones."
@@ -12,13 +12,14 @@ LICENSE="GPL-2"
KEYWORDS="x86"
DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
src_compile() {
econf || die "./configure failed"
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
exeinto /usr/lib/scmxx
doexe contrib/*
diff --git a/app-misc/smtm/smtm-1.4.0.ebuild b/app-misc/smtm/smtm-1.4.0.ebuild
index 778820d7da95..10b8a01d479c 100644
--- a/app-misc/smtm/smtm-1.4.0.ebuild
+++ b/app-misc/smtm/smtm-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/smtm/smtm-1.4.0.ebuild,v 1.3 2002/10/04 04:57:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/smtm/smtm-1.4.0.ebuild,v 1.4 2002/10/17 00:24:16 vapier Exp $
DESCRIPTION="Stock ticker, profit/loss calculator and chart tool"
HOMEPAGE="http://eddelbuettel.com/dirk/code/smtm.html"
@@ -14,14 +14,11 @@ DEPEND=">=sys-devel/perl-5
dev-perl/perl-tk
dev-perl/DateManip
dev-perl/libwww-perl"
+RDEPEND="${DEPEND}"
S=${WORKDIR}
-src_compile() {
- echo "nothing to compile"
-}
-
-src_install () {
+src_install() {
exeinto /usr/bin
doexe smtm
diff --git a/app-misc/splitvt/splitvt-1.6.5.ebuild b/app-misc/splitvt/splitvt-1.6.5.ebuild
index 8c8834602a48..c0d33fa2d651 100644
--- a/app-misc/splitvt/splitvt-1.6.5.ebuild
+++ b/app-misc/splitvt/splitvt-1.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/splitvt/splitvt-1.6.5.ebuild,v 1.7 2002/10/04 04:57:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/splitvt/splitvt-1.6.5.ebuild,v 1.8 2002/10/17 00:24:16 vapier Exp $
S=${WORKDIR}/${P}
SRC_URI="http://www.devolution.com/~slouken/projects/${PN}/${P}.tar.gz"
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
KEYWORDS="x86 ppc"
DEPEND=">=sys-libs/ncurses-5.2"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
diff --git a/app-misc/sqeed/sqeed-0.2.2.ebuild b/app-misc/sqeed/sqeed-0.2.2.ebuild
index 44e08eae911d..2ca6b69f3936 100644
--- a/app-misc/sqeed/sqeed-0.2.2.ebuild
+++ b/app-misc/sqeed/sqeed-0.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sqeed/sqeed-0.2.2.ebuild,v 1.4 2002/10/04 04:57:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sqeed/sqeed-0.2.2.ebuild,v 1.5 2002/10/17 00:24:16 vapier Exp $
S="${WORKDIR}/${P}"
DESCRIPTION="A simple bash script holding a database with notes."
@@ -12,13 +12,9 @@ LICENSE="GPL-2"
KEYWORDS="x86"
DEPEND="sys-apps/bash"
+RDEPEND="${DEPEND}"
-src_compile() {
- echo "Nothing to compile for ${P}."
-}
-
-src_install () {
-
+src_install() {
insinto /etc/
doins ${FILESDIR}/sqeed.data
fperms 666 /etc/sqeed.data
diff --git a/app-misc/todo-manager-bronze/todo-manager-bronze-20020711.ebuild b/app-misc/todo-manager-bronze/todo-manager-bronze-20020711.ebuild
index 9bd779b3863b..fb76e59f1b07 100644
--- a/app-misc/todo-manager-bronze/todo-manager-bronze-20020711.ebuild
+++ b/app-misc/todo-manager-bronze/todo-manager-bronze-20020711.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/todo-manager-bronze/todo-manager-bronze-20020711.ebuild,v 1.4 2002/10/04 04:57:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/todo-manager-bronze/todo-manager-bronze-20020711.ebuild,v 1.5 2002/10/17 00:24:16 vapier Exp $
S="${WORKDIR}/${PN}"
DESCRIPTION="A task manager."
@@ -13,6 +13,7 @@ KEYWORDS="x86"
DEPEND="dev-lang/python
dev-lang/tk"
+RDEPEND="${DEPEND}"
src_compile() {
python setup.py clean || die
diff --git a/app-misc/toshiba-utils/toshiba-utils-2.0.1-r1.ebuild b/app-misc/toshiba-utils/toshiba-utils-2.0.1-r1.ebuild
index 544908883c3e..a3a96f213c5a 100644
--- a/app-misc/toshiba-utils/toshiba-utils-2.0.1-r1.ebuild
+++ b/app-misc/toshiba-utils/toshiba-utils-2.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/toshiba-utils/toshiba-utils-2.0.1-r1.ebuild,v 1.4 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/toshiba-utils/toshiba-utils-2.0.1-r1.ebuild,v 1.5 2002/10/17 00:24:16 vapier Exp $
IUSE="X gtk"
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
KEYWORDS="x86 -ppc -sparc -sparc64"
DEPEND="gtk? ( =x11-libs/gtk+-1* )"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A} ; cd ${S}
diff --git a/app-misc/uptimed/uptimed-0.2.0-r1.ebuild b/app-misc/uptimed/uptimed-0.2.0-r1.ebuild
index 600957de1bf2..415995300b31 100644
--- a/app-misc/uptimed/uptimed-0.2.0-r1.ebuild
+++ b/app-misc/uptimed/uptimed-0.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/uptimed/uptimed-0.2.0-r1.ebuild,v 1.3 2002/08/30 15:51:02 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/uptimed/uptimed-0.2.0-r1.ebuild,v 1.4 2002/10/17 00:24:16 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Standard informational utilities and process-handling tools"
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
KEYWORDS="x86"
DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
diff --git a/app-misc/vlock/vlock-1.3-r1.ebuild b/app-misc/vlock/vlock-1.3-r1.ebuild
index ddad40278361..fd5d15b4436f 100644
--- a/app-misc/vlock/vlock-1.3-r1.ebuild
+++ b/app-misc/vlock/vlock-1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/vlock/vlock-1.3-r1.ebuild,v 1.6 2002/10/04 04:58:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/vlock/vlock-1.3-r1.ebuild,v 1.7 2002/10/17 00:24:16 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A console screen locker"
@@ -12,14 +12,13 @@ LICENSE="GPL-2"
KEYWORDS="x86 ppc alpha"
DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
src_compile() {
- cd ${S}
emake RPM_OPT_FLAGS="${CFLAGS}" || die "emake failed"
}
-src_install () {
- cd ${S}
+src_install() {
dobin vlock
# Setuid root is required to unlock a screen with root's password.
# This is "safe" because vlock drops privs ASAP; read the README
diff --git a/app-misc/vlock/vlock-1.3.ebuild b/app-misc/vlock/vlock-1.3.ebuild
index 8e3ede6b6f87..850a98cbfef7 100644
--- a/app-misc/vlock/vlock-1.3.ebuild
+++ b/app-misc/vlock/vlock-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/vlock/vlock-1.3.ebuild,v 1.4 2002/10/04 04:58:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/vlock/vlock-1.3.ebuild,v 1.5 2002/10/17 00:24:16 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A console screen locker"
@@ -12,14 +12,13 @@ LICENSE="GPL-2"
KEYWORDS="x86"
DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
src_compile() {
- cd ${S}
make RPM_OPT_FLAGS="${CFLAGS}" || die
}
-src_install () {
- cd ${S}
+src_install() {
dobin vlock
doman vlock.1
dodoc COPYING README
diff --git a/app-misc/worker/worker-2.3.1.ebuild b/app-misc/worker/worker-2.3.1.ebuild
index c79aed329ee1..7e0a9a57cedc 100644
--- a/app-misc/worker/worker-2.3.1.ebuild
+++ b/app-misc/worker/worker-2.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/worker/worker-2.3.1.ebuild,v 1.4 2002/10/04 04:58:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/worker/worker-2.3.1.ebuild,v 1.5 2002/10/17 00:24:16 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Worker Filemanager: Amiga Directory Opus 4 clone."
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
KEYWORDS="x86"
DEPEND="virtual/x11"
+RDEPEND="${DEPEND}"
src_compile() {
econf || die
diff --git a/app-misc/xclip/xclip-0.05.ebuild b/app-misc/xclip/xclip-0.05.ebuild
index 342cfc6ada8b..1d14fc55af92 100644
--- a/app-misc/xclip/xclip-0.05.ebuild
+++ b/app-misc/xclip/xclip-0.05.ebuild
@@ -1,30 +1,27 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xclip/xclip-0.05.ebuild,v 1.4 2002/10/04 04:58:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xclip/xclip-0.05.ebuild,v 1.5 2002/10/17 00:24:16 vapier Exp $
S=${WORKDIR}/xclip
-DESCRIPTION="Command-line utility to read data from standard in and
- place it in an X selection for pasting into X applications."
+DESCRIPTION="Command-line utility to read data from standard in and place it in an X selection for pasting into X applications."
SRC_URI="http://people.debian.org/~kims/xclip/${P}.tar.gz"
-HOMEPAGE="http://people.debian.org/~kims/xclip"
+HOMEPAGE="http://people.debian.org/~kims/xclip/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
DEPEND="virtual/x11"
+RDEPEND="${DEPEND}"
src_compile() {
-
xmkmf || die
make || die
-
}
src_install () {
-
make DESTDIR=${D} install || die
make DESTDIR=${D} install.man || die
dodoc README INSTALL CHANGES
-
}
+
diff --git a/app-misc/xclip/xclip-0.08.ebuild b/app-misc/xclip/xclip-0.08.ebuild
index fe15d7a96705..0ef144a7e034 100644
--- a/app-misc/xclip/xclip-0.08.ebuild
+++ b/app-misc/xclip/xclip-0.08.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xclip/xclip-0.08.ebuild,v 1.4 2002/10/04 04:58:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xclip/xclip-0.08.ebuild,v 1.5 2002/10/17 00:24:16 vapier Exp $
S=${WORKDIR}/xclip
-DESCRIPTION="Command-line utility to read data from standard in and
- place it in an X selection for pasting into X applications."
+DESCRIPTION="Command-line utility to read data from standard in and place it in an X selection for pasting into X applications."
SRC_URI="http://people.debian.org/~kims/xclip/${P}.tar.gz"
-HOMEPAGE="http://people.debian.org/~kims/xclip"
+HOMEPAGE="http://people.debian.org/~kims/xclip/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
DEPEND="virtual/x11"
+RDEPEND="${DEPEND}"
src_compile() {
xmkmf || die
diff --git a/app-misc/xlockmore/xlockmore-5.04.ebuild b/app-misc/xlockmore/xlockmore-5.04.ebuild
index 95f2ce8525b4..d30a36c6e4e4 100644
--- a/app-misc/xlockmore/xlockmore-5.04.ebuild
+++ b/app-misc/xlockmore/xlockmore-5.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/xlockmore-5.04.ebuild,v 1.6 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/xlockmore-5.04.ebuild,v 1.7 2002/10/17 00:27:13 vapier Exp $
IUSE="nas esd motif opengl truetype gtk pam"
@@ -21,6 +21,7 @@ DEPEND="virtual/x11
esd? ( media-sound/esound )
motif? ( >=x11-libs/openmotif-2.1.30-r1 )
gtk? ( x11-libs/gtk+ )"
+RDEPEND="${DEPEND}"
src_compile() {
local myconf
diff --git a/app-misc/xplore/xplore-1.1-r1.ebuild b/app-misc/xplore/xplore-1.1-r1.ebuild
index 209b924e98e4..64eabe7cc871 100644
--- a/app-misc/xplore/xplore-1.1-r1.ebuild
+++ b/app-misc/xplore/xplore-1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xplore/xplore-1.1-r1.ebuild,v 1.4 2002/10/04 04:58:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xplore/xplore-1.1-r1.ebuild,v 1.5 2002/10/17 00:27:13 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="motif file manager for X."
@@ -13,10 +13,9 @@ KEYWORDS="x86"
DEPEND="virtual/x11
>=x11-libs/openmotif-2.1.30-r1"
-
+RDEPEND="${DEPEND}"
src_compile() {
-
#Fix Xplore.tmpl so installation is to /usr instead of /usr/X11R6
#Note: LIBDIR is used to point to X11 tree.
cp Xplore.tmpl Xplore.tmpl.orig
@@ -27,11 +26,9 @@ src_compile() {
xmkmf -a || die "xmkmf Makefile creation failed"
emake || die "Parallel make failed."
-
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die "Installation failed"
dodoc COPYING ChangeLog INSTALL README TODO
}
diff --git a/app-misc/xplore/xplore-1.1e.ebuild b/app-misc/xplore/xplore-1.1e.ebuild
index bfc5c2c1a1d4..fd974528fafc 100644
--- a/app-misc/xplore/xplore-1.1e.ebuild
+++ b/app-misc/xplore/xplore-1.1e.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xplore/xplore-1.1e.ebuild,v 1.4 2002/10/04 04:58:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xplore/xplore-1.1e.ebuild,v 1.5 2002/10/17 00:27:13 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="motif file manager for X."
@@ -13,6 +13,7 @@ KEYWORDS="x86"
DEPEND="virtual/x11
>=x11-libs/openmotif-2.1.30-r1"
+RDEPEND="${DEPEND}"
src_compile() {
#Fix Xplore.tmpl so installation is to /usr instead of /usr/X11R6
@@ -27,7 +28,7 @@ src_compile() {
emake || die "Parallel make failed."
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "Installation failed"
dodoc COPYING ChangeLog INSTALL README TODO
}
diff --git a/app-misc/xsnap/xsnap-1.3.ebuild b/app-misc/xsnap/xsnap-1.3.ebuild
index c2a13ea8b06c..c6b9ef21a560 100644
--- a/app-misc/xsnap/xsnap-1.3.ebuild
+++ b/app-misc/xsnap/xsnap-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xsnap/xsnap-1.3.ebuild,v 1.6 2002/10/04 04:58:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xsnap/xsnap-1.3.ebuild,v 1.7 2002/10/17 00:27:13 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Program to interactively take a 'snapshot' of a region of
@@ -13,13 +13,14 @@ LICENSE="BSD"
KEYWORDS="x86 ppc"
DEPEND="virtual/x11"
+RDEPEND="${DEPEND}"
src_compile() {
xmkmf || die
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
make DESTDIR=${D} install.man || die
dodoc README INSTALL AUTHORS
diff --git a/app-misc/xtrlock/xtrlock-2.0.ebuild b/app-misc/xtrlock/xtrlock-2.0.ebuild
index 08de06ce1883..25381e5e6d13 100644
--- a/app-misc/xtrlock/xtrlock-2.0.ebuild
+++ b/app-misc/xtrlock/xtrlock-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xtrlock/xtrlock-2.0.ebuild,v 1.5 2002/10/04 04:58:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xtrlock/xtrlock-2.0.ebuild,v 1.6 2002/10/17 00:27:13 vapier Exp $
MY_P=${PN}_${PV}-6
S=${WORKDIR}/${P}
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
KEYWORDS="x86"
DEPEND="virtual/x11"
+RDEPEND="${DEPEND}"
src_compile() {
xmkmf || die
@@ -20,7 +21,7 @@ src_compile() {
make CFLAGS="${CFLAGS} -DSHADOW_PWD" xtrlock || die
}
-src_install () {
+src_install() {
dobin xtrlock
chmod u+s ${D}/usr/bin/xtrlock
mv xtrlock.man xtrlock.1
diff --git a/app-misc/zisofs-tools/zisofs-tools-1.0.3.ebuild b/app-misc/zisofs-tools/zisofs-tools-1.0.3.ebuild
index 502673fad231..a1d896c04179 100644
--- a/app-misc/zisofs-tools/zisofs-tools-1.0.3.ebuild
+++ b/app-misc/zisofs-tools/zisofs-tools-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/zisofs-tools/zisofs-tools-1.0.3.ebuild,v 1.3 2002/10/04 04:58:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/zisofs-tools/zisofs-tools-1.0.3.ebuild,v 1.4 2002/10/17 00:27:13 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="User utilities for zisofs"
@@ -8,6 +8,7 @@ HOMEPAGE="http://www.kernel.org/pub/linux/utils/fs/zisofs/"
SRC_URI="http://www.kernel.org/pub/linux/utils/fs/zisofs/${P}.tar.bz2"
DEPEND=">=sys-libs/zlib-1.1.4"
+RDEPEND="${DEPEND}"
SLOT="0"
LICENSE="GPL-2"