summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuval Yaari <yuval@gentoo.org>2008-04-28 23:23:46 +0000
committerYuval Yaari <yuval@gentoo.org>2008-04-28 23:23:46 +0000
commit56617c92d6a22a3967a3806b55496f2f59daead6 (patch)
treedab948db21919abcfb950e6bd80f1e2d161da46b /dev-perl/libwww-perl
parentuse variable instead of fixed string so I won't continually forget to adjust ... (diff)
downloadhistorical-56617c92d6a22a3967a3806b55496f2f59daead6.tar.gz
historical-56617c92d6a22a3967a3806b55496f2f59daead6.tar.bz2
historical-56617c92d6a22a3967a3806b55496f2f59daead6.zip
Version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog9
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.812.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index 37b055e3577c..bac4a3d80f4a 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/libwww-perl
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.80 2007/05/12 05:10:44 kumba Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.81 2008/04/28 23:22:51 yuval Exp $
+
+*libwww-perl-5.812 (28 Apr 2008)
+
+ 28 Apr 2008; Yuval Yaari <yuval@gentoo.org> +libwww-perl-5.812.ebuild:
+ Version bump
12 May 2007; Joshua Kinard <kumba@gentoo.org> libwww-perl-5.805.ebuild:
Stable on mips.
diff --git a/dev-perl/libwww-perl/libwww-perl-5.812.ebuild b/dev-perl/libwww-perl/libwww-perl-5.812.ebuild
new file mode 100644
index 000000000000..c4b3e93132e7
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.812.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.812.ebuild,v 1.1 2008/04/28 23:22:51 yuval Exp $
+
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+SRC_URI="mirror://cpan/authors/id/G/GA/GAAS/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~gaas/${P}/"
+IUSE="ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="virtual/perl-libnet
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=virtual/perl-Digest-MD5-2.12
+ dev-perl/HTML-Tree
+ >=virtual/perl-MIME-Base64-2.12
+ >=dev-perl/Compress-Zlib-1.10
+ ssl? ( dev-perl/Crypt-SSLeay )
+ dev-lang/perl"
+
+src_compile() {
+ echo "y" | perl-module_src_compile
+}
+
+src_install() {
+ perl-module_src_install
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+}