summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/libwww-perl/libwww-perl-5.812.ebuild')
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.812.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/libwww-perl/libwww-perl-5.812.ebuild b/dev-perl/libwww-perl/libwww-perl-5.812.ebuild
new file mode 100644
index 000000000000..c4b3e93132e7
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.812.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.812.ebuild,v 1.1 2008/04/28 23:22:51 yuval Exp $
+
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+SRC_URI="mirror://cpan/authors/id/G/GA/GAAS/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~gaas/${P}/"
+IUSE="ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="virtual/perl-libnet
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=virtual/perl-Digest-MD5-2.12
+ dev-perl/HTML-Tree
+ >=virtual/perl-MIME-Base64-2.12
+ >=dev-perl/Compress-Zlib-1.10
+ ssl? ( dev-perl/Crypt-SSLeay )
+ dev-lang/perl"
+
+src_compile() {
+ echo "y" | perl-module_src_compile
+}
+
+src_install() {
+ perl-module_src_install
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+}