summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-08 02:19:24 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-08 02:19:24 +0000
commitb31f9d466df90dfbde2747054af5f18a64009532 (patch)
tree5e583a8185e9c931a2786356d4f5bc8b7810df48 /dev-lisp
parentclean up and unmask for x86 (diff)
downloadhistorical-b31f9d466df90dfbde2747054af5f18a64009532.tar.gz
historical-b31f9d466df90dfbde2747054af5f18a64009532.tar.bz2
historical-b31f9d466df90dfbde2747054af5f18a64009532.zip
clean up and unmask for x86
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-asdf/Manifest5
-rw-r--r--dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild58
-rw-r--r--dev-lisp/cl-asdf/files/digest-cl-asdf-1.77.21
3 files changed, 14 insertions, 50 deletions
diff --git a/dev-lisp/cl-asdf/Manifest b/dev-lisp/cl-asdf/Manifest
index 2734fe9219ba..7882f860590e 100644
--- a/dev-lisp/cl-asdf/Manifest
+++ b/dev-lisp/cl-asdf/Manifest
@@ -1,6 +1,5 @@
-MD5 3b46a5ad19cb0e36e2c42cf394f31853 ChangeLog 546
+MD5 66a666d1faea1044344ff8ffd545f76d ChangeLog 659
MD5 295c0a110eb80901e2c61c97d0f8b633 cl-asdf-1.73b.ebuild 2101
-MD5 e9341f0ffe23d17d46fd037219e47d92 cl-asdf-1.77.2.ebuild 978
-MD5 d5cf3a8f88bf98f8fb5c6e61d67835d1 cl-asdf-1.77.2.ebuild.~1.2.~ 2107
+MD5 a936ea13e9215f80652fb32293606826 cl-asdf-1.77.2.ebuild 977
MD5 da47e17802d933cda8e74bd9f7351645 files/digest-cl-asdf-1.73b 64
MD5 4e53222358707bfedc32e63d26507894 files/digest-cl-asdf-1.77.2 137
diff --git a/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild b/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild
index 47f66f0adb67..42b752bb9212 100644
--- a/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild
+++ b/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild
@@ -1,22 +1,29 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild,v 1.2 2003/09/06 22:35:54 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild,v 1.3 2003/10/08 02:19:22 mkennedy Exp $
+
+DEB_PV=1
DESCRIPTION="Another System Definition Facility for Common Lisp"
HOMEPAGE="http://packages.debian.org/unstable/devel/cl-asdf.html"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/${PN}_${PV}.orig.tar.gz"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/${PN}_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}-${DEB_PV}.diff.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="x86 ~sparc"
IUSE=""
DEPEND=""
S=${WORKDIR}/${P}
+src_unpack() {
+ unpack ${A}
+ epatch cl-asdf_${PV}-${DEB_PV}.diff
+}
+
src_install() {
insinto /usr/share/common-lisp/source/asdf
doins asdf.lisp wild-modules.lisp
-
dodoc LICENSE README
insinto /usr/share/doc/${P}/examples
doins test/*
@@ -27,46 +34,3 @@ pkg_postinst() {
/usr/sbin/clc-reregister-all-impl
fi
}
-
-
-### from debian cl-clan.postinst:
-
-# #!/bin/sh
-
-# set -e
-
-# pkg=cclan
-
-# # summary of how this script can be called:
-# # * <postinst> `configure' <most-recently-configured-version>
-# # * <old-postinst> `abort-upgrade' <new version>
-# # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
-# # <new-version>
-# # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
-# # <failed-install-package> <version> `removing'
-# # <conflicting-package> <version>
-# # for details, see http://www.debian.org/doc/debian-policy/ or
-# # the debian-policy package
-# #
-# # quoting from the policy:
-# # Any necessary prompting should almost always be confined to the
-# # post-installation script, and should be protected with a conditional
-# # so that unnecessary prompting doesn't happen if a package's
-# # installation fails and the `postinst' is called with `abort-upgrade',
-# # `abort-remove' or `abort-deconfigure'.
-
-# case "$1" in
-# configure)
-# /usr/sbin/register-common-lisp-source $pkg
-# ;;
-# abort-upgrade|abort-remove|abort-deconfigure)
-# ;;
-# *)
-# echo "postinst called with unknown argument \`$1'" >&2
-# exit 1
-# ;;
-# esac
-
-# #DEBHELPER#
-
-# exit 0
diff --git a/dev-lisp/cl-asdf/files/digest-cl-asdf-1.77.2 b/dev-lisp/cl-asdf/files/digest-cl-asdf-1.77.2
index a72e1d27a664..365effee165b 100644
--- a/dev-lisp/cl-asdf/files/digest-cl-asdf-1.77.2
+++ b/dev-lisp/cl-asdf/files/digest-cl-asdf-1.77.2
@@ -1 +1,2 @@
MD5 dc76d07b025853bc76bd5496914bdfc3 cl-asdf_1.77.2.orig.tar.gz 40084
+MD5 1092d8937b278ae7b0c534c1581f0caf cl-asdf_1.77.2-1.diff.gz 4762