summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild')
-rw-r--r--dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild58
1 files changed, 11 insertions, 47 deletions
diff --git a/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild b/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild
index 47f66f0adb67..42b752bb9212 100644
--- a/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild
+++ b/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild
@@ -1,22 +1,29 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild,v 1.2 2003/09/06 22:35:54 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild,v 1.3 2003/10/08 02:19:22 mkennedy Exp $
+
+DEB_PV=1
DESCRIPTION="Another System Definition Facility for Common Lisp"
HOMEPAGE="http://packages.debian.org/unstable/devel/cl-asdf.html"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/${PN}_${PV}.orig.tar.gz"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/${PN}_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}-${DEB_PV}.diff.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="x86 ~sparc"
IUSE=""
DEPEND=""
S=${WORKDIR}/${P}
+src_unpack() {
+ unpack ${A}
+ epatch cl-asdf_${PV}-${DEB_PV}.diff
+}
+
src_install() {
insinto /usr/share/common-lisp/source/asdf
doins asdf.lisp wild-modules.lisp
-
dodoc LICENSE README
insinto /usr/share/doc/${P}/examples
doins test/*
@@ -27,46 +34,3 @@ pkg_postinst() {
/usr/sbin/clc-reregister-all-impl
fi
}
-
-
-### from debian cl-clan.postinst:
-
-# #!/bin/sh
-
-# set -e
-
-# pkg=cclan
-
-# # summary of how this script can be called:
-# # * <postinst> `configure' <most-recently-configured-version>
-# # * <old-postinst> `abort-upgrade' <new version>
-# # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
-# # <new-version>
-# # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
-# # <failed-install-package> <version> `removing'
-# # <conflicting-package> <version>
-# # for details, see http://www.debian.org/doc/debian-policy/ or
-# # the debian-policy package
-# #
-# # quoting from the policy:
-# # Any necessary prompting should almost always be confined to the
-# # post-installation script, and should be protected with a conditional
-# # so that unnecessary prompting doesn't happen if a package's
-# # installation fails and the `postinst' is called with `abort-upgrade',
-# # `abort-remove' or `abort-deconfigure'.
-
-# case "$1" in
-# configure)
-# /usr/sbin/register-common-lisp-source $pkg
-# ;;
-# abort-upgrade|abort-remove|abort-deconfigure)
-# ;;
-# *)
-# echo "postinst called with unknown argument \`$1'" >&2
-# exit 1
-# ;;
-# esac
-
-# #DEBHELPER#
-
-# exit 0