summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-17 18:18:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-17 18:18:21 +0000
commit77eaefe8d3b8c8adca9211181959e3b8980d743b (patch)
tree2ce7e0ee836ee75136cf6ab68480a4fb5b32e55b /dev-libs/libxml2/libxml2-2.7.7.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-77eaefe8d3b8c8adca9211181959e3b8980d743b.tar.gz
historical-77eaefe8d3b8c8adca9211181959e3b8980d743b.tar.bz2
historical-77eaefe8d3b8c8adca9211181959e3b8980d743b.zip
Use 'python_pkg_setup' instead of 'python_execute_function -f -q'.
Use 'python_clean_installation_image' instead of 'python_clean_sitedirs'. Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libxml2/libxml2-2.7.7.ebuild')
-rw-r--r--dev-libs/libxml2/libxml2-2.7.7.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/dev-libs/libxml2/libxml2-2.7.7.ebuild b/dev-libs/libxml2/libxml2-2.7.7.ebuild
index 44a6f6de4355..847aba78aa3b 100644
--- a/dev-libs/libxml2/libxml2-2.7.7.ebuild
+++ b/dev-libs/libxml2/libxml2-2.7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.7.ebuild,v 1.8 2010/05/14 03:59:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.7.ebuild,v 1.9 2010/05/17 18:18:21 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -34,6 +34,12 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
src_unpack() {
# ${A} isn't used to avoid unpacking of test tarballs into $WORKDIR,
# as they are needed as tarballs in ${S}/xstc instead and not unpacked
@@ -81,15 +87,7 @@ src_configure() {
# filter seemingly problematic CFLAGS (#26320)
filter-flags -fprefetch-loop-arrays -funroll-loops
- # This ebuild is critical during preparation of a stage1 build.
- # If the Python binary is not present in $ROOT, python_execute_function
- # returns successfully but silently, WITHOUT running the command (with
- # disasterous side-effects).
- if use python; then
- python_execute_function -f -q econf ${myconf}
- else
- econf ${myconf}
- fi
+ econf ${myconf}
}
src_compile() {
@@ -131,7 +129,7 @@ src_install() {
}
python_execute_function -s --source-dir python installation
- python_clean_sitedirs
+ python_clean_installation_image
fi
rm -rf "${D}"/usr/share/doc/${P}