summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-17 18:18:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-17 18:18:21 +0000
commit77eaefe8d3b8c8adca9211181959e3b8980d743b (patch)
tree2ce7e0ee836ee75136cf6ab68480a4fb5b32e55b /dev-libs/libxml2
parentAutomated update of use.local.desc (diff)
downloadhistorical-77eaefe8d3b8c8adca9211181959e3b8980d743b.tar.gz
historical-77eaefe8d3b8c8adca9211181959e3b8980d743b.tar.bz2
historical-77eaefe8d3b8c8adca9211181959e3b8980d743b.zip
Use 'python_pkg_setup' instead of 'python_execute_function -f -q'.
Use 'python_clean_installation_image' instead of 'python_clean_sitedirs'. Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/Manifest2
-rw-r--r--dev-libs/libxml2/libxml2-2.7.7.ebuild20
2 files changed, 10 insertions, 12 deletions
diff --git a/dev-libs/libxml2/Manifest b/dev-libs/libxml2/Manifest
index 3404fea04a5e..d250e3a88e96 100644
--- a/dev-libs/libxml2/Manifest
+++ b/dev-libs/libxml2/Manifest
@@ -7,6 +7,6 @@ DIST xsts-2002-01-16.tar.gz 6894439 RMD160 e8905fe1451a1c367b0104af24edca73bad1d
DIST xsts-2004-01-14.tar.gz 2761085 RMD160 faff2d7826e47ae9968564bc83dab1b54c5e4bf6 SHA1 5896c2aa2cda464246306c5cf0577ed506eefaab SHA256 09bdf9f81f381ebf9bc158a9472e498e896f7a02eb7461146e9abe1b9493ca17
EBUILD libxml2-2.7.3-r2.ebuild 4457 RMD160 a88ba8bf4844dee50a72ea5f1a0d6c6a5b55f8a4 SHA1 9e55595b368a863bd7cf4b96f272f1ed0da3faf7 SHA256 f7cf9157bfd0afe55edff5365980939edf5fa07c5a9fb72cff7b196f89b809ed
EBUILD libxml2-2.7.6.ebuild 3932 RMD160 c87a141c90429a28eea755271fe86e23f688fcac SHA1 91b0c0924901b411c91ed64ecded962ffc892213 SHA256 686a385c960c4b6782d932d91ef81cb6ee73c69661700243058e1a2af3853ae4
-EBUILD libxml2-2.7.7.ebuild 4979 RMD160 7f4479c98fa951d8640fca14b4e478db4bc352e9 SHA1 7f7f79ae8735db848c8d834d7f3ba42596a7c2bc SHA256 bd279bbaaf1bf2f75ceba7db1151faf0394b6deb273d1f0f416e05934d4bc6d5
+EBUILD libxml2-2.7.7.ebuild 4731 RMD160 18656065279d058a6e850132bd58b2bb2e5b07d0 SHA1 a117bfeb04621f8706abe50e58c984e9ee4c5c54 SHA256 fdfed48baf14a3225dd54d703f6f0ae22d6e5203114baa28f9100defcc982fc1
MISC ChangeLog 38932 RMD160 467df4c4cf6076256641d74c40021f81c2d62049 SHA1 168decc6777c979db6aa56b776edc9d55b05e9cd SHA256 6be8afc54531887fa6b756d993105b75d4b0748d1fb57eb57c9915c14b9da8c6
MISC metadata.xml 158 RMD160 c0e2bae8e91bb6be8922bac5e4f597302e06587e SHA1 38f78e9790bcd4382b4a49aa226aa6dda1d3a3d7 SHA256 3a7dbca0fdc557de69783e0663e2d76ddab129ea8a19b2d0ef6d3e5d1b947ce1
diff --git a/dev-libs/libxml2/libxml2-2.7.7.ebuild b/dev-libs/libxml2/libxml2-2.7.7.ebuild
index 44a6f6de4355..847aba78aa3b 100644
--- a/dev-libs/libxml2/libxml2-2.7.7.ebuild
+++ b/dev-libs/libxml2/libxml2-2.7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.7.ebuild,v 1.8 2010/05/14 03:59:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.7.ebuild,v 1.9 2010/05/17 18:18:21 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -34,6 +34,12 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
src_unpack() {
# ${A} isn't used to avoid unpacking of test tarballs into $WORKDIR,
# as they are needed as tarballs in ${S}/xstc instead and not unpacked
@@ -81,15 +87,7 @@ src_configure() {
# filter seemingly problematic CFLAGS (#26320)
filter-flags -fprefetch-loop-arrays -funroll-loops
- # This ebuild is critical during preparation of a stage1 build.
- # If the Python binary is not present in $ROOT, python_execute_function
- # returns successfully but silently, WITHOUT running the command (with
- # disasterous side-effects).
- if use python; then
- python_execute_function -f -q econf ${myconf}
- else
- econf ${myconf}
- fi
+ econf ${myconf}
}
src_compile() {
@@ -131,7 +129,7 @@ src_install() {
}
python_execute_function -s --source-dir python installation
- python_clean_sitedirs
+ python_clean_installation_image
fi
rm -rf "${D}"/usr/share/doc/${P}