summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-04-02 19:15:09 +0000
committerJon Portnoy <avenj@gentoo.org>2004-04-02 19:15:09 +0000
commit68a14c8ba294418adada19c756c1427b57b12936 (patch)
treebdfa076d55dad88229b7ea63972f0dea1cedd652 /app-text/aspell
parentVersion bump (diff)
downloadhistorical-68a14c8ba294418adada19c756c1427b57b12936.tar.gz
historical-68a14c8ba294418adada19c756c1427b57b12936.tar.bz2
historical-68a14c8ba294418adada19c756c1427b57b12936.zip
Fix ncurses/gpm support, bug 46432
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog7
-rw-r--r--app-text/aspell/Manifest8
-rw-r--r--app-text/aspell/aspell-0.50.3.ebuild9
-rw-r--r--app-text/aspell/aspell-0.50.4.1.ebuild9
-rw-r--r--app-text/aspell/aspell-0.50.5.ebuild8
5 files changed, 28 insertions, 13 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index ee5326f41fb4..330235e65248 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/aspell
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.32 2004/04/02 18:58:52 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.33 2004/04/02 19:15:09 avenj Exp $
+
+ 02 Apr 2004; Jon Portnoy <avenj@gentoo.org> aspell-0.50.5.ebuild,
+ aspell-0.50.4.1.ebuild, aspell-0.50.3.ebuild :
+ Added LDFLAGS hack to make sure gpm gets linked in with USE=gpm.
+ This is needed when ncurses is built with gpm support. #46432
02 Apr 2004; Jon Portnoy <avenj@gentoo.org> aspell-0.50.5.ebuild :
AMD64 keywords.
diff --git a/app-text/aspell/Manifest b/app-text/aspell/Manifest
index 95e1b6be0395..e9c5ebc81607 100644
--- a/app-text/aspell/Manifest
+++ b/app-text/aspell/Manifest
@@ -1,7 +1,7 @@
-MD5 1d88b64c27272ec92eb8bfdce9ba4a98 ChangeLog 6201
-MD5 e04e4e87f5d0511c429244ea515c24f7 aspell-0.50.3.ebuild 1481
-MD5 4c7f300a1010d5beb313655b806adf74 aspell-0.50.4.1.ebuild 1432
-MD5 6031047344384c2e89c30ddf02949e49 aspell-0.50.5.ebuild 1542
+MD5 517e2c7feee3d83e331f3d8cc9d85332 ChangeLog 6450
+MD5 7bad419d2ac013527a730c842db78aa3 aspell-0.50.3.ebuild 1540
+MD5 a27612f9dae534f74bf8bce58a030bc8 aspell-0.50.4.1.ebuild 1495
+MD5 3d3ebd9e8d408c44a6115dfedd61590b aspell-0.50.5.ebuild 1605
MD5 eb03775ece62e57725480e782cd84ee8 metadata.xml 162
MD5 4fa550930c5e5fb38177ac9f77619891 files/01-gcc3.3-assert.patch 309
MD5 f956a4b48687a0823d0d5d7608b567e9 files/02-gcc3.3-constcast.patch 453
diff --git a/app-text/aspell/aspell-0.50.3.ebuild b/app-text/aspell/aspell-0.50.3.ebuild
index 43a4edd02475..ffb1a094a4bb 100644
--- a/app-text/aspell/aspell-0.50.3.ebuild
+++ b/app-text/aspell/aspell-0.50.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.3.ebuild,v 1.11 2003/09/05 22:37:21 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.3.ebuild,v 1.12 2004/04/02 19:15:09 avenj Exp $
inherit libtool
@@ -8,17 +8,20 @@ DESCRIPTION="A spell checker replacement for ispell"
HOMEPAGE="http://aspell.net/"
SRC_URI="ftp://ftp.gnu.org/gnu/aspell/${P}.tar.gz"
+IUSE="gpm"
SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="x86 ppc sparc alpha ~mips hppa amd64"
-DEPEND=">=sys-libs/ncurses-5.2"
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
pkg_setup() {
if [ ${ARCH} = "ppc" ] ; then
CXXFLAGS="-O2 -fsigned-char"
CFLAGS=${CXXFLAGS}
fi
+ use gpm && LDFLAGS="-lgpm"
}
src_compile() {
diff --git a/app-text/aspell/aspell-0.50.4.1.ebuild b/app-text/aspell/aspell-0.50.4.1.ebuild
index 08987cbc630b..b7fcda042488 100644
--- a/app-text/aspell/aspell-0.50.4.1.ebuild
+++ b/app-text/aspell/aspell-0.50.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.4.1.ebuild,v 1.5 2004/02/29 18:10:25 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.4.1.ebuild,v 1.6 2004/04/02 19:15:09 avenj Exp $
inherit libtool
@@ -8,17 +8,20 @@ DESCRIPTION="A spell checker replacement for ispell"
HOMEPAGE="http://aspell.net/"
SRC_URI="http://aspell.net/${P}.tar.gz"
+IUSE="gpm"
SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa -amd64 ia64"
-DEPEND=">=sys-libs/ncurses-5.2"
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
pkg_setup() {
if [ ${ARCH} = "ppc" ] ; then
CXXFLAGS="-O2 -fsigned-char"
CFLAGS=${CXXFLAGS}
fi
+ use gpm && LDFLAGS="-lgpm"
}
src_compile() {
diff --git a/app-text/aspell/aspell-0.50.5.ebuild b/app-text/aspell/aspell-0.50.5.ebuild
index 63cdc2ebe60f..f0596ee74a39 100644
--- a/app-text/aspell/aspell-0.50.5.ebuild
+++ b/app-text/aspell/aspell-0.50.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5.ebuild,v 1.5 2004/04/02 18:58:53 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5.ebuild,v 1.6 2004/04/02 19:15:09 avenj Exp $
inherit libtool
@@ -8,17 +8,21 @@ DESCRIPTION="A spell checker replacement for ispell"
HOMEPAGE="http://aspell.net/"
SRC_URI="http://aspell.net/${P}.tar.gz"
+IUSE="gpm"
+
SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ia64 s390"
-DEPEND=">=sys-libs/ncurses-5.2"
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
pkg_setup() {
if [ ${ARCH} = "ppc" ] ; then
CXXFLAGS="-O2 -fsigned-char"
CFLAGS=${CXXFLAGS}
fi
+ use gpm && LDFLAGS="-lgpm"
}
src_compile() {