summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-10-15 11:17:14 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-10-15 11:17:14 +0000
commitf05cc3581fa0199d92f43fe9615961c419638db6 (patch)
tree4fa5363dc61df8bbe9037a2179622ff47f09b869 /app-emulation/virtinst
parent(#189824) Add VNC widget for GTK+, based on the work of Jiri Tyr. This is a d... (diff)
downloadhistorical-f05cc3581fa0199d92f43fe9615961c419638db6.tar.gz
historical-f05cc3581fa0199d92f43fe9615961c419638db6.tar.bz2
historical-f05cc3581fa0199d92f43fe9615961c419638db6.zip
Adds some new features like remote access and OpenVZ (although the latter may only be at the libvirt level so far).
Package-Manager: portage-2.1.3.13
Diffstat (limited to 'app-emulation/virtinst')
-rw-r--r--app-emulation/virtinst/ChangeLog10
-rw-r--r--app-emulation/virtinst/files/digest-virtinst-0.300.13
-rw-r--r--app-emulation/virtinst/files/virtinst-0.300.1-nfs-check.patch12
-rw-r--r--app-emulation/virtinst/files/virtinst-0.300.1-remove-usb-tablet.patch96
-rw-r--r--app-emulation/virtinst/virtinst-0.300.1.ebuild25
5 files changed, 145 insertions, 1 deletions
diff --git a/app-emulation/virtinst/ChangeLog b/app-emulation/virtinst/ChangeLog
index cfbca610a682..89f55322d4ea 100644
--- a/app-emulation/virtinst/ChangeLog
+++ b/app-emulation/virtinst/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/virtinst
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.1 2007/06/10 06:07:02 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.2 2007/10/15 11:16:31 dberkholz Exp $
+
+*virtinst-0.300.1 (15 Oct 2007)
+
+ 15 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/virtinst-0.300.1-nfs-check.patch,
+ +files/virtinst-0.300.1-remove-usb-tablet.patch, +virtinst-0.300.1.ebuild:
+ Adds some new features like remote access and OpenVZ (although the latter
+ may only be at the libvirt level so far).
*virtinst-0.103.0 (10 Jun 2007)
diff --git a/app-emulation/virtinst/files/digest-virtinst-0.300.1 b/app-emulation/virtinst/files/digest-virtinst-0.300.1
new file mode 100644
index 000000000000..1d9dadfbd8fe
--- /dev/null
+++ b/app-emulation/virtinst/files/digest-virtinst-0.300.1
@@ -0,0 +1,3 @@
+MD5 0424cdd829fda57b7117782f367d4aec virtinst-0.300.1.tar.gz 96757
+RMD160 7a334a18bea44db4c383e0b7420cb144381256a4 virtinst-0.300.1.tar.gz 96757
+SHA256 58e812432685950e7179373a26219558f612ca459e461ee5874f84058dd97b40 virtinst-0.300.1.tar.gz 96757
diff --git a/app-emulation/virtinst/files/virtinst-0.300.1-nfs-check.patch b/app-emulation/virtinst/files/virtinst-0.300.1-nfs-check.patch
new file mode 100644
index 000000000000..a45bf1125f47
--- /dev/null
+++ b/app-emulation/virtinst/files/virtinst-0.300.1-nfs-check.patch
@@ -0,0 +1,12 @@
+diff -r 531b73491ac2 virtinst/DistroManager.py
+--- a/virtinst/DistroManager.py Wed Oct 10 14:24:48 2007 -0400
++++ b/virtinst/DistroManager.py Thu Oct 11 11:39:58 2007 -0400
+@@ -161,7 +161,7 @@ class MountedImageFetcher(ImageFetcher):
+ if tmpfile is not None:
+ os.unlink(tmpfile)
+ return True
+- except RuntimeError, e:
++ except Exception, e:
+ logging.debug("Cannot find file %s" % filename)
+ return False
+
diff --git a/app-emulation/virtinst/files/virtinst-0.300.1-remove-usb-tablet.patch b/app-emulation/virtinst/files/virtinst-0.300.1-remove-usb-tablet.patch
new file mode 100644
index 000000000000..1eeff1faa46d
--- /dev/null
+++ b/app-emulation/virtinst/files/virtinst-0.300.1-remove-usb-tablet.patch
@@ -0,0 +1,96 @@
+Only in virtinst-0.300.1.new: .coverage
+diff -rup virtinst-0.300.1.orig/tests/boot-fullyvirt-disk-block.xml virtinst-0.300.1.new/tests/boot-fullyvirt-disk-block.xml
+--- virtinst-0.300.1.orig/tests/boot-fullyvirt-disk-block.xml 2007-09-25 11:01:12.000000000 -0400
++++ virtinst-0.300.1.new/tests/boot-fullyvirt-disk-block.xml 2007-10-04 12:10:00.000000000 -0400
+@@ -28,7 +28,7 @@
+ </disk>
+
+
+- <input type='tablet' bus='usb'/>
++ <input type='mouse' bus='ps2'/>
+ <graphics type='sdl'/>
+ </devices>
+ </domain>
+diff -rup virtinst-0.300.1.orig/tests/boot-fullyvirt-disk-file.xml virtinst-0.300.1.new/tests/boot-fullyvirt-disk-file.xml
+--- virtinst-0.300.1.orig/tests/boot-fullyvirt-disk-file.xml 2007-09-25 11:01:12.000000000 -0400
++++ virtinst-0.300.1.new/tests/boot-fullyvirt-disk-file.xml 2007-10-04 12:10:17.000000000 -0400
+@@ -28,7 +28,7 @@
+ </disk>
+
+
+- <input type='tablet' bus='usb'/>
++ <input type='mouse' bus='ps2'/>
+ <graphics type='sdl'/>
+ </devices>
+ </domain>
+diff -rup virtinst-0.300.1.orig/tests/install-fullyvirt-disk-block.xml virtinst-0.300.1.new/tests/install-fullyvirt-disk-block.xml
+--- virtinst-0.300.1.orig/tests/install-fullyvirt-disk-block.xml 2007-09-25 11:01:12.000000000 -0400
++++ virtinst-0.300.1.new/tests/install-fullyvirt-disk-block.xml 2007-10-04 12:10:29.000000000 -0400
+@@ -29,7 +29,7 @@
+ </disk>
+
+
+- <input type='tablet' bus='usb'/>
++ <input type='mouse' bus='ps2'/>
+ <graphics type='sdl'/>
+ </devices>
+ </domain>
+diff -rup virtinst-0.300.1.orig/tests/install-fullyvirt-disk-file.xml virtinst-0.300.1.new/tests/install-fullyvirt-disk-file.xml
+--- virtinst-0.300.1.orig/tests/install-fullyvirt-disk-file.xml 2007-09-25 11:01:12.000000000 -0400
++++ virtinst-0.300.1.new/tests/install-fullyvirt-disk-file.xml 2007-10-04 12:10:37.000000000 -0400
+@@ -29,7 +29,7 @@
+ </disk>
+
+
+- <input type='tablet' bus='usb'/>
++ <input type='mouse' bus='ps2'/>
+ <graphics type='sdl'/>
+ </devices>
+ </domain>
+diff -rup virtinst-0.300.1.orig/virtinst/FullVirtGuest.py virtinst-0.300.1.new/virtinst/FullVirtGuest.py
+--- virtinst-0.300.1.orig/virtinst/FullVirtGuest.py 2007-09-25 11:01:12.000000000 -0400
++++ virtinst-0.300.1.new/virtinst/FullVirtGuest.py 2007-10-04 12:02:36.000000000 -0400
+@@ -27,6 +27,7 @@ class FullVirtGuest(Guest.XenGuest):
+ "acpi": True, \
+ "apic": True, \
+ "continue": False, \
++ "input": [ "mouse", "ps2"],
+ "variants": { "rhel2.1": { "label": "Red Hat Enterprise Linux 2.1", "distro": "rhel" }, \
+ "rhel3": { "label": "Red Hat Enterprise Linux 3", "distro": "rhel" }, \
+ "rhel4": { "label": "Red Hat Enterprise Linux 4", "distro": "rhel" }, \
+@@ -44,6 +45,7 @@ class FullVirtGuest(Guest.XenGuest):
+ "acpi": True, \
+ "apic": True, \
+ "continue": True, \
++ "input": [ "tablet", "usb"],
+ "variants": { "winxp": { "label": "Microsoft Windows XP", \
+ "acpi": False, \
+ "apic": False }, \
+@@ -58,6 +60,7 @@ class FullVirtGuest(Guest.XenGuest):
+ "acpi": True,
+ "apic": True,
+ "continue": False, \
++ "input": [ "mouse", "ps2"],
+ "variants": { "solaris9": { "label": "Sun Solaris 9" }, \
+ "solaris10": { "label": "Sun Solaris 10" }, \
+ "freebsd6": { "label": "Free BSD 6.x" }, \
+@@ -68,6 +71,7 @@ class FullVirtGuest(Guest.XenGuest):
+ "acpi": True,
+ "apic": True,
+ "continue": False,
++ "input": [ "mouse", "ps2"],
+ "variants": { "msdos": { "label": "MS-DOS", \
+ "acpi": False, \
+ "apic": False }, \
+@@ -161,7 +165,10 @@ class FullVirtGuest(Guest.XenGuest):
+ os_distro = property(get_os_distro)
+
+ def get_input_device(self):
+- return ("tablet", "usb")
++ if self.os_type is None or not FullVirtGuest.OS_TYPES.has_key(self.os_type):
++ return ("mouse", "ps2")
++ input = FullVirtGuest.OS_TYPES[self.os_type]["input"]
++ return (input[0], input[1])
+
+ def _get_features_xml(self):
+ ret = "<features>\n"
diff --git a/app-emulation/virtinst/virtinst-0.300.1.ebuild b/app-emulation/virtinst/virtinst-0.300.1.ebuild
new file mode 100644
index 000000000000..273d5326f5e9
--- /dev/null
+++ b/app-emulation/virtinst/virtinst-0.300.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.300.1.ebuild,v 1.1 2007/10/15 11:16:31 dberkholz Exp $
+
+inherit distutils rpm
+
+DESCRIPTION="Python modules for starting virtualized guest installations"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=">=app-emulation/libvirt-0.2.1
+ dev-python/urlgrabber"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ rpm_src_unpack
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-nfs-check.patch
+ epatch "${FILESDIR}"/${P}-remove-usb-tablet.patch
+
+}