summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/libvirt/ChangeLog9
-rw-r--r--app-emulation/libvirt/files/digest-libvirt-0.3.33
-rw-r--r--app-emulation/libvirt/libvirt-0.3.3.ebuild41
-rw-r--r--app-emulation/virt-manager/ChangeLog9
-rw-r--r--app-emulation/virt-manager/files/digest-virt-manager-0.5.13
-rw-r--r--app-emulation/virt-manager/virt-manager-0.5.1.ebuild56
-rw-r--r--app-emulation/virtinst/ChangeLog10
-rw-r--r--app-emulation/virtinst/files/digest-virtinst-0.300.13
-rw-r--r--app-emulation/virtinst/files/virtinst-0.300.1-nfs-check.patch12
-rw-r--r--app-emulation/virtinst/files/virtinst-0.300.1-remove-usb-tablet.patch96
-rw-r--r--app-emulation/virtinst/virtinst-0.300.1.ebuild25
11 files changed, 264 insertions, 3 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index b9a62ece2014..579d3aa0374b 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.7 2007/08/29 16:45:17 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.8 2007/10/15 11:16:02 dberkholz Exp $
+
+*libvirt-0.3.3 (15 Oct 2007)
+
+ 15 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +libvirt-0.3.3.ebuild:
+ Adds some new features like remote access and OpenVZ (although the latter
+ may only be at the libvirt level so far).
29 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing agriffis from metadata due to his retirement (see #182294 for
diff --git a/app-emulation/libvirt/files/digest-libvirt-0.3.3 b/app-emulation/libvirt/files/digest-libvirt-0.3.3
new file mode 100644
index 000000000000..db5781e24783
--- /dev/null
+++ b/app-emulation/libvirt/files/digest-libvirt-0.3.3
@@ -0,0 +1,3 @@
+MD5 583fa13938df63bd404cc1b7cf553874 libvirt-0.3.3.tar.gz 2525163
+RMD160 73023c90a5ed80ec06919a98824fc9e60a941f31 libvirt-0.3.3.tar.gz 2525163
+SHA256 f58c57148782f70f7ddf11da29bdf2df6f639edd77cdd38a5fa538044997f647 libvirt-0.3.3.tar.gz 2525163
diff --git a/app-emulation/libvirt/libvirt-0.3.3.ebuild b/app-emulation/libvirt/libvirt-0.3.3.ebuild
new file mode 100644
index 000000000000..e3069a2cbe88
--- /dev/null
+++ b/app-emulation/libvirt/libvirt-0.3.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.3.3.ebuild,v 1.1 2007/10/15 11:16:02 dberkholz Exp $
+
+DESCRIPTION="C toolkit to manipulate virtual machines"
+HOMEPAGE="http://www.libvirt.org/"
+SRC_URI="http://libvirt.org/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qemu xen"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses
+ dev-libs/libxml2
+ qemu? ( app-emulation/qemu )
+ xen? ( app-emulation/xen-tools )
+ dev-lang/python
+ sys-fs/sysfsutils"
+
+pkg_setup() {
+ if ! use qemu && ! use xen; then
+ local msg="You must enable one of these USE flags: qemu xen"
+ eerror "$msg"
+ die "$msg"
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_with qemu) \
+ $(use_with xen) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ mv ${D}/usr/share/doc/{${PN}-python*,${P}/python}
+}
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index 308118f09d6a..b2c1de69ff2f 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/virt-manager
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.3 2007/06/13 17:50:45 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.4 2007/10/15 11:17:14 dberkholz Exp $
+
+*virt-manager-0.5.1 (15 Oct 2007)
+
+ 15 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +virt-manager-0.5.1.ebuild:
+ Adds some new features like remote access and OpenVZ (although the latter
+ may only be at the libvirt level so far).
13 Jun 2007; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
Add xen herd, at rbu's request.
diff --git a/app-emulation/virt-manager/files/digest-virt-manager-0.5.1 b/app-emulation/virt-manager/files/digest-virt-manager-0.5.1
new file mode 100644
index 000000000000..06cd7bf1e4df
--- /dev/null
+++ b/app-emulation/virt-manager/files/digest-virt-manager-0.5.1
@@ -0,0 +1,3 @@
+MD5 e5022314bbe13881e2cc28d93f4994dd virt-manager-0.5.1.tar.gz 1772253
+RMD160 181fbb0ef1bfe20e7957f8650a8c1f999e8dc8a0 virt-manager-0.5.1.tar.gz 1772253
+SHA256 7afd369795ae11943d534847c9d7b3ee1002d88408c6d3840a4aa672c5e01f5c virt-manager-0.5.1.tar.gz 1772253
diff --git a/app-emulation/virt-manager/virt-manager-0.5.1.ebuild b/app-emulation/virt-manager/virt-manager-0.5.1.ebuild
new file mode 100644
index 000000000000..ec2016e422a7
--- /dev/null
+++ b/app-emulation/virt-manager/virt-manager-0.5.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.5.1.ebuild,v 1.1 2007/10/15 11:17:14 dberkholz Exp $
+
+# Stop gnome2.eclass from doing stuff on USE=debug
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="A graphical tool for administering virtual machines such as Xen"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=">=dev-python/pygtk-1.99.11
+ >=dev-python/gnome-python-1.99
+ >=app-emulation/libvirt-0.1.4
+ || ( dev-python/dbus-python >=sys-apps/dbus-0.61 )
+ >=gnome-base/gnome-keyring-0.4.9
+ >=dev-python/gnome-python-desktop-2.15
+ >=dev-libs/libxml2-2.6.23
+ >=app-emulation/virtinst-0.103
+ >=gnome-base/librsvg-2
+ >=x11-libs/vte-0.12.2
+ sys-apps/usermode
+ dev-python/rhpl
+ net-libs/gtk-vnc"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if ! built_with_use --missing false sys-apps/dbus python; then
+ if ! has_version dev-python/dbus-python; then
+ local msg="You must install dbus with USE=python or dbus-python."
+ eerror "$msg"
+ die "$msg"
+ fi
+ fi
+
+ if ! built_with_use dev-libs/libxml2 python; then
+ local msg="You must install libxml2 with USE=python."
+ eerror "$msg"
+ die "$msg"
+ fi
+
+ if ! built_with_use x11-libs/vte python; then
+ local msg="You must install vte with USE=python."
+ eerror "$msg"
+ die "$msg"
+ fi
+}
+
+#src_install() {
+# emake DESTDIR="${D}" install || die "emake install failed"
+#}
diff --git a/app-emulation/virtinst/ChangeLog b/app-emulation/virtinst/ChangeLog
index cfbca610a682..89f55322d4ea 100644
--- a/app-emulation/virtinst/ChangeLog
+++ b/app-emulation/virtinst/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/virtinst
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.1 2007/06/10 06:07:02 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.2 2007/10/15 11:16:31 dberkholz Exp $
+
+*virtinst-0.300.1 (15 Oct 2007)
+
+ 15 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/virtinst-0.300.1-nfs-check.patch,
+ +files/virtinst-0.300.1-remove-usb-tablet.patch, +virtinst-0.300.1.ebuild:
+ Adds some new features like remote access and OpenVZ (although the latter
+ may only be at the libvirt level so far).
*virtinst-0.103.0 (10 Jun 2007)
diff --git a/app-emulation/virtinst/files/digest-virtinst-0.300.1 b/app-emulation/virtinst/files/digest-virtinst-0.300.1
new file mode 100644
index 000000000000..1d9dadfbd8fe
--- /dev/null
+++ b/app-emulation/virtinst/files/digest-virtinst-0.300.1
@@ -0,0 +1,3 @@
+MD5 0424cdd829fda57b7117782f367d4aec virtinst-0.300.1.tar.gz 96757
+RMD160 7a334a18bea44db4c383e0b7420cb144381256a4 virtinst-0.300.1.tar.gz 96757
+SHA256 58e812432685950e7179373a26219558f612ca459e461ee5874f84058dd97b40 virtinst-0.300.1.tar.gz 96757
diff --git a/app-emulation/virtinst/files/virtinst-0.300.1-nfs-check.patch b/app-emulation/virtinst/files/virtinst-0.300.1-nfs-check.patch
new file mode 100644
index 000000000000..a45bf1125f47
--- /dev/null
+++ b/app-emulation/virtinst/files/virtinst-0.300.1-nfs-check.patch
@@ -0,0 +1,12 @@
+diff -r 531b73491ac2 virtinst/DistroManager.py
+--- a/virtinst/DistroManager.py Wed Oct 10 14:24:48 2007 -0400
++++ b/virtinst/DistroManager.py Thu Oct 11 11:39:58 2007 -0400
+@@ -161,7 +161,7 @@ class MountedImageFetcher(ImageFetcher):
+ if tmpfile is not None:
+ os.unlink(tmpfile)
+ return True
+- except RuntimeError, e:
++ except Exception, e:
+ logging.debug("Cannot find file %s" % filename)
+ return False
+
diff --git a/app-emulation/virtinst/files/virtinst-0.300.1-remove-usb-tablet.patch b/app-emulation/virtinst/files/virtinst-0.300.1-remove-usb-tablet.patch
new file mode 100644
index 000000000000..1eeff1faa46d
--- /dev/null
+++ b/app-emulation/virtinst/files/virtinst-0.300.1-remove-usb-tablet.patch
@@ -0,0 +1,96 @@
+Only in virtinst-0.300.1.new: .coverage
+diff -rup virtinst-0.300.1.orig/tests/boot-fullyvirt-disk-block.xml virtinst-0.300.1.new/tests/boot-fullyvirt-disk-block.xml
+--- virtinst-0.300.1.orig/tests/boot-fullyvirt-disk-block.xml 2007-09-25 11:01:12.000000000 -0400
++++ virtinst-0.300.1.new/tests/boot-fullyvirt-disk-block.xml 2007-10-04 12:10:00.000000000 -0400
+@@ -28,7 +28,7 @@
+ </disk>
+
+
+- <input type='tablet' bus='usb'/>
++ <input type='mouse' bus='ps2'/>
+ <graphics type='sdl'/>
+ </devices>
+ </domain>
+diff -rup virtinst-0.300.1.orig/tests/boot-fullyvirt-disk-file.xml virtinst-0.300.1.new/tests/boot-fullyvirt-disk-file.xml
+--- virtinst-0.300.1.orig/tests/boot-fullyvirt-disk-file.xml 2007-09-25 11:01:12.000000000 -0400
++++ virtinst-0.300.1.new/tests/boot-fullyvirt-disk-file.xml 2007-10-04 12:10:17.000000000 -0400
+@@ -28,7 +28,7 @@
+ </disk>
+
+
+- <input type='tablet' bus='usb'/>
++ <input type='mouse' bus='ps2'/>
+ <graphics type='sdl'/>
+ </devices>
+ </domain>
+diff -rup virtinst-0.300.1.orig/tests/install-fullyvirt-disk-block.xml virtinst-0.300.1.new/tests/install-fullyvirt-disk-block.xml
+--- virtinst-0.300.1.orig/tests/install-fullyvirt-disk-block.xml 2007-09-25 11:01:12.000000000 -0400
++++ virtinst-0.300.1.new/tests/install-fullyvirt-disk-block.xml 2007-10-04 12:10:29.000000000 -0400
+@@ -29,7 +29,7 @@
+ </disk>
+
+
+- <input type='tablet' bus='usb'/>
++ <input type='mouse' bus='ps2'/>
+ <graphics type='sdl'/>
+ </devices>
+ </domain>
+diff -rup virtinst-0.300.1.orig/tests/install-fullyvirt-disk-file.xml virtinst-0.300.1.new/tests/install-fullyvirt-disk-file.xml
+--- virtinst-0.300.1.orig/tests/install-fullyvirt-disk-file.xml 2007-09-25 11:01:12.000000000 -0400
++++ virtinst-0.300.1.new/tests/install-fullyvirt-disk-file.xml 2007-10-04 12:10:37.000000000 -0400
+@@ -29,7 +29,7 @@
+ </disk>
+
+
+- <input type='tablet' bus='usb'/>
++ <input type='mouse' bus='ps2'/>
+ <graphics type='sdl'/>
+ </devices>
+ </domain>
+diff -rup virtinst-0.300.1.orig/virtinst/FullVirtGuest.py virtinst-0.300.1.new/virtinst/FullVirtGuest.py
+--- virtinst-0.300.1.orig/virtinst/FullVirtGuest.py 2007-09-25 11:01:12.000000000 -0400
++++ virtinst-0.300.1.new/virtinst/FullVirtGuest.py 2007-10-04 12:02:36.000000000 -0400
+@@ -27,6 +27,7 @@ class FullVirtGuest(Guest.XenGuest):
+ "acpi": True, \
+ "apic": True, \
+ "continue": False, \
++ "input": [ "mouse", "ps2"],
+ "variants": { "rhel2.1": { "label": "Red Hat Enterprise Linux 2.1", "distro": "rhel" }, \
+ "rhel3": { "label": "Red Hat Enterprise Linux 3", "distro": "rhel" }, \
+ "rhel4": { "label": "Red Hat Enterprise Linux 4", "distro": "rhel" }, \
+@@ -44,6 +45,7 @@ class FullVirtGuest(Guest.XenGuest):
+ "acpi": True, \
+ "apic": True, \
+ "continue": True, \
++ "input": [ "tablet", "usb"],
+ "variants": { "winxp": { "label": "Microsoft Windows XP", \
+ "acpi": False, \
+ "apic": False }, \
+@@ -58,6 +60,7 @@ class FullVirtGuest(Guest.XenGuest):
+ "acpi": True,
+ "apic": True,
+ "continue": False, \
++ "input": [ "mouse", "ps2"],
+ "variants": { "solaris9": { "label": "Sun Solaris 9" }, \
+ "solaris10": { "label": "Sun Solaris 10" }, \
+ "freebsd6": { "label": "Free BSD 6.x" }, \
+@@ -68,6 +71,7 @@ class FullVirtGuest(Guest.XenGuest):
+ "acpi": True,
+ "apic": True,
+ "continue": False,
++ "input": [ "mouse", "ps2"],
+ "variants": { "msdos": { "label": "MS-DOS", \
+ "acpi": False, \
+ "apic": False }, \
+@@ -161,7 +165,10 @@ class FullVirtGuest(Guest.XenGuest):
+ os_distro = property(get_os_distro)
+
+ def get_input_device(self):
+- return ("tablet", "usb")
++ if self.os_type is None or not FullVirtGuest.OS_TYPES.has_key(self.os_type):
++ return ("mouse", "ps2")
++ input = FullVirtGuest.OS_TYPES[self.os_type]["input"]
++ return (input[0], input[1])
+
+ def _get_features_xml(self):
+ ret = "<features>\n"
diff --git a/app-emulation/virtinst/virtinst-0.300.1.ebuild b/app-emulation/virtinst/virtinst-0.300.1.ebuild
new file mode 100644
index 000000000000..273d5326f5e9
--- /dev/null
+++ b/app-emulation/virtinst/virtinst-0.300.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.300.1.ebuild,v 1.1 2007/10/15 11:16:31 dberkholz Exp $
+
+inherit distutils rpm
+
+DESCRIPTION="Python modules for starting virtualized guest installations"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=">=app-emulation/libvirt-0.2.1
+ dev-python/urlgrabber"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ rpm_src_unpack
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-nfs-check.patch
+ epatch "${FILESDIR}"/${P}-remove-usb-tablet.patch
+
+}