summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild')
-rw-r--r--x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
index 7a3d3101534e..f8ce7f6cbc45 100644
--- a/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
+++ b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
@@ -1,24 +1,34 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic
+
+inherit autotools flag-o-matic
DESCRIPTION="A generic touchscreen calibration program for X.Org"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/xinput_calibrator"
-SRC_URI="https://github.com/downloads/tias/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/tias/xinput_calibrator/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
- x11-libs/libXrandr"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+ x11-libs/libXrandr
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
src_configure() {
append-cxxflags -std=c++11 #566594