summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 13:02:17 +0100
committerSam James <sam@gentoo.org>2023-05-01 13:35:49 +0100
commit397fc0fd53568700d9ce805a6ca8cc7bf67e53ab (patch)
tree49d78ed9a201f7f4ae7acdbfdf898cdd160756a5 /x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
parentmedia-sound/audiotag: update SRC_URI to drop github.com/downloads (diff)
downloadgentoo-397fc0fd53568700d9ce805a6ca8cc7bf67e53ab.tar.gz
gentoo-397fc0fd53568700d9ce805a6ca8cc7bf67e53ab.tar.bz2
gentoo-397fc0fd53568700d9ce805a6ca8cc7bf67e53ab.zip
x11-apps/xinput_calibrator: update SRC_URI to drop github.com/downloads
github.com/downloads is gone. Unforunately, the release tarball is gone. Fixes: 24326d8f3494ebd312c9cc172a5f9ed3bf25cce9 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild')
-rw-r--r--x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
index 7a3d3101534e..f8ce7f6cbc45 100644
--- a/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
+++ b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
@@ -1,24 +1,34 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic
+
+inherit autotools flag-o-matic
DESCRIPTION="A generic touchscreen calibration program for X.Org"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/xinput_calibrator"
-SRC_URI="https://github.com/downloads/tias/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/tias/xinput_calibrator/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
- x11-libs/libXrandr"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+ x11-libs/libXrandr
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
src_configure() {
append-cxxflags -std=c++11 #566594