summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pcapfix/pcapfix-1.1.4.ebuild')
-rw-r--r--net-misc/pcapfix/pcapfix-1.1.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/pcapfix/pcapfix-1.1.4.ebuild b/net-misc/pcapfix/pcapfix-1.1.4.ebuild
new file mode 100644
index 000000000000..9f2ecbc9c679
--- /dev/null
+++ b/net-misc/pcapfix/pcapfix-1.1.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Repair and fix broken pcap files"
+HOMEPAGE="http://f00l.de/pcapfix/"
+SRC_URI="http://f00l.de/pcapfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DOCS=( Changelog README )
+
+src_prepare() {
+ default
+ sed -e 's/gcc/$(CC) $(CFLAGS)/g' -i Makefile || die
+ use debug || sed -e 's/DEBUGFLAGS = -g/DEBUGFLAGS =/g' -i Makefile || die
+}
+
+src_install() {
+ doman pcapfix.1
+ dobin pcapfix
+ einstalldocs
+}