summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-03-19 17:33:44 +0200
committerRobin H. Johnson <robbat2@gentoo.org>2019-04-17 21:01:31 -0700
commit56e4cf2e58f6dc15ea574e4eac6db82792087a74 (patch)
treee0af36a7f84e76a8539d3bb334d1f685d754b134 /net-misc/pcapfix/pcapfix-1.1.4.ebuild
parentnet-misc/aggregate-flim: update HOMEPAGE, SRC_URI (diff)
downloadgentoo-56e4cf2e58f6dc15ea574e4eac6db82792087a74.tar.gz
gentoo-56e4cf2e58f6dc15ea574e4eac6db82792087a74.tar.bz2
gentoo-56e4cf2e58f6dc15ea574e4eac6db82792087a74.zip
net-misc/pcapfix: version bump 1.1.4, EAPI 7
Closes: https://bugs.gentoo.org/498752 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Fixes: https://github.com/gentoo/gentoo/pull/11412 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-misc/pcapfix/pcapfix-1.1.4.ebuild')
-rw-r--r--net-misc/pcapfix/pcapfix-1.1.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/pcapfix/pcapfix-1.1.4.ebuild b/net-misc/pcapfix/pcapfix-1.1.4.ebuild
new file mode 100644
index 000000000000..9f2ecbc9c679
--- /dev/null
+++ b/net-misc/pcapfix/pcapfix-1.1.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Repair and fix broken pcap files"
+HOMEPAGE="http://f00l.de/pcapfix/"
+SRC_URI="http://f00l.de/pcapfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DOCS=( Changelog README )
+
+src_prepare() {
+ default
+ sed -e 's/gcc/$(CC) $(CFLAGS)/g' -i Makefile || die
+ use debug || sed -e 's/DEBUGFLAGS = -g/DEBUGFLAGS =/g' -i Makefile || die
+}
+
+src_install() {
+ doman pcapfix.1
+ dobin pcapfix
+ einstalldocs
+}