summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2025-01-04 21:52:44 +0100
committerSam James <sam@gentoo.org>2025-01-05 20:33:28 +0000
commitcd099e30b43871af1a43dd85125eceda61899060 (patch)
tree051578ea16f7575b000854f0aac7eb3294884aeb /media-libs/osl
parentmedia-libs/osl: add 1.13.12.0 (diff)
downloadgentoo-cd099e30b43871af1a43dd85125eceda61899060.tar.gz
gentoo-cd099e30b43871af1a43dd85125eceda61899060.tar.bz2
gentoo-cd099e30b43871af1a43dd85125eceda61899060.zip
media-libs/osl: default to qt6 for USE=gui
Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/osl')
-rw-r--r--media-libs/osl/metadata.xml3
-rw-r--r--media-libs/osl/osl-1.12.14.0-r2.ebuild (renamed from media-libs/osl/osl-1.12.14.0-r1.ebuild)24
-rw-r--r--media-libs/osl/osl-1.13.10.0.ebuild24
3 files changed, 9 insertions, 42 deletions
diff --git a/media-libs/osl/metadata.xml b/media-libs/osl/metadata.xml
index a0f31940cbeb..a62fb425a42a 100644
--- a/media-libs/osl/metadata.xml
+++ b/media-libs/osl/metadata.xml
@@ -15,12 +15,11 @@
lights, displacement, and pattern generation.
</longdescription>
<use>
- <flag name="gui">Build the osltoy binary (with Qt5)</flag>
+ <flag name="gui">Build the osltoy binary</flag>
<flag name="libcxx">Build against <pkg>llvm-runtimes/libcxx</pkg> when using clang</flag>
<flag name="nofma">Do not use Fuse-Multiply-Add operations</flag>
<flag name="optix">Add support for NVIDIA's OptiX Raytracing Engine</flag>
<flag name="partio">Use <pkg>media-libs/partio</pkg></flag>
- <flag name="qt6">Build the osltoy binary (with Qt6)</flag>
</use>
<upstream>
<remote-id type="github">AcademySoftwareFoundation/OpenShadingLanguage</remote-id>
diff --git a/media-libs/osl/osl-1.12.14.0-r1.ebuild b/media-libs/osl/osl-1.12.14.0-r2.ebuild
index a5bef473888b..104c0702a449 100644
--- a/media-libs/osl/osl-1.12.14.0-r1.ebuild
+++ b/media-libs/osl/osl-1.12.14.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,7 +32,7 @@ X86_CPU_FEATURES=(
)
CPU_FEATURES=( "${X86_CPU_FEATURES[@]/#/cpu_flags_x86_}" )
-IUSE="debug doc gui libcxx nofma partio qt6 test ${CPU_FEATURES[*]%:*} python"
+IUSE="debug doc gui libcxx nofma partio test ${CPU_FEATURES[*]%:*} python"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -55,15 +55,7 @@ RDEPEND="
)
partio? ( media-libs/partio )
gui? (
- !qt6? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtopengl:5
- )
- qt6? (
- dev-qt/qtbase:6[gui,widgets,opengl]
- )
+ dev-qt/qtbase:6[gui,widgets,opengl]
)
"
@@ -177,6 +169,7 @@ src_configure() {
-DUSE_BATCHED="$(IFS=","; echo "${mybatched[*]}")"
-DUSE_LIBCPLUSPLUS="$(usex libcxx)"
-DUSE_OPTIX="no"
+ -DUSE_QT="$(usex gui)"
-DOpenImageIO_ROOT="${EPREFIX}/usr"
)
@@ -187,15 +180,6 @@ src_configure() {
)
fi
- if use gui; then
- mycmakeargs+=( -DUSE_QT="yes" )
- if ! use qt6; then
- mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Qt6="yes" )
- fi
- else
- mycmakeargs+=( -DUSE_QT="no" )
- fi
-
if use partio; then
mycmakeargs+=(
-Dpartio_ROOT="${EPREFIX}/usr"
diff --git a/media-libs/osl/osl-1.13.10.0.ebuild b/media-libs/osl/osl-1.13.10.0.ebuild
index 1ab9bcdd3d56..bd2b569e7e9c 100644
--- a/media-libs/osl/osl-1.13.10.0.ebuild
+++ b/media-libs/osl/osl-1.13.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,7 +32,7 @@ X86_CPU_FEATURES=(
)
CPU_FEATURES=( "${X86_CPU_FEATURES[@]/#/cpu_flags_x86_}" )
-IUSE="debug doc gui libcxx nofma optix partio qt6 test ${CPU_FEATURES[*]%:*} python"
+IUSE="debug doc gui libcxx nofma optix partio test ${CPU_FEATURES[*]%:*} python"
RESTRICT="!test? ( test )"
@@ -59,15 +59,7 @@ RDEPEND="
)
partio? ( media-libs/partio )
gui? (
- !qt6? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtopengl:5
- )
- qt6? (
- dev-qt/qtbase:6[gui,widgets,opengl]
- )
+ dev-qt/qtbase:6[gui,widgets,opengl]
)
"
@@ -189,6 +181,7 @@ src_configure() {
-DUSE_BATCHED="$(IFS=","; echo "${mybatched[*]}")"
-DUSE_LIBCPLUSPLUS="$(usex libcxx)"
-DOSL_USE_OPTIX="$(usex optix)"
+ -DUSE_QT="$(usex gui)"
-DOpenImageIO_ROOT="${EPREFIX}/usr"
)
@@ -199,15 +192,6 @@ src_configure() {
)
fi
- if use gui; then
- mycmakeargs+=( -DUSE_QT="yes" )
- if ! use qt6; then
- mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Qt6="yes" )
- fi
- else
- mycmakeargs+=( -DUSE_QT="no" )
- fi
-
if use optix; then
mycmakeargs+=(
-DOptiX_FIND_QUIETLY="no"