summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/osl/osl-1.13.10.0.ebuild')
-rw-r--r--media-libs/osl/osl-1.13.10.0.ebuild24
1 files changed, 4 insertions, 20 deletions
diff --git a/media-libs/osl/osl-1.13.10.0.ebuild b/media-libs/osl/osl-1.13.10.0.ebuild
index 1ab9bcdd3d56..bd2b569e7e9c 100644
--- a/media-libs/osl/osl-1.13.10.0.ebuild
+++ b/media-libs/osl/osl-1.13.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,7 +32,7 @@ X86_CPU_FEATURES=(
)
CPU_FEATURES=( "${X86_CPU_FEATURES[@]/#/cpu_flags_x86_}" )
-IUSE="debug doc gui libcxx nofma optix partio qt6 test ${CPU_FEATURES[*]%:*} python"
+IUSE="debug doc gui libcxx nofma optix partio test ${CPU_FEATURES[*]%:*} python"
RESTRICT="!test? ( test )"
@@ -59,15 +59,7 @@ RDEPEND="
)
partio? ( media-libs/partio )
gui? (
- !qt6? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtopengl:5
- )
- qt6? (
- dev-qt/qtbase:6[gui,widgets,opengl]
- )
+ dev-qt/qtbase:6[gui,widgets,opengl]
)
"
@@ -189,6 +181,7 @@ src_configure() {
-DUSE_BATCHED="$(IFS=","; echo "${mybatched[*]}")"
-DUSE_LIBCPLUSPLUS="$(usex libcxx)"
-DOSL_USE_OPTIX="$(usex optix)"
+ -DUSE_QT="$(usex gui)"
-DOpenImageIO_ROOT="${EPREFIX}/usr"
)
@@ -199,15 +192,6 @@ src_configure() {
)
fi
- if use gui; then
- mycmakeargs+=( -DUSE_QT="yes" )
- if ! use qt6; then
- mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Qt6="yes" )
- fi
- else
- mycmakeargs+=( -DUSE_QT="no" )
- fi
-
if use optix; then
mycmakeargs+=(
-DOptiX_FIND_QUIETLY="no"