summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-09 04:05:25 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-09 04:05:25 +0100
commited63d4964b6b9a8bb407fe267dccb8d4aeba8e10 (patch)
treeac036acc59148f770ce72065d530a5c6bca0f801 /dev-python
parentdev-python/botocore: Bump to 1.31.82 (diff)
downloadgentoo-ed63d4964b6b9a8bb407fe267dccb8d4aeba8e10.tar.gz
gentoo-ed63d4964b6b9a8bb407fe267dccb8d4aeba8e10.tar.bz2
gentoo-ed63d4964b6b9a8bb407fe267dccb8d4aeba8e10.zip
dev-python/boto3: Bump to 1.28.82
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.82.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 2b23f761d6a5..1979e1bad25f 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.28.77.gh.tar.gz 723612 BLAKE2B e2a2d3919f2f0ad09c0385b5f93bf4167c00
DIST boto3-1.28.78.gh.tar.gz 724185 BLAKE2B 5089a7d1eab11c23bd65699c41c3c6687f0666f10ebcc7fc4813f96225ceee5a10a008ae6969cd7927f43f09e0988178ea40386bcd91c473ac5fba1dedeeeef1 SHA512 e74f7348d369580e8d26f7c1f084276ec339d4bdd3ee628bdbe56cc6e4b1c0b22a759bb4ffe1075f0cb0d6f1692864db85a73d3cb884358dc97d6428f3fd9b0a
DIST boto3-1.28.79.gh.tar.gz 724864 BLAKE2B b6327a3dfd0095078668c85fb539885cdbc848a73b67afeaf97f58cb7362b1f928c49cb3cb233873b59ac925b9e97bc0571129f478177802f1249ddaa597297a SHA512 55eaf9e8122ef2f3424caa86f838fe03028a666aad281b6c52e0c8629c9d64707e1659c6d2e21666fe805f60cdde2ef0aece744737952cd55a20165c1d8186af
DIST boto3-1.28.80.gh.tar.gz 725109 BLAKE2B ba34c01f64817f437a2cf85f3de3672c01edbe2a4aa5f7dec3bcc0e0c78c6c3f1932e630e936d8f515e3293635f5935490905ed7847667d082a77645915344fd SHA512 83bc9f9c9880b7fc847fc95d202c2ffbfde32e06deeed787f86e76b0ccae9c44585f95ec193afb80d16d257f508334fdd048b8eefef9ebff5505de521e8c7288
+DIST boto3-1.28.82.gh.tar.gz 726369 BLAKE2B 757445a7af86182d6bd3143bbf576e24a1a4608929bafb641ed678d444364d2948d07ebc0ef434a53a0349a8a286dc818d757ee3c59545f8550ff39dcd745147 SHA512 ccfd72a6988565c884232a64ee33e01cf54a03e8f0f77990cc5bf633e60b92cad7562d1603726488e723813671e8931b1386ef06069074fea0611728aea06f96
diff --git a/dev-python/boto3/boto3-1.28.82.ebuild b/dev-python/boto3/boto3-1.28.82.ebuild
new file mode 100644
index 000000000000..0604e0996a82
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.82.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}