summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-09 04:05:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-09 04:05:17 +0100
commit9a5f4cbed90e75d21a3116ff575d91921a267b89 (patch)
tree52caadcd414c95778b9a62de069d088a39674b89 /dev-python
parentdev-libs/libchdr: treeclean (diff)
downloadgentoo-9a5f4cbed90e75d21a3116ff575d91921a267b89.tar.gz
gentoo-9a5f4cbed90e75d21a3116ff575d91921a267b89.tar.bz2
gentoo-9a5f4cbed90e75d21a3116ff575d91921a267b89.zip
dev-python/botocore: Bump to 1.31.82
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.31.82.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 52e5314497c7..2df9e36ea7c2 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.31.77.gh.tar.gz 12031161 BLAKE2B 24e4daa5b0ae49dc2fd8851b459f3a5
DIST botocore-1.31.78.gh.tar.gz 12035206 BLAKE2B 0dd1109d34a8cf99af76f1f615095776e75c0042717a573da3714d1e20efce5cf67bf38d5421c3c5558112821adb4307f7ca0791efc8e62c9ea2e9ba8c2ddc7a SHA512 68c0f68b699ff0c0276cc70f4d4843259a953511c9c2813a3101d7dc43c36a0a3bda68df66a7ab2c206977a96ce0d933830b4004898f03febf478c710beb5261
DIST botocore-1.31.79.gh.tar.gz 12039146 BLAKE2B 9c4c8609e75e1d95130fc4919bba318732a09a884cd6256f86557bef13f8dbdf46d7ec57584c7132b53a17ad50feb3240ad4e6c3306bf9ae974e693f14e7d65c SHA512 84669e6c3c0fa9991ece0d65dd03e9d68d9c03cadef4477c96d1d45a3bce03534fa489a996725078be294b42dafc54c78ec527cbe7e3e015317642c0f80e9e47
DIST botocore-1.31.80.gh.tar.gz 12043936 BLAKE2B 447c88e82f9e73fd683045c0e05e1f2d601446dddb2731b3e461b8ddb991ca045cd0489b0d0174d3b2b3301d984eb8af7ddd93a6e1bfcd9fc0fe68adfe4cc4ec SHA512 7bea745675fc09fe2a858fbda0df93dbf2d1c1d933afbef1625788b11c2b032e794b52d9da6e864ac350b6b1fc92c77f3d7c3749168ba1836ad21bb57de3cabb
+DIST botocore-1.31.82.gh.tar.gz 12051646 BLAKE2B e474bab929f7b16b37f71e261230014585c10cf30d36f2b241e6aae4845356e373db811de9158e1e074568e02d481bb83bf7f5aaaeece4bd196d49443574b3f1 SHA512 ecfa4dc060ee961def1cec0ab55739673fa04fda0a3154ea609526928eb16811a7cbc8d3d15b33aaa8c1a1606943f07935d9df06619517117e9392cbac6eeaf8
diff --git a/dev-python/botocore/botocore-1.31.82.ebuild b/dev-python/botocore/botocore-1.31.82.ebuild
new file mode 100644
index 000000000000..05766e84276c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.31.82.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}