summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-21 14:26:13 +0100
committerJustin Lecher <jlec@gentoo.org>2014-12-21 14:26:40 +0100
commite30278cf2272c4a4e75f874bd4d5140bc2a0523b (patch)
treea2787f7b82ed0a1fe9ecee01f79230f88b4649f6 /dev-vcs
parentgames-board/xboard-xiangqi: 0 (diff)
downloadbetagarden-e30278cf2272c4a4e75f874bd4d5140bc2a0523b.tar.gz
betagarden-e30278cf2272c4a4e75f874bd4d5140bc2a0523b.tar.bz2
betagarden-e30278cf2272c4a4e75f874bd4d5140bc2a0523b.zip
dev-vcs/hub: Add test phase
Package-Manager: portage-2.2.15 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hub/ChangeLog3
-rw-r--r--dev-vcs/hub/hub-9999.ebuild13
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-vcs/hub/ChangeLog b/dev-vcs/hub/ChangeLog
index 6ab1fe5..ee268b0 100644
--- a/dev-vcs/hub/ChangeLog
+++ b/dev-vcs/hub/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/ChangeLog,v 1.3 2013/05/31 23:14:44 ottxor Exp $
+ 21 Dec 2014; Justin Lecher <jlec@gentoo.org> hub-9999.ebuild:
+ Add test phase
+
22 Nov 2014; Justin Lecher <jlec@gentoo.org> hub-9999.ebuild:
Update to latest HEAD
diff --git a/dev-vcs/hub/hub-9999.ebuild b/dev-vcs/hub/hub-9999.ebuild
index 6c74230..fa0520b 100644
--- a/dev-vcs/hub/hub-9999.ebuild
+++ b/dev-vcs/hub/hub-9999.ebuild
@@ -14,9 +14,16 @@ EGIT_REPO_URI="https://github.com/github/hub.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
+IUSE="test"
RDEPEND="dev-vcs/git"
-DEPEND="dev-lang/go"
+DEPEND="
+ dev-lang/go
+ test? (
+ app-misc/tmux
+ dev-util/cucumber
+ dev-ruby/bundler
+ )"
DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
@@ -24,6 +31,10 @@ src_compile() {
bash ./script/build || die
}
+src_test() {
+ bash ./script/test || die
+}
+
src_install() {
dobin ${PN}