summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-30 07:57:59 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-30 07:57:59 +0000
commitf6be679fe9a422e20fcc0d523adae286097d1f90 (patch)
tree8baee214d2995e9779cd2d2a9241fe396a514634 /www-client/dwb
parentLeechcraft changed license since 0.5.95 (diff)
downloadgentoo-2-f6be679fe9a422e20fcc0d523adae286097d1f90.tar.gz
gentoo-2-f6be679fe9a422e20fcc0d523adae286097d1f90.tar.bz2
gentoo-2-f6be679fe9a422e20fcc0d523adae286097d1f90.zip
Fix compile with >=json-c-0.11 (bug #467940), fix compile on uclibc and other systems without execinfo.h (bug #465170), and add dep on gnutls.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-client/dwb')
-rw-r--r--www-client/dwb/ChangeLog7
-rw-r--r--www-client/dwb/dwb-2013.03.30.ebuild12
-rw-r--r--www-client/dwb/dwb-9999.ebuild9
-rw-r--r--www-client/dwb/files/dwb-2013.03.30-json-c.patch33
4 files changed, 56 insertions, 5 deletions
diff --git a/www-client/dwb/ChangeLog b/www-client/dwb/ChangeLog
index b6bfc1eaf883..7efedcaa4e1e 100644
--- a/www-client/dwb/ChangeLog
+++ b/www-client/dwb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/dwb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/ChangeLog,v 1.17 2013/04/08 15:28:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/ChangeLog,v 1.18 2013/04/30 07:57:58 radhermit Exp $
+
+ 30 Apr 2013; Tim Harder <radhermit@gentoo.org> dwb-2013.03.30.ebuild,
+ +files/dwb-2013.03.30-json-c.patch, dwb-9999.ebuild:
+ Fix compile with >=json-c-0.11 (bug #467940), fix compile on uclibc and other
+ systems without execinfo.h (bug #465170), and add dep on gnutls.
*dwb-2013.03.30 (08 Apr 2013)
diff --git a/www-client/dwb/dwb-2013.03.30.ebuild b/www-client/dwb/dwb-2013.03.30.ebuild
index 00e4a03d905a..a8ab5d3e8b91 100644
--- a/www-client/dwb/dwb-2013.03.30.ebuild
+++ b/www-client/dwb/dwb-2013.03.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-2013.03.30.ebuild,v 1.1 2013/04/08 15:28:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-2013.03.30.ebuild,v 1.2 2013/04/30 07:57:58 radhermit Exp $
EAPI=5
@@ -17,6 +17,7 @@ IUSE="examples gtk3"
RDEPEND=">=net-libs/libsoup-2.32:2.4
dev-libs/json-c
+ net-libs/gnutls
!gtk3? (
>=net-libs/webkit-gtk-1.8.0:2
x11-libs/gtk+:2
@@ -30,13 +31,20 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-verbose-build.patch
- sed -i "/^CFLAGS += -\(pipe\|g\|O2\)/d" config.mk || die
+ epatch "${FILESDIR}"/${P}-json-c.patch
+
+ sed -i '/^CFLAGS += -\(pipe\|g\|O2\)/d' config.mk || die
}
src_compile() {
local myconf
use gtk3 && myconf+=" GTK=3"
+ # uclibc and other systems don't have execinfo.h (bug #465170)
+ if ! (echo '#include <execinfo.h>' | $(tc-getCC) -E - &>/dev/null) ; then
+ myconf+=" WITHOUT_EXECINFO=1"
+ fi
+
emake CC="$(tc-getCC)" ${myconf}
}
diff --git a/www-client/dwb/dwb-9999.ebuild b/www-client/dwb/dwb-9999.ebuild
index b7752420ae8e..c0fdfcb9537f 100644
--- a/www-client/dwb/dwb-9999.ebuild
+++ b/www-client/dwb/dwb-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-9999.ebuild,v 1.6 2013/04/08 15:17:04 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-9999.ebuild,v 1.7 2013/04/30 07:57:58 radhermit Exp $
EAPI=5
@@ -10,7 +10,6 @@ EGIT_REPO_URI="https://bitbucket.org/portix/dwb.git"
DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
HOMEPAGE="http://portix.bitbucket.org/dwb/"
-SRC_URI=""
LICENSE="GPL-3"
SLOT="0"
@@ -19,6 +18,7 @@ IUSE="examples gtk3"
RDEPEND=">=net-libs/libsoup-2.32:2.4
dev-libs/json-c
+ net-libs/gnutls
!gtk3? (
>=net-libs/webkit-gtk-1.8.0:2
x11-libs/gtk+:2
@@ -38,6 +38,11 @@ src_compile() {
local myconf
use gtk3 && myconf+=" GTK=3"
+ # uclibc and other systems don't have execinfo.h (bug #465170)
+ if ! (echo '#include <execinfo.h>' | $(tc-getCC) -E - &>/dev/null) ; then
+ myconf+=" WITHOUT_EXECINFO=1"
+ fi
+
emake CC="$(tc-getCC)" ${myconf}
}
diff --git a/www-client/dwb/files/dwb-2013.03.30-json-c.patch b/www-client/dwb/files/dwb-2013.03.30-json-c.patch
new file mode 100644
index 000000000000..fbd3b55de0d0
--- /dev/null
+++ b/www-client/dwb/files/dwb-2013.03.30-json-c.patch
@@ -0,0 +1,33 @@
+--- dwb-2013.03.30/config.mk
++++ dwb-2013.03.30/config.mk
+@@ -105,8 +105,18 @@
+ $(error Cannot find $(GNUTLS))
+ endif
+
++# >=json-c-0.11 renamed its library, pc file, and include dir
++# first check for >=0.11, if it doesn't exist check for <0.11
++ifeq ($(shell pkg-config --exists json-c && echo 1), 1)
++JSONC=json-c
++else
+ ifeq ($(shell pkg-config --exists json && echo 1), 1)
+-LIBS+=$(GNUTLS)
++JSONC=json
++endif
++endif
++
++ifdef JSONC
++LIBS+=$(JSONC)
+ else
+ $(error Cannot find json-c)
+ endif
+--- dwb-2013.03.30/src/util/Makefile
++++ dwb-2013.03.30/src/util/Makefile
+@@ -13,7 +13,7 @@
+ TRANSPORT_SECURITY_JSON=transport_security_state_static.json
+ TRANSPORT_SECURITY_CERTS=transport_security_state_static.certs
+
+-LIBS=glib-2.0 gnutls json
++LIBS=glib-2.0 gnutls $(JSONC)
+ CFLAGS+=$(shell pkg-config --cflags $(LIBS))
+ LDFLAGS=$(shell pkg-config --libs $(LIBS))
+