summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/dwb/dwb-2013.03.30.ebuild')
-rw-r--r--www-client/dwb/dwb-2013.03.30.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/www-client/dwb/dwb-2013.03.30.ebuild b/www-client/dwb/dwb-2013.03.30.ebuild
index 00e4a03d905a..a8ab5d3e8b91 100644
--- a/www-client/dwb/dwb-2013.03.30.ebuild
+++ b/www-client/dwb/dwb-2013.03.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-2013.03.30.ebuild,v 1.1 2013/04/08 15:28:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-2013.03.30.ebuild,v 1.2 2013/04/30 07:57:58 radhermit Exp $
EAPI=5
@@ -17,6 +17,7 @@ IUSE="examples gtk3"
RDEPEND=">=net-libs/libsoup-2.32:2.4
dev-libs/json-c
+ net-libs/gnutls
!gtk3? (
>=net-libs/webkit-gtk-1.8.0:2
x11-libs/gtk+:2
@@ -30,13 +31,20 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-verbose-build.patch
- sed -i "/^CFLAGS += -\(pipe\|g\|O2\)/d" config.mk || die
+ epatch "${FILESDIR}"/${P}-json-c.patch
+
+ sed -i '/^CFLAGS += -\(pipe\|g\|O2\)/d' config.mk || die
}
src_compile() {
local myconf
use gtk3 && myconf+=" GTK=3"
+ # uclibc and other systems don't have execinfo.h (bug #465170)
+ if ! (echo '#include <execinfo.h>' | $(tc-getCC) -E - &>/dev/null) ; then
+ myconf+=" WITHOUT_EXECINFO=1"
+ fi
+
emake CC="$(tc-getCC)" ${myconf}
}