summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-15 02:00:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-15 02:00:28 +0000
commit16af2baa162c68d98d1719da14b67f85c59ec7c5 (patch)
tree1b1a2b533a8cd9be9eae2f7e360d30ec98a6088a /sys-devel/bison/bison-1.875.ebuild
parentppc/uclibc (diff)
downloadgentoo-2-16af2baa162c68d98d1719da14b67f85c59ec7c5.tar.gz
gentoo-2-16af2baa162c68d98d1719da14b67f85c59ec7c5.tar.bz2
gentoo-2-16af2baa162c68d98d1719da14b67f85c59ec7c5.zip
create yacc symlink LIKE MAGIC #49331
Diffstat (limited to 'sys-devel/bison/bison-1.875.ebuild')
-rw-r--r--sys-devel/bison/bison-1.875.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
index ab2a49d4b831..e29aa8d31256 100644
--- a/sys-devel/bison/bison-1.875.ebuild
+++ b/sys-devel/bison/bison-1.875.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.24 2004/09/25 07:43:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.25 2004/10/15 02:00:28 vapier Exp $
inherit gcc flag-o-matic eutils gnuconfig
@@ -10,7 +10,7 @@ SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
IUSE="nls static uclibc"
DEPEND="sys-devel/m4
@@ -41,13 +41,9 @@ src_compile() {
replace-cpu-flags k6 k6-1 k6-2 i586
fi
- econf `use_enable nls` || die
-
- if use static; then
- emake LDFLAGS="-static" || die
- else
- emake || die
- fi
+ econf $(use_enable nls) || die
+ use static && append-ldflags -static
+ emake || die
}
src_install() {
@@ -58,9 +54,7 @@ src_install() {
install || die
# This one is installed by dev-util/yacc
- if ! use uclibc; then
- mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
- fi
+ mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
# We do not need this.
rm -f ${D}/usr/lib/liby.a
@@ -69,3 +63,9 @@ src_install() {
docinto txt
dodoc doc/FAQ
}
+
+pkg_postinst() {
+ if [ ! -e "${ROOT}/usr/bin/yacc" ] ; then
+ ln -s yacc.bison /usr/bin/yacc
+ fi
+}