summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/bison/ChangeLog6
-rw-r--r--sys-devel/bison/bison-1.875.ebuild24
2 files changed, 17 insertions, 13 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index ba7852f4e813..5fbc247cf1ae 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/bison
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.31 2004/07/19 15:53:22 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.32 2004/10/15 02:00:28 vapier Exp $
+
+ 14 Oct 2004; Mike Frysinger <vapier@gentoo.org> bison-1.875.ebuild:
+ Dont install bison as yacc, but if yacc doesnt exist, create a symlink
+ #49331 by Bruno Redondi.
19 Jul 2004; <solar@gentoo.org> bison-1.875.ebuild:
updated bison to use gnuconfig.eclass. Needed for uclibc and maybe others.
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
index ab2a49d4b831..e29aa8d31256 100644
--- a/sys-devel/bison/bison-1.875.ebuild
+++ b/sys-devel/bison/bison-1.875.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.24 2004/09/25 07:43:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.25 2004/10/15 02:00:28 vapier Exp $
inherit gcc flag-o-matic eutils gnuconfig
@@ -10,7 +10,7 @@ SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
IUSE="nls static uclibc"
DEPEND="sys-devel/m4
@@ -41,13 +41,9 @@ src_compile() {
replace-cpu-flags k6 k6-1 k6-2 i586
fi
- econf `use_enable nls` || die
-
- if use static; then
- emake LDFLAGS="-static" || die
- else
- emake || die
- fi
+ econf $(use_enable nls) || die
+ use static && append-ldflags -static
+ emake || die
}
src_install() {
@@ -58,9 +54,7 @@ src_install() {
install || die
# This one is installed by dev-util/yacc
- if ! use uclibc; then
- mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
- fi
+ mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
# We do not need this.
rm -f ${D}/usr/lib/liby.a
@@ -69,3 +63,9 @@ src_install() {
docinto txt
dodoc doc/FAQ
}
+
+pkg_postinst() {
+ if [ ! -e "${ROOT}/usr/bin/yacc" ] ; then
+ ln -s yacc.bison /usr/bin/yacc
+ fi
+}