summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 13:05:30 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 13:05:30 +0000
commit5ae62e71aa8611c06f46980f35949688c8279ce2 (patch)
tree477650a3bd334dcdc09263cd359a4bd7f7956990 /sci-mathematics
parentstable x86, bug 320163 (diff)
downloadgentoo-2-5ae62e71aa8611c06f46980f35949688c8279ce2.tar.gz
gentoo-2-5ae62e71aa8611c06f46980f35949688c8279ce2.tar.bz2
gentoo-2-5ae62e71aa8611c06f46980f35949688c8279ce2.zip
QA resorting ebuild, moving to EAPI=3
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/num-utils/num-utils-0.3.ebuild18
-rw-r--r--sci-mathematics/num-utils/num-utils-0.5.ebuild19
2 files changed, 19 insertions, 18 deletions
diff --git a/sci-mathematics/num-utils/num-utils-0.3.ebuild b/sci-mathematics/num-utils/num-utils-0.3.ebuild
index e32370be398e..e0db5a5cbdb9 100644
--- a/sci-mathematics/num-utils/num-utils-0.3.ebuild
+++ b/sci-mathematics/num-utils/num-utils-0.3.ebuild
@@ -1,26 +1,26 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/num-utils/num-utils-0.3.ebuild,v 1.3 2010/06/24 13:00:56 jlec Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/num-utils/num-utils-0.3.ebuild,v 1.4 2010/06/24 13:05:30 jlec Exp $
DESCRIPTION="A set of programs for dealing with numbers from the command line"
SRC_URI="http://suso.suso.org/programs/num-utils/downloads/${P}.tar.gz"
HOMEPAGE="http://suso.suso.org/programs/num-utils/"
-LICENSE="GPL-2"
-DEPEND=""
-RDEPEND="dev-lang/perl"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
-RDEPEND="!<sci-chemistry/gromacs-4"
+DEPEND=""
+RDEPEND="
+ dev-lang/perl
+ !<sci-chemistry/gromacs-4"
src_compile() {
emake || die
}
src_install () {
- make ROOT=${D} install || die
- dodoc CHANGELOG COPYING GOALS LICENSE MANIFEST README VERSION WARNING
+ make ROOT="${D}" install || die
+ dodoc CHANGELOG COPYING GOALS MANIFEST README VERSION WARNING
}
diff --git a/sci-mathematics/num-utils/num-utils-0.5.ebuild b/sci-mathematics/num-utils/num-utils-0.5.ebuild
index 964edbbeaadd..5b2e03cb854a 100644
--- a/sci-mathematics/num-utils/num-utils-0.5.ebuild
+++ b/sci-mathematics/num-utils/num-utils-0.5.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/num-utils/num-utils-0.5.ebuild,v 1.6 2010/06/24 13:00:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/num-utils/num-utils-0.5.ebuild,v 1.7 2010/06/24 13:05:29 jlec Exp $
-IUSE=""
+EAPI="3"
DESCRIPTION="A set of programs for dealing with numbers from the command line"
SRC_URI="http://suso.suso.org/programs/num-utils/downloads/${P}.tar.gz"
HOMEPAGE="http://suso.suso.org/programs/num-utils/"
-LICENSE="GPL-2"
-DEPEND=""
-RDEPEND="dev-lang/perl"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
-RDEPEND="!<sci-chemistry/gromacs-4"
+DEPEND=""
+RDEPEND="
+ dev-lang/perl
+ !<sci-chemistry/gromacs-4"
-src_compile() {
+src_prepare() {
# bug #248324
mv normalize nnormalize || die
sed -i \
@@ -25,11 +27,10 @@ src_compile() {
-e '/^DOCS/s/MANIFEST//' \
-e 's/normalize/nnormalize/' \
Makefile || die "sed Makefile failed"
- emake || die "emake failed"
}
src_install () {
- emake ROOT="${D}" install || die "emake install failed"
+ emake ROOT="${ED}" install || die "emake install failed"
}
pkg_postinst() {