summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/num-utils/num-utils-0.5.ebuild')
-rw-r--r--sci-mathematics/num-utils/num-utils-0.5.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/sci-mathematics/num-utils/num-utils-0.5.ebuild b/sci-mathematics/num-utils/num-utils-0.5.ebuild
index 964edbbeaadd..5b2e03cb854a 100644
--- a/sci-mathematics/num-utils/num-utils-0.5.ebuild
+++ b/sci-mathematics/num-utils/num-utils-0.5.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/num-utils/num-utils-0.5.ebuild,v 1.6 2010/06/24 13:00:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/num-utils/num-utils-0.5.ebuild,v 1.7 2010/06/24 13:05:29 jlec Exp $
-IUSE=""
+EAPI="3"
DESCRIPTION="A set of programs for dealing with numbers from the command line"
SRC_URI="http://suso.suso.org/programs/num-utils/downloads/${P}.tar.gz"
HOMEPAGE="http://suso.suso.org/programs/num-utils/"
-LICENSE="GPL-2"
-DEPEND=""
-RDEPEND="dev-lang/perl"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
-RDEPEND="!<sci-chemistry/gromacs-4"
+DEPEND=""
+RDEPEND="
+ dev-lang/perl
+ !<sci-chemistry/gromacs-4"
-src_compile() {
+src_prepare() {
# bug #248324
mv normalize nnormalize || die
sed -i \
@@ -25,11 +27,10 @@ src_compile() {
-e '/^DOCS/s/MANIFEST//' \
-e 's/normalize/nnormalize/' \
Makefile || die "sed Makefile failed"
- emake || die "emake failed"
}
src_install () {
- emake ROOT="${D}" install || die "emake install failed"
+ emake ROOT="${ED}" install || die "emake install failed"
}
pkg_postinst() {