summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-08-29 21:33:46 +0000
committerTim Harder <radhermit@gentoo.org>2010-08-29 21:33:46 +0000
commit1b2a37c2396ad420126d4b04a3cac91c56bc9f48 (patch)
tree4edf8022a19d82d2c5d73675482bb68d3dedab58 /net-mail/gnubiff
parentDo not add CFLAGS to CXXFLAGS, bug #234028. Fix automagic samba support, bug ... (diff)
downloadgentoo-2-1b2a37c2396ad420126d4b04a3cac91c56bc9f48.tar.gz
gentoo-2-1b2a37c2396ad420126d4b04a3cac91c56bc9f48.tar.bz2
gentoo-2-1b2a37c2396ad420126d4b04a3cac91c56bc9f48.zip
Version bump for bug #301196, thanks to Geert Vanhaute for reporting. Remove buggy version, closes bugs #272095 and #333809.
(Portage version: 2.2_rc71/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/gnubiff')
-rw-r--r--net-mail/gnubiff/ChangeLog11
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.13.ebuild (renamed from net-mail/gnubiff/gnubiff-2.2.11.ebuild)22
2 files changed, 20 insertions, 13 deletions
diff --git a/net-mail/gnubiff/ChangeLog b/net-mail/gnubiff/ChangeLog
index 716613a7e413..fb7cd87c229c 100644
--- a/net-mail/gnubiff/ChangeLog
+++ b/net-mail/gnubiff/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/gnubiff
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.24 2009/05/22 20:18:30 dertobi123 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.25 2010/08/29 21:33:46 radhermit Exp $
+
+*gnubiff-2.2.13 (29 Aug 2010)
+
+ 29 Aug 2010; Tim Harder <radhermit@gentoo.org> -gnubiff-2.2.11.ebuild,
+ +gnubiff-2.2.13.ebuild:
+ Version bump for bug #301196, thanks to Geert Vanhaute for reporting.
+ Remove buggy version, closes bugs #272095 and #333809.
*gnubiff-2.2.11 (22 May 2009)
diff --git a/net-mail/gnubiff/gnubiff-2.2.11.ebuild b/net-mail/gnubiff/gnubiff-2.2.13.ebuild
index 0ecff4fc4ee2..2c765f87df4b 100644
--- a/net-mail/gnubiff/gnubiff-2.2.11.ebuild
+++ b/net-mail/gnubiff/gnubiff-2.2.13.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.11.ebuild,v 1.1 2009/05/22 20:18:30 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.13.ebuild,v 1.1 2010/08/29 21:33:46 radhermit Exp $
-inherit base eutils
+EAPI=3
DESCRIPTION="A mail notification program"
HOMEPAGE="http://gnubiff.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
+
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
IUSE="debug fam gnome nls password"
-RDEPEND=">=x11-libs/gtk+-2.4
+RDEPEND=">=x11-libs/gtk+-2.6
>=gnome-base/libglade-2.3
dev-libs/popt
gnome? (
@@ -24,18 +25,17 @@ RDEPEND=">=x11-libs/gtk+-2.4
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_compile() {
- econf $(use_enable debug) \
+src_configure() {
+ econf \
+ $(use_enable debug) \
$(use_enable gnome) \
$(use_enable nls) \
$(use_enable fam) \
$(use_with password) \
- $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM}) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM})
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README THANKS TODO
}