summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/gnubiff/gnubiff-2.2.13.ebuild')
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.13.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/gnubiff/gnubiff-2.2.13.ebuild b/net-mail/gnubiff/gnubiff-2.2.13.ebuild
new file mode 100644
index 000000000000..2c765f87df4b
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.2.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.13.ebuild,v 1.1 2010/08/29 21:33:46 radhermit Exp $
+
+EAPI=3
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="debug fam gnome nls password"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3
+ dev-libs/popt
+ gnome? (
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2 )
+ password? ( dev-libs/openssl )
+ fam? ( virtual/fam )
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable gnome) \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM})
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}