summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-04-12 17:21:04 +0000
committerJustin Lecher <jlec@gentoo.org>2015-04-12 17:21:04 +0000
commit318556440a30fb76d90ed7707eb423bd7022d50c (patch)
tree2176e42605cb5785093de0494c2b450d69ec387e /net-libs
parentVersion bump (diff)
downloadgentoo-2-318556440a30fb76d90ed7707eb423bd7022d50c.tar.gz
gentoo-2-318556440a30fb76d90ed7707eb423bd7022d50c.tar.bz2
gentoo-2-318556440a30fb76d90ed7707eb423bd7022d50c.zip
Export best python version before configure, #545354
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog7
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild79
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r2.ebuild5
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.19.ebuild5
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild72
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild5
6 files changed, 18 insertions, 155 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index db2f1a8b8156..ea41b211eebb 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.193 2015/03/28 13:32:02 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.194 2015/04/12 17:21:04 jlec Exp $
+
+ 12 Apr 2015; Justin Lecher <jlec@gentoo.org> -rb_libtorrent-0.16.17-r1.ebuild,
+ -rb_libtorrent-1.0.2.ebuild, rb_libtorrent-0.16.17-r2.ebuild,
+ rb_libtorrent-0.16.19.ebuild, rb_libtorrent-1.0.3.ebuild:
+ Export best python version before configure, #545354
28 Mar 2015; Justin Lecher <jlec@gentoo.org>
files/rb_libtorrent-1.0.2-python.patch:
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild
deleted file mode 100644
index 09a77cfae0a7..000000000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild,v 1.3 2015/03/03 22:24:13 hwoarang Exp $
-
-EAPI="5"
-PYTHON_DEPEND="python? 2:2.7"
-PYTHON_USE_WITH="threads"
-PYTHON_USE_WITH_OPT="python"
-
-inherit eutils multilib python versionator
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl static-libs test"
-RESTRICT="test"
-
-RDEPEND=">=dev-libs/boost-1.48:=[python?,threads(+)]
- sys-libs/zlib
- examples? ( !net-p2p/mldonkey )
- ssl? ( dev-libs/openssl:= )"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-2.2"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- use python && python_convert_shebangs -r 2 .
- epatch_user
-}
-
-src_configure() {
- local myconf
-
- # bug 441842
- myconf="--disable-silent-rules"
-
- # use multi-threading versions of boost libs
- if has_version '>=dev-libs/boost-1.52.0-r1'; then
- myconf+=" --with-boost-python=boost_python-${PYTHON_ABI}"
- else
- myconf+=" --with-boost-system=boost_system-mt \
- --with-boost-python=boost_python-${PYTHON_ABI}-mt"
- fi
-
- local LOGGING
- use debug && myconf+=" --enable-logging=verbose"
-
- econf $(use_enable debug) \
- $(use_enable test tests) \
- $(use_enable examples) \
- $(use_enable python python-binding) \
- $(use_enable ssl encryption) \
- $(use_enable static-libs static) \
- --with-boost-libdir=/usr/$(get_libdir) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
- dodoc ChangeLog AUTHORS NEWS README
- if use doc; then
- dohtml docs/*
- fi
-}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r2.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r2.ebuild
index 99a5000816d3..8f25d97b1387 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r2.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r2.ebuild,v 1.4 2015/03/23 12:07:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r2.ebuild,v 1.5 2015/04/12 17:21:04 jlec Exp $
EAPI=5
@@ -53,6 +53,9 @@ src_configure() {
$(use_enable python python-binding)
$(usex debug "--enable-logging=verbose" "")
)
+
+ use python && python_setup
+
autotools-utils_src_configure
use python && cd "${BUILD_DIR}"/bindings/python && distutils-r1_src_configure
}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.19.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.19.ebuild
index 696f15f78b68..9c24688694a9 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.19.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.19.ebuild,v 1.2 2015/03/23 12:07:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.19.ebuild,v 1.3 2015/04/12 17:21:04 jlec Exp $
EAPI=5
@@ -53,6 +53,9 @@ src_configure() {
$(use_enable python python-binding)
$(usex debug "--enable-logging=verbose" "")
)
+
+ use python && python_setup
+
autotools-utils_src_configure
use python && cd "${BUILD_DIR}"/bindings/python && distutils-r1_src_configure
}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild
deleted file mode 100644
index 960fe5277c24..000000000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild,v 1.3 2015/03/23 12:07:50 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
-PYTHON_REQ_USE="threads"
-DISTUTILS_OPTIONAL=true
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils multilib distutils-r1
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl static-libs test"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- >=dev-libs/boost-1.53:=[threads]
- sys-libs/zlib
- examples? ( !net-p2p/mldonkey )
- ssl? ( dev-libs/openssl:0= )
- python? (
- ${PYTHON_DEPS}
- dev-libs/boost[python,${PYTHON_USEDEP}]
- )"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-2.2"
-
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${P}-python.patch )
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-src_configure() {
- local myeconfargs=(
- --disable-silent-rules # bug 441842
- --with-boost-libdir=/usr/$(get_libdir)
- $(use_enable debug)
- $(use_enable test tests)
- $(use_enable examples)
- $(use_enable ssl encryption)
- $(use_enable python python-binding)
- $(usex debug "--enable-logging=verbose" "")
- )
- autotools-utils_src_configure
- use python && cd "${BUILD_DIR}"/bindings/python && distutils-r1_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- use python && cd "${BUILD_DIR}"/bindings/python && distutils-r1_src_compile
-}
-
-src_install() {
- use doc && HTML_DOCS=( docs/. )
-
- autotools-utils_src_install
- use python && cd "${BUILD_DIR}"/bindings/python && distutils-r1_src_install
-}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild
index 74a62e0783c2..b5d4fd4c3dbc 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild,v 1.4 2015/03/23 12:07:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild,v 1.5 2015/04/12 17:21:04 jlec Exp $
EAPI=5
@@ -55,6 +55,9 @@ src_configure() {
$(use_enable python python-binding)
$(usex debug "--enable-logging=verbose" "")
)
+
+ use python && python_setup
+
autotools-utils_src_configure
use python && cd "${BUILD_DIR}"/bindings/python && distutils-r1_src_configure
}