summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-02-04 08:37:19 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-02-04 08:37:19 +0000
commit2823c26bcd79bbba5a071f18f319634978778123 (patch)
tree71a924a06be5f440da5e33e107dfba01764b926a /net-libs
parentVersion bump by "Nikoli" at Freenode (diff)
downloadgentoo-2-2823c26bcd79bbba5a071f18f319634978778123.tar.gz
gentoo-2-2823c26bcd79bbba5a071f18f319634978778123.tar.bz2
gentoo-2-2823c26bcd79bbba5a071f18f319634978778123.zip
Finer control on gles2 vs. opengl USE, bug #500150. Actually properly allow ruby21, bug #500230.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/ChangeLog7
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.2.4-r200.ebuild11
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild9
3 files changed, 19 insertions, 8 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index b81df6e8231e..c9a19575eeb0 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.236 2014/02/04 07:15:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.237 2014/02/04 08:37:19 eva Exp $
+
+ 04 Feb 2014; Gilles Dartiguelongue <eva@gentoo.org> webkit-gtk-2.2.4.ebuild,
+ webkit-gtk-2.2.4-r200.ebuild:
+ Finer control on gles2 vs. opengl USE, bug #500150. Actually properly allow
+ ruby21, bug #500230.
04 Feb 2014; Pacho Ramos <pacho@gentoo.org> webkit-gtk-2.2.4-r200.ebuild,
webkit-gtk-2.2.4.ebuild:
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.2.4-r200.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.2.4-r200.ebuild
index 24b381a76f1b..701cfedd850c 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.2.4-r200.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.2.4-r200.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.2.4-r200.ebuild,v 1.3 2014/02/04 07:15:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.2.4-r200.ebuild,v 1.4 2014/02/04 08:37:19 eva Exp $
EAPI="5"
@@ -19,10 +19,11 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd
IUSE="aqua coverage debug +egl +geoloc gles2 +gstreamer +introspection +jit libsecret +opengl spell +webgl"
# bugs 372493, 416331
REQUIRED_USE="
- ^^ ( gles2 opengl )
geoloc? ( introspection )
introspection? ( gstreamer )
gles2? ( egl )
+ webgl? ( ^^ ( gles2 opengl ) )
+ !webgl? ( ?? ( gles2 opengl ) )
"
# use sqlite, svg by default
@@ -162,7 +163,7 @@ src_prepare() {
-i Source/WebKit/gtk/GNUmakefile.am || die
if ! use gstreamer; then
- # webkit2's TestWebKitWebView requires <video> support, bug #128164
+ # webkit2's TestWebKitWebView requires <video> support, upstream bug #128164
sed -e '/Programs\/WebKit2APITests\/TestWebKitWebView/ d' \
-i Tools/TestWebKitAPI/GNUmakefile.am || die
fi
@@ -196,7 +197,9 @@ src_configure() {
local myconf=""
- if has_version "virtual/rubygems[ruby_targets_ruby20]"; then
+ if has_version "virtual/rubygems[ruby_targets_ruby21]"; then
+ myconf="${myconf} RUBY=$(type -P ruby21)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby20]"; then
myconf="${myconf} RUBY=$(type -P ruby20)"
elif has_version "virtual/rubygems[ruby_targets_ruby19]"; then
myconf="${myconf} RUBY=$(type -P ruby19)"
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild
index 9605673a044f..088c4582bcb1 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild,v 1.3 2014/02/04 07:15:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild,v 1.4 2014/02/04 08:37:19 eva Exp $
EAPI="5"
@@ -19,10 +19,11 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd
IUSE="aqua coverage debug +egl +geoloc gles2 +gstreamer +introspection +jit libsecret +opengl spell +webgl"
# bugs 372493, 416331
REQUIRED_USE="
- ^^ ( gles2 opengl )
geoloc? ( introspection )
introspection? ( gstreamer )
gles2? ( egl )
+ webgl? ( ^^ ( gles2 opengl ) )
+ !webgl? ( ?? ( gles2 opengl ) )
"
# use sqlite, svg by default
@@ -201,7 +202,9 @@ src_configure() {
local myconf=""
- if has_version "virtual/rubygems[ruby_targets_ruby20]"; then
+ if has_version "virtual/rubygems[ruby_targets_ruby21]"; then
+ myconf="${myconf} RUBY=$(type -P ruby21)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby20]"; then
myconf="${myconf} RUBY=$(type -P ruby20)"
elif has_version "virtual/rubygems[ruby_targets_ruby19]"; then
myconf="${myconf} RUBY=$(type -P ruby19)"