summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild')
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild
index 9605673a044f..088c4582bcb1 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild,v 1.3 2014/02/04 07:15:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.2.4.ebuild,v 1.4 2014/02/04 08:37:19 eva Exp $
EAPI="5"
@@ -19,10 +19,11 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd
IUSE="aqua coverage debug +egl +geoloc gles2 +gstreamer +introspection +jit libsecret +opengl spell +webgl"
# bugs 372493, 416331
REQUIRED_USE="
- ^^ ( gles2 opengl )
geoloc? ( introspection )
introspection? ( gstreamer )
gles2? ( egl )
+ webgl? ( ^^ ( gles2 opengl ) )
+ !webgl? ( ?? ( gles2 opengl ) )
"
# use sqlite, svg by default
@@ -201,7 +202,9 @@ src_configure() {
local myconf=""
- if has_version "virtual/rubygems[ruby_targets_ruby20]"; then
+ if has_version "virtual/rubygems[ruby_targets_ruby21]"; then
+ myconf="${myconf} RUBY=$(type -P ruby21)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby20]"; then
myconf="${myconf} RUBY=$(type -P ruby20)"
elif has_version "virtual/rubygems[ruby_targets_ruby19]"; then
myconf="${myconf} RUBY=$(type -P ruby19)"