summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-10 20:36:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-10 20:36:40 +0000
commit57b1465a0dc94bcaaed6fd314df60e14e26b37fb (patch)
tree519b96ab2ccddf9fe9b7e99bcad5eccb744e98b8 /media-libs/libvisual
parentAdd the virtualization herd as a co-maintainer (diff)
downloadgentoo-2-57b1465a0dc94bcaaed6fd314df60e14e26b37fb.tar.gz
gentoo-2-57b1465a0dc94bcaaed6fd314df60e14e26b37fb.tar.bz2
gentoo-2-57b1465a0dc94bcaaed6fd314df60e14e26b37fb.zip
Convert to multilib. Stack it for medialibs r10. Remove unneeded glib dependency: It uses pthreads by default and gthreads is only a fallback.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libvisual')
-rw-r--r--media-libs/libvisual/ChangeLog8
-rw-r--r--media-libs/libvisual/libvisual-0.4.0-r3.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/media-libs/libvisual/ChangeLog b/media-libs/libvisual/ChangeLog
index d3e0bf2326ec..7a605a97c579 100644
--- a/media-libs/libvisual/ChangeLog
+++ b/media-libs/libvisual/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libvisual
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/ChangeLog,v 1.48 2013/02/02 22:51:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/ChangeLog,v 1.49 2013/08/10 20:36:39 aballier Exp $
+
+*libvisual-0.4.0-r3 (10 Aug 2013)
+
+ 10 Aug 2013; Alexis Ballier <aballier@gentoo.org> +libvisual-0.4.0-r3.ebuild:
+ Convert to multilib. Stack it for medialibs r10. Remove unneeded glib
+ dependency: It uses pthreads by default and gthreads is only a fallback.
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> libvisual-0.4.0-r2.ebuild:
Add ~arm, wrt bug #449220
diff --git a/media-libs/libvisual/libvisual-0.4.0-r3.ebuild b/media-libs/libvisual/libvisual-0.4.0-r3.ebuild
new file mode 100644
index 000000000000..051e0fbd4ac9
--- /dev/null
+++ b/media-libs/libvisual/libvisual-0.4.0-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/libvisual-0.4.0-r3.ebuild,v 1.1 2013/08/10 20:36:40 aballier Exp $
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+inherit autotools-multilib
+
+DESCRIPTION="Libvisual is an abstraction library that comes between applications and audio visualisation plugins."
+HOMEPAGE="http://libvisual.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug nls static-libs threads"
+
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r9
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-better-altivec-detection.patch
+ "${FILESDIR}"/${P}-inlinedefineconflict.patch
+ )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libvisual-0.4/libvisual/lvconfig.h
+)
+
+src_prepare() {
+ autotools-multilib_src_prepare
+ # autogenerated, causes problems for out of tree builds
+ rm -f libvisual/lvconfig.h || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable nls)
+ $(use_enable threads)
+ $(use_enable debug)
+ )
+ autotools-multilib_src_configure
+}