summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-01-23 13:12:19 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-01-23 13:12:19 +0000
commit32225a69fecf22ff8408a9f649675edc1d1af2d9 (patch)
tree1f159f1d67054361ffb9b0392132ca4dc5e18115 /dev-python
parentRemoved sparc-sources-2.4.21_pre1 (diff)
downloadgentoo-2-32225a69fecf22ff8408a9f649675edc1d1af2d9.tar.gz
gentoo-2-32225a69fecf22ff8408a9f649675edc1d1af2d9.tar.bz2
gentoo-2-32225a69fecf22ff8408a9f649675edc1d1af2d9.zip
commited twisted 1.0.2alpha4
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted/ChangeLog9
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.2_alpha41
-rw-r--r--dev-python/twisted/twisted-1.0.2_alpha4.ebuild33
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 6f90da3bced5..9d54c615ca94 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-python/twisted
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.9 2002/12/13 10:56:45 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.10 2003/01/23 13:12:19 lordvan Exp $
+
+*twisted-1.0.2_alpha4 (23 Jan 2003)
+ 23 Jan 2003; Thomas Raschbacher <lordvan@gentoo.org>: twisted-1.0.2_alpha4.ebuild
+ version bump ~arch masked
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-*twisted-1.0.1-r1 (05 Dec 2002) Thomas Raschbacher <lordvan@gentoo.org>
+*twisted-1.0.1-r1 (05 Dec 2002)
+ 05 Dec 2002; Thomas Raschbacher <lordvan@gentoo.org>: twisted-1.0.1-r1
Added dep for dev-python/pycrypto
Added IUSE
diff --git a/dev-python/twisted/files/digest-twisted-1.0.2_alpha4 b/dev-python/twisted/files/digest-twisted-1.0.2_alpha4
new file mode 100644
index 000000000000..072ecaee7721
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.2_alpha4
@@ -0,0 +1 @@
+MD5 45b7ce23b8d28a1b2f0e212fcf034172 Twisted-1.0.2alpha4.tar.bz2 3832538
diff --git a/dev-python/twisted/twisted-1.0.2_alpha4.ebuild b/dev-python/twisted/twisted-1.0.2_alpha4.ebuild
new file mode 100644
index 000000000000..55f798e11b97
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.2_alpha4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.2_alpha4.ebuild,v 1.1 2003/01/23 13:12:19 lordvan Exp $
+
+S=${WORKDIR}/Twisted-${PV}
+DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+SRC_URI="http://twisted.sourceforge.net/Twisted-1.0.2alpha4.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND="virtual/python
+ >=dev-python/pycrypto-1.9_alpha4"
+RDEPEND="$DEPEND"
+KEYWORDS="~x86 ~alpha ~sparc "
+IUSE=""
+
+inherit distutils
+
+src_install() {
+ distutils_src_install
+
+ # next few lines will install docs: 9.4 megs!
+ dodir /usr/share/doc/${PF}
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+ cd doc
+ cp -r . ${D}/usr/share/doc/${PF}
+ cd ../
+# should be taken care of by the distutils install
+# dodoc README TODO CREDITS
+}
+