summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twisted/twisted-1.0.2_alpha4.ebuild')
-rw-r--r--dev-python/twisted/twisted-1.0.2_alpha4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/twisted/twisted-1.0.2_alpha4.ebuild b/dev-python/twisted/twisted-1.0.2_alpha4.ebuild
new file mode 100644
index 000000000000..55f798e11b97
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.2_alpha4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.2_alpha4.ebuild,v 1.1 2003/01/23 13:12:19 lordvan Exp $
+
+S=${WORKDIR}/Twisted-${PV}
+DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+SRC_URI="http://twisted.sourceforge.net/Twisted-1.0.2alpha4.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND="virtual/python
+ >=dev-python/pycrypto-1.9_alpha4"
+RDEPEND="$DEPEND"
+KEYWORDS="~x86 ~alpha ~sparc "
+IUSE=""
+
+inherit distutils
+
+src_install() {
+ distutils_src_install
+
+ # next few lines will install docs: 9.4 megs!
+ dodir /usr/share/doc/${PF}
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+ cd doc
+ cp -r . ${D}/usr/share/doc/${PF}
+ cd ../
+# should be taken care of by the distutils install
+# dodoc README TODO CREDITS
+}
+