summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-22 05:31:21 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-22 05:31:21 +0000
commitbdd1e2a985614eed16ef7a8ba4f4c9785a42f154 (patch)
treec576fe229a01e78a53f2fe29bc8728a9dd0b75c2 /dev-python/http-parser
parentUpdated makemkv 1.8.0 ebuild to reflect upstreams change in location of icons... (diff)
downloadgentoo-2-bdd1e2a985614eed16ef7a8ba4f4c9785a42f154.tar.gz
gentoo-2-bdd1e2a985614eed16ef7a8ba4f4c9785a42f154.tar.bz2
gentoo-2-bdd1e2a985614eed16ef7a8ba4f4c9785a42f154.zip
Bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/http-parser')
-rw-r--r--dev-python/http-parser/ChangeLog7
-rw-r--r--dev-python/http-parser/http-parser-0.8.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/http-parser/ChangeLog b/dev-python/http-parser/ChangeLog
index 06a40c887d51..4f5b3c3af79e 100644
--- a/dev-python/http-parser/ChangeLog
+++ b/dev-python/http-parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/http-parser
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/ChangeLog,v 1.10 2013/02/09 04:42:38 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/ChangeLog,v 1.11 2013/02/22 05:31:21 patrick Exp $
+
+*http-parser-0.8.1 (22 Feb 2013)
+
+ 22 Feb 2013; Patrick Lauer <patrick@gentoo.org> +http-parser-0.8.1.ebuild:
+ Bump
09 Feb 2013; Mike Gilbert <floppym@gentoo.org> http-parser-0.7.12.ebuild:
Utilize python_install_all.
diff --git a/dev-python/http-parser/http-parser-0.8.1.ebuild b/dev-python/http-parser/http-parser-0.8.1.ebuild
new file mode 100644
index 000000000000..a64398a7dce2
--- /dev/null
+++ b/dev-python/http-parser/http-parser-0.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/http-parser-0.8.1.ebuild,v 1.1 2013/02/22 05:31:21 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="2.5 *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="HTTP request/response parser for python in C"
+HOMEPAGE="http://github.com/benoitc/http-parser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ dev-python/cython"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples
+ insinto usr/share/doc/${P}
+ doins -r examples/
+ fi
+}