summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/http-parser/http-parser-0.8.1.ebuild')
-rw-r--r--dev-python/http-parser/http-parser-0.8.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/http-parser/http-parser-0.8.1.ebuild b/dev-python/http-parser/http-parser-0.8.1.ebuild
new file mode 100644
index 000000000000..a64398a7dce2
--- /dev/null
+++ b/dev-python/http-parser/http-parser-0.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/http-parser-0.8.1.ebuild,v 1.1 2013/02/22 05:31:21 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="2.5 *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="HTTP request/response parser for python in C"
+HOMEPAGE="http://github.com/benoitc/http-parser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ dev-python/cython"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples
+ insinto usr/share/doc/${P}
+ doins -r examples/
+ fi
+}