summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-10-23 07:54:56 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-10-23 07:54:56 +0000
commitcfeedffc1ebc86f84c521482949f026f30b6013d (patch)
treeb46c598258348a6977a30f24cf2ce5b32eb7be8a /dev-php/pecl-ssh2
parentVersion bump, disable tests that require unreleased gobject-introspection. (diff)
downloadgentoo-2-cfeedffc1ebc86f84c521482949f026f30b6013d.tar.gz
gentoo-2-cfeedffc1ebc86f84c521482949f026f30b6013d.tar.bz2
gentoo-2-cfeedffc1ebc86f84c521482949f026f30b6013d.zip
Moved from dev-php5/pecl-ssh2
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-php/pecl-ssh2')
-rw-r--r--dev-php/pecl-ssh2/ChangeLog53
-rw-r--r--dev-php/pecl-ssh2/metadata.xml5
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-0.11.2-r1.ebuild20
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-php/pecl-ssh2/ChangeLog b/dev-php/pecl-ssh2/ChangeLog
new file mode 100644
index 000000000000..33b20da8fa35
--- /dev/null
+++ b/dev-php/pecl-ssh2/ChangeLog
@@ -0,0 +1,53 @@
+# ChangeLog for dev-php5/pecl-ssh2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-ssh2/ChangeLog,v 1.1 2011/10/23 07:54:56 olemarkus Exp $
+
+ 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org>
+ pecl-ssh2-0.11.2-r1.ebuild:
+ Stable on amd64 wrt bug #349659
+
+ 04 Jan 2011; Christian Faulhammer <fauli@gentoo.org>
+ pecl-ssh2-0.11.2-r1.ebuild:
+ stable x86, bug 349659
+
+*pecl-ssh2-0.11.2-r1 (04 Nov 2010)
+*pecl-ssh2-0.11.2 (04 Nov 2010)
+
+ 04 Nov 2010; Matti Bickel <mabi@gentoo.org> -pecl-ssh2-0.11.0.ebuild,
+ +pecl-ssh2-0.11.2.ebuild, +pecl-ssh2-0.11.2-r1.ebuild:
+ add version supporting minor version slotting, version bump
+
+ 14 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
+ pecl-ssh2-0.11.0-r1.ebuild:
+ Stable on amd64 wrt bug #339686
+
+ 14 Oct 2010; Christian Faulhammer <fauli@gentoo.org>
+ pecl-ssh2-0.11.0-r1.ebuild:
+ stable x86, bug 339686
+
+*pecl-ssh2-0.11.0-r1 (29 Dec 2009)
+
+ 29 Dec 2009; Christian Hoffmann <hoffie@gentoo.org>
+ +pecl-ssh2-0.11.0-r1.ebuild, files/pecl-ssh2-0.11.0-php-5.3-compat.patch:
+ new attempt at getting a version which works with 5.2 and 5.3
+
+ 27 Dec 2009; Christian Hoffmann <hoffie@gentoo.org>
+ pecl-ssh2-0.11.0.ebuild:
+ reverting the php-5.3 compatibility change because of bug 298449; this has
+ not been noticed before because the bug only occurs with
+ dev-lang/php[threads]; will make another attempt at fixing the actual bug
+ later
+
+ 24 Dec 2009; Christian Hoffmann <hoffie@gentoo.org>
+ pecl-ssh2-0.11.0.ebuild, +files/pecl-ssh2-0.11.0-php-5.3-compat.patch:
+ php-5.3 compatibility, bug 274512
+
+ 15 Oct 2009; Markus Meier <maekke@gentoo.org> pecl-ssh2-0.11.0.ebuild:
+ amd64/x86 stable, bug #288070
+
+*pecl-ssh2-0.11.0 (11 Aug 2009)
+
+ 11 Aug 2009; Hanno Boeck <hanno@gentoo.org> +pecl-ssh2-0.11.0.ebuild,
+ +metadata.xml:
+ Initial commit of php bindings for libssh2.
+
diff --git a/dev-php/pecl-ssh2/metadata.xml b/dev-php/pecl-ssh2/metadata.xml
new file mode 100644
index 000000000000..40dbb4c4bbaf
--- /dev/null
+++ b/dev-php/pecl-ssh2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-0.11.2-r1.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-0.11.2-r1.ebuild
new file mode 100644
index 000000000000..fc353b6a941c
--- /dev/null
+++ b/dev-php/pecl-ssh2/pecl-ssh2-0.11.2-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-ssh2/pecl-ssh2-0.11.2-r1.ebuild,v 1.1 2011/10/23 07:54:56 olemarkus Exp $
+
+EAPI=3
+
+PHP_EXT_NAME="ssh2"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README ChangeLog"
+
+inherit php-ext-pecl-r2
+
+DESCRIPTION="Provides bindings to the functions of libssh2 which implements the SSH2 protocol."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+DEPEND=">=net-libs/libssh2-0.18"
+RDEPEND="${DEPEND}"