summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/seabios/seabios-1.7.0-r2.ebuild')
-rw-r--r--sys-apps/seabios/seabios-1.7.0-r2.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/sys-apps/seabios/seabios-1.7.0-r2.ebuild b/sys-apps/seabios/seabios-1.7.0-r2.ebuild
deleted file mode 100644
index 8eab911..0000000
--- a/sys-apps/seabios/seabios-1.7.0-r2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/seabios-1.7.0.ebuild,v 1.1 2012/06/28 15:09:36 cardoe Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2"
-
-inherit python
-
-#BACKPORTS=1
-
-if [[ ${PV} = *9999* || ! -z "${EGIT_COMMIT}" ]]; then
- EGIT_REPO_URI="git://git.seabios.org/seabios.git"
- inherit git-2
- KEYWORDS=""
- SRC_URI=""
-else
- KEYWORDS="~amd64"
- SRC_URI="http://www.linuxtogo.org/~kevin/SeaBIOS/${PN}-${PV}.tar.gz
- ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${PN}-${PV}-bp-${BACKPORTS}.tar.bz2}"
-fi
-
-DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
-HOMEPAGE="http://www.seabios.org"
-
-LICENSE="LGPL-3 GPL-3"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- !app-emulation/qemu
- !<=app-emulation/qemu-kvm-0.15.0"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- sed 's/$(Q)$(MAKE)/$(Q)+$(MAKE)/' -i "${S}/Makefile"
- if [[ -z "${EGIT_COMMIT}" ]]; then
- sed -e "s/VERSION=.*/VERSION=${PV}/" \
- -i "${S}/Makefile"
- else
- sed -e "s/VERSION=.*/VERSION=${PV}_pre${EGIT_COMMIT}/" \
- -i "${S}/Makefile"
- fi
-}
-
-src_configure() {
- :
-}
-
-src_compile() {
- emake out/bios.bin
-# emake out/vgabios.bin
-}
-
-src_install() {
- insinto /usr/share/seabios
- doins out/bios.bin
-# doins out/vgabios.bin
-}