summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Kuhn <wuodan@hispeed.ch>2012-06-27 20:20:41 +0200
committerStefan Kuhn <wuodan@hispeed.ch>2012-06-27 20:20:41 +0200
commita473f219b3c83c176fa9243376c2f965bf65040c (patch)
tree474be44f03e5eaea314820f95bce4351dd98ee13
downloadwuodan-a473f219b3c83c176fa9243376c2f965bf65040c.tar.gz
wuodan-a473f219b3c83c176fa9243376c2f965bf65040c.tar.bz2
wuodan-a473f219b3c83c176fa9243376c2f965bf65040c.zip
initial commit
only packages not already in tree
-rw-r--r--app-text/peg-multimarkdown-latex-support/Manifest2
-rw-r--r--app-text/peg-multimarkdown-latex-support/metadata.xml15
-rw-r--r--app-text/peg-multimarkdown-latex-support/peg-multimarkdown-latex-support-9999.ebuild38
-rw-r--r--app-text/peg-multimarkdown/Manifest8
-rw-r--r--app-text/peg-multimarkdown/files/peg-multimarkdown-3.6-cflags.patch104
-rw-r--r--app-text/peg-multimarkdown/files/peg-multimarkdown-9999-cflags.patch104
-rw-r--r--app-text/peg-multimarkdown/files/peg-multimarkdown-9999-doc.patch30
-rw-r--r--app-text/peg-multimarkdown/files/peg-multimarkdown-9999-xslt.patch82
-rw-r--r--app-text/peg-multimarkdown/metadata.xml28
-rw-r--r--app-text/peg-multimarkdown/peg-multimarkdown-3.6.ebuild75
-rw-r--r--app-text/peg-multimarkdown/peg-multimarkdown-9999.ebuild216
-rw-r--r--profiles/repo_name1
12 files changed, 703 insertions, 0 deletions
diff --git a/app-text/peg-multimarkdown-latex-support/Manifest b/app-text/peg-multimarkdown-latex-support/Manifest
new file mode 100644
index 0000000..a62422f
--- /dev/null
+++ b/app-text/peg-multimarkdown-latex-support/Manifest
@@ -0,0 +1,2 @@
+EBUILD peg-multimarkdown-latex-support-9999.ebuild 987 SHA1 65b49a2834c704be3f09d1c55d30b9f6e185de2a SHA256 45fa4c0c7c4c210e3994f08d7e3d6c7984fab5c59dbb58de676d55beda738d7f
+MISC metadata.xml 1087 SHA1 1e6e7d1b36dafe8cef27e4a181543fe520115902 SHA256 aebb83c4a021470ac25e777849d9051bdd4462bc9b3dbe7f6662a5677f5f786e
diff --git a/app-text/peg-multimarkdown-latex-support/metadata.xml b/app-text/peg-multimarkdown-latex-support/metadata.xml
new file mode 100644
index 0000000..2fec08c
--- /dev/null
+++ b/app-text/peg-multimarkdown-latex-support/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>wuodan@hispeed.ch</email>
+ <name>Stefan Kuhn</name>
+ </maintainer>
+ <longdescription lang="en">
+ peg-multimarkdown is a program to convert plain text into HTML or LaTeX. This project includes some default template files that can be used to create certain types of documents using LaTeX.
+
+ You are not limited to using these classes or templates. You can create your own template files, or just embed your LaTeX commands within comments in your MultiMarkdown document itself. If you find yourself creating similar documents over and over again, however, you may be better off creating a few templates you can simply call with the LaTeX Input metadata fields in MultiMarkdown.
+
+ These files were designed to handle some of the common metadata fields in a consistent way, an to implement some defaults that should prevent errors if you leave out important metadata (substituting Title, Author, etc).
+ </longdescription>
+</pkgmetadata>
diff --git a/app-text/peg-multimarkdown-latex-support/peg-multimarkdown-latex-support-9999.ebuild b/app-text/peg-multimarkdown-latex-support/peg-multimarkdown-latex-support-9999.ebuild
new file mode 100644
index 0000000..cc939b7
--- /dev/null
+++ b/app-text/peg-multimarkdown-latex-support/peg-multimarkdown-latex-support-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit latex-package git-2
+
+DESCRIPTION="Default templates to create certain types of LaTex documents with MultiMarkdown"
+HOMEPAGE="http://http://fletcherpenney.net/multimarkdown"
+SRC_URI=""
+
+EGIT_REPO_URI="git://github.com/fletcher/${PN}.git"
+
+LICENSE="|| ( GPL-2 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# These are the dependencies to create the peg-multimarkdown docu.
+# More might be needed, please report is something is missing
+DEPEND="
+ virtual/latex-base
+"
+# post-depend: if this is installed first, then peg-mmd can run some tests
+# some files are also needed later to create docu
+PDEPEND="${DEPEND} ${CATEGORY}/peg-multimarkdown[latex]"
+RDEPEND="
+ dev-texlive/texlive-latexextra
+ dev-tex/glossaries
+ dev-tex/xcolor
+"
+
+src_install()
+{
+ # install latex support
+ insinto ${TEXMF}/tex/latex/${PN}
+ doins * || die "Installation of $PN failed"
+}
diff --git a/app-text/peg-multimarkdown/Manifest b/app-text/peg-multimarkdown/Manifest
new file mode 100644
index 0000000..8cac99c
--- /dev/null
+++ b/app-text/peg-multimarkdown/Manifest
@@ -0,0 +1,8 @@
+AUX peg-multimarkdown-3.6-cflags.patch 2870 SHA1 82aab3b6da54a2a790e07a6f7ce441a489cd2390 SHA256 6704ee5940f0e52c3dfd304a7ce966386d119186a1bf4aac46063d5d81345804
+AUX peg-multimarkdown-9999-cflags.patch 2870 SHA1 82aab3b6da54a2a790e07a6f7ce441a489cd2390 SHA256 6704ee5940f0e52c3dfd304a7ce966386d119186a1bf4aac46063d5d81345804
+AUX peg-multimarkdown-9999-doc.patch 1337 SHA1 0a5f5a439040033ce5e1b43ef229cbf96e730378 SHA256 a2d6e7246ce5a369284f53097837735e3fa8036bdcf3db001ac1fe0956f44876
+AUX peg-multimarkdown-9999-xslt.patch 2166 SHA1 f14eb7f5d9be31eee95acd8940023d52b0e2a711 SHA256 b7db27dbbddbade8cf259a34e63d46805ef71cdc31ece51576987808de280576
+DIST peg-multimarkdown-3.6.tar.gz 141026 SHA1 d2fed777dcd5f72ba8cfa759278092a7519bf986 SHA256 ccdf71ec242d2319487dee6778a1cca8f6d772716cdc066c092570e4ee27cf74
+EBUILD peg-multimarkdown-3.6.ebuild 2143 SHA1 5d7412fcecf42abe4908864db5ab32220e6fa3db SHA256 bca764713040781e9cae7c7e2525177f5570f86a8d6d0d4d41fc0d4b8335621a
+EBUILD peg-multimarkdown-9999.ebuild 6670 SHA1 8a15653d6e773d4cd4dc6e093de5ca2489d392ef SHA256 d85d72bfb097056bcbee662ac5aa5424d1aac71678ad1f2ca8b6e7abf9dd123d
+MISC metadata.xml 2351 SHA1 c701ef6eb1585322d7989c29689b734a7d933092 SHA256 375dd6d9cda5417275975ec3e5662d015f9ad4ab6a28387b1f491a055a5f35b6
diff --git a/app-text/peg-multimarkdown/files/peg-multimarkdown-3.6-cflags.patch b/app-text/peg-multimarkdown/files/peg-multimarkdown-3.6-cflags.patch
new file mode 100644
index 0000000..4a6802a
--- /dev/null
+++ b/app-text/peg-multimarkdown/files/peg-multimarkdown-3.6-cflags.patch
@@ -0,0 +1,104 @@
+--- Makefile 2012-05-05 17:08:42.000000000 +0200
++++ Makefile 2012-06-17 16:59:29.289745982 +0200
+@@ -18,26 +18,27 @@ else
+ FINALNOTES=Build complete.
+ endif
+
+-CFLAGS ?= -Wall -O3 -include GLibFacade.h -I ./ -D MD_USE_GET_OPT=1
++OFLAGS = $(CFLAGS)
++LDFLAGS += -include GLibFacade.h -I ./ -D MD_USE_GET_OPT=1
+ ifeq ($(UNAME), SunOS)
+ CC = gcc
+ # Use of <stdbool.h> is valid only in a c99 compilation environment
+- CFLAGS += --std=c99
++ OFLAGS += --std=c99
+ else
+- CFLAGS += -ansi
++ OFLAGS += -ansi
+ endif
+
+ # make ARCH=ppc
+ # build for ppc architecture - Only works on machines with PPC compilation support installed
+ # probably only Snow Leopard machines with Xcode 3 installed
+ ifeq ($(ARCH), ppc)
+- CFLAGS += -arch ppc
++ OFLAGS += -arch ppc
+ endif
+
+ # make ARCH=i386
+ # build for i386 architecture - useful with older machines or those running 10.4?
+ ifeq ($(ARCH), i386)
+- CFLAGS += -arch i386
++ OFLAGS += -arch i386
+ endif
+
+ OBJS=markdown_parser.o markdown_output.o markdown_lib.o GLibFacade.o
+@@ -49,18 +50,18 @@ PKG_CONFIG = pkg-config
+ ALL : $(PROGRAM)
+
+ $(PEGDIR):
+- cp -r $(PEGDIR_ORIG) $(PEGDIR) ; \
+- patch -p1 < peg-memory-fix.patch ; \
+- patch -p1 < peg-exe-ext.patch
++ # cp -r $(PEGDIR_ORIG) $(PEGDIR) ; \
++ # patch -p1 < peg-memory-fix.patch ; \
++ # patch -p1 < peg-exe-ext.patch
+
+ $(LEG): $(PEGDIR)
+ CC=gcc $(MAKE) -C $(PEGDIR)
+
+ %.o : %.c markdown_peg.h
+- $(CC) -c $(CFLAGS) -o $@ $<
++ $(CC) -c $(OFLAGS) -o $@ $<
+
+ $(PROGRAM) : markdown.c $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS) $<
++ $(CC) $(OFLAGS) $(LDFLAGS) -o $@ $(OBJS) $<
+ @echo "$(FINALNOTES)"
+
+ markdown_parser.c : markdown_parser.leg $(LEG) markdown_peg.h parsing_functions.c utility_functions.c
+--- peg/Makefile 2012-06-17 17:07:40.089725367 +0200
++++ peg/Makefile 2012-06-17 17:00:54.691742397 +0200
+@@ -1,5 +1,6 @@
+-CFLAGS = -g -Wall $(OFLAGS) $(XFLAGS)
+-OFLAGS = -O3 -DNDEBUG
++# CFLAGS = -g -Wall $(OFLAGS) $(XFLAGS)
++# OFLAGS = -O3 -DNDEBUG
++CFLAGS += -DNDEBUG
+ #OFLAGS = -pg
+
+ OBJS = tree.o compile.o
+--- peg/examples/Makefile 2012-06-17 17:07:40.089725367 +0200
++++ peg/examples/Makefile 2012-06-17 17:02:10.977739219 +0200
+@@ -1,6 +1,6 @@
+ EXAMPLES = test rule accept wc dc dcv calc basic
+
+-CFLAGS = -g -O3
++CFLAGS += -g
+
+ DIFF = diff
+ TEE = cat >
+--- peg-0.1.4/Makefile 2012-06-17 17:07:40.093725369 +0200
++++ peg-0.1.4/Makefile 2012-06-17 17:01:27.767741069 +0200
+@@ -1,8 +1,9 @@
+ PEG = peg$(X)
+ LEG = leg$(X)
+
+-CFLAGS = -g -Wall $(OFLAGS) $(XFLAGS)
+-OFLAGS = -O3 -DNDEBUG
++# CFLAGS = -g -Wall $(OFLAGS) $(XFLAGS)
++# OFLAGS = -O3 -DNDEBUG
++CFLAGS += -DNDEBUG
+ #OFLAGS = -pg
+
+ OBJS = tree.o compile.o
+--- peg-0.1.4/examples/Makefile 2012-05-05 17:08:42.000000000 +0200
++++ peg-0.1.4/examples/Makefile 2012-06-17 17:02:27.055738544 +0200
+@@ -1,6 +1,6 @@
+ EXAMPLES = test rule accept wc dc dcv calc basic
+
+-CFLAGS = -g -O3
++CFLAGS += -g
+
+ DIFF = diff
+ TEE = cat >
diff --git a/app-text/peg-multimarkdown/files/peg-multimarkdown-9999-cflags.patch b/app-text/peg-multimarkdown/files/peg-multimarkdown-9999-cflags.patch
new file mode 100644
index 0000000..4a6802a
--- /dev/null
+++ b/app-text/peg-multimarkdown/files/peg-multimarkdown-9999-cflags.patch
@@ -0,0 +1,104 @@
+--- Makefile 2012-05-05 17:08:42.000000000 +0200
++++ Makefile 2012-06-17 16:59:29.289745982 +0200
+@@ -18,26 +18,27 @@ else
+ FINALNOTES=Build complete.
+ endif
+
+-CFLAGS ?= -Wall -O3 -include GLibFacade.h -I ./ -D MD_USE_GET_OPT=1
++OFLAGS = $(CFLAGS)
++LDFLAGS += -include GLibFacade.h -I ./ -D MD_USE_GET_OPT=1
+ ifeq ($(UNAME), SunOS)
+ CC = gcc
+ # Use of <stdbool.h> is valid only in a c99 compilation environment
+- CFLAGS += --std=c99
++ OFLAGS += --std=c99
+ else
+- CFLAGS += -ansi
++ OFLAGS += -ansi
+ endif
+
+ # make ARCH=ppc
+ # build for ppc architecture - Only works on machines with PPC compilation support installed
+ # probably only Snow Leopard machines with Xcode 3 installed
+ ifeq ($(ARCH), ppc)
+- CFLAGS += -arch ppc
++ OFLAGS += -arch ppc
+ endif
+
+ # make ARCH=i386
+ # build for i386 architecture - useful with older machines or those running 10.4?
+ ifeq ($(ARCH), i386)
+- CFLAGS += -arch i386
++ OFLAGS += -arch i386
+ endif
+
+ OBJS=markdown_parser.o markdown_output.o markdown_lib.o GLibFacade.o
+@@ -49,18 +50,18 @@ PKG_CONFIG = pkg-config
+ ALL : $(PROGRAM)
+
+ $(PEGDIR):
+- cp -r $(PEGDIR_ORIG) $(PEGDIR) ; \
+- patch -p1 < peg-memory-fix.patch ; \
+- patch -p1 < peg-exe-ext.patch
++ # cp -r $(PEGDIR_ORIG) $(PEGDIR) ; \
++ # patch -p1 < peg-memory-fix.patch ; \
++ # patch -p1 < peg-exe-ext.patch
+
+ $(LEG): $(PEGDIR)
+ CC=gcc $(MAKE) -C $(PEGDIR)
+
+ %.o : %.c markdown_peg.h
+- $(CC) -c $(CFLAGS) -o $@ $<
++ $(CC) -c $(OFLAGS) -o $@ $<
+
+ $(PROGRAM) : markdown.c $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS) $<
++ $(CC) $(OFLAGS) $(LDFLAGS) -o $@ $(OBJS) $<
+ @echo "$(FINALNOTES)"
+
+ markdown_parser.c : markdown_parser.leg $(LEG) markdown_peg.h parsing_functions.c utility_functions.c
+--- peg/Makefile 2012-06-17 17:07:40.089725367 +0200
++++ peg/Makefile 2012-06-17 17:00:54.691742397 +0200
+@@ -1,5 +1,6 @@
+-CFLAGS = -g -Wall $(OFLAGS) $(XFLAGS)
+-OFLAGS = -O3 -DNDEBUG
++# CFLAGS = -g -Wall $(OFLAGS) $(XFLAGS)
++# OFLAGS = -O3 -DNDEBUG
++CFLAGS += -DNDEBUG
+ #OFLAGS = -pg
+
+ OBJS = tree.o compile.o
+--- peg/examples/Makefile 2012-06-17 17:07:40.089725367 +0200
++++ peg/examples/Makefile 2012-06-17 17:02:10.977739219 +0200
+@@ -1,6 +1,6 @@
+ EXAMPLES = test rule accept wc dc dcv calc basic
+
+-CFLAGS = -g -O3
++CFLAGS += -g
+
+ DIFF = diff
+ TEE = cat >
+--- peg-0.1.4/Makefile 2012-06-17 17:07:40.093725369 +0200
++++ peg-0.1.4/Makefile 2012-06-17 17:01:27.767741069 +0200
+@@ -1,8 +1,9 @@
+ PEG = peg$(X)
+ LEG = leg$(X)
+
+-CFLAGS = -g -Wall $(OFLAGS) $(XFLAGS)
+-OFLAGS = -O3 -DNDEBUG
++# CFLAGS = -g -Wall $(OFLAGS) $(XFLAGS)
++# OFLAGS = -O3 -DNDEBUG
++CFLAGS += -DNDEBUG
+ #OFLAGS = -pg
+
+ OBJS = tree.o compile.o
+--- peg-0.1.4/examples/Makefile 2012-05-05 17:08:42.000000000 +0200
++++ peg-0.1.4/examples/Makefile 2012-06-17 17:02:27.055738544 +0200
+@@ -1,6 +1,6 @@
+ EXAMPLES = test rule accept wc dc dcv calc basic
+
+-CFLAGS = -g -O3
++CFLAGS += -g
+
+ DIFF = diff
+ TEE = cat >
diff --git a/app-text/peg-multimarkdown/files/peg-multimarkdown-9999-doc.patch b/app-text/peg-multimarkdown/files/peg-multimarkdown-9999-doc.patch
new file mode 100644
index 0000000..bb3d992
--- /dev/null
+++ b/app-text/peg-multimarkdown/files/peg-multimarkdown-9999-doc.patch
@@ -0,0 +1,30 @@
+--- Makefile 2012-06-19 18:36:29.122777560 +0200
++++ Makefile 2012-06-19 18:38:24.910775119 +0200
+@@ -178,19 +178,25 @@
+ /usr/local/bin/platypus -D -a 'MMD to OPML' -o 'Text Window' -p '/bin/sh' -V '3.0' -I 'net.fletcherpenney.MMD2OPML' -X '*' -T '****|fold' -N 'PATH=/usr/local/bin' -c 'scripts/mmd2opml' 'drag/MMD2OPML.app'; \
+ /usr/local/bin/platypus -D -a 'MMD to ODF' -o 'Text Window' -p '/bin/sh' -V '3.0' -I 'net.fletcherpenney.MMD2ODF' -X '*' -T '****|fold' -N 'PATH=/usr/local/bin' -c 'scripts/mmd2odf' 'drag/MMD2ODF.app';
+
+-# Create HTML and PDF (if latex installed) documentation
++# Create HTML documentation
+ docs: $(PROGRAM)
+ cd documentation; \
+ ../Support/Utilities/mmd_merge.pl index.txt > manual.txt; \
+ mkdir -p ../manual; \
+ ../multimarkdown manual.txt > ../manual/index.html; \
++ rm ../documentation/manual.t*;
++
++# Create PDF documentation (requires latex, etc.)
++docs-latex: $(PROGRAM)
++ cd documentation; \
++ ../Support/Utilities/mmd_merge.pl index.txt > manual.txt; \
++ mkdir -p ../manual; \
+ ../multimarkdown -b -t latex manual.txt; \
+ latexmk -pdf manual.tex; \
+ latexmk -c manual.tex; \
+ mv manual.pdf ../manual/mmd-manual.pdf; \
+ rm ../documentation/manual.t*;
+
+-
+ # For me to push updated documentation to my github site
+ docs-live: docs
+ cd manual; git add mmd-manual.pdf index.html; \
diff --git a/app-text/peg-multimarkdown/files/peg-multimarkdown-9999-xslt.patch b/app-text/peg-multimarkdown/files/peg-multimarkdown-9999-xslt.patch
new file mode 100644
index 0000000..b15bf4a
--- /dev/null
+++ b/app-text/peg-multimarkdown/files/peg-multimarkdown-9999-xslt.patch
@@ -0,0 +1,82 @@
+From 72d46151fd0d3456305fb42378f54b604373a2a3 Mon Sep 17 00:00:00 2001
+From: stefan <stefan@halley.(none)>
+Date: Wed, 13 Jun 2012 05:51:59 +0200
+Subject: [PATCH] Patch for Gentoo installation
+
+Path for XSLT-templates is altered in the scripts
+---
+ Support/bin/mmd-xslt | 2 +-
+ Support/bin/mmd2tex-xslt | 2 +-
+ Support/bin/opml2html | 2 +-
+ Support/bin/opml2mmd | 2 +-
+ Support/bin/opml2tex | 2 +-
+ 5 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/Support/bin/mmd-xslt b/Support/bin/mmd-xslt
+index c67f09c..2b66679 100755
+--- a/Support/bin/mmd-xslt
++++ b/Support/bin/mmd-xslt
+@@ -14,7 +14,7 @@ export PATH="/usr/local/bin:$PATH"
+
+
+ # Locate XSLT directory
+-xslt_path=`dirname "$0"`
++xslt_path="/usr/share/peg-multimarkdown/XSLT/"
+
+
+ # Define subroutine to find proper XSLT to use
+diff --git a/Support/bin/mmd2tex-xslt b/Support/bin/mmd2tex-xslt
+index f6a8550..7e15dc8 100755
+--- a/Support/bin/mmd2tex-xslt
++++ b/Support/bin/mmd2tex-xslt
+@@ -14,7 +14,7 @@ export PATH="/usr/local/bin:$PATH"
+
+
+ # Locate XSLT directory
+-xslt_path=`dirname "$0"`
++xslt_path="/usr/share/peg-multimarkdown/XSLT/"
+
+
+ # Define subroutine to find proper XSLT to use
+diff --git a/Support/bin/opml2html b/Support/bin/opml2html
+index d3dd133..6962ad1 100755
+--- a/Support/bin/opml2html
++++ b/Support/bin/opml2html
+@@ -11,7 +11,7 @@
+ export PATH="/usr/local/bin:$PATH"
+
+ # Locate XSLT directory
+-xslt_path=`dirname "$0"`
++xslt_path="/usr/share/peg-multimarkdown/XSLT/"
+
+ if [ $# = 0 ]
+ then
+diff --git a/Support/bin/opml2mmd b/Support/bin/opml2mmd
+index f97fbe7..5a4c3db 100755
+--- a/Support/bin/opml2mmd
++++ b/Support/bin/opml2mmd
+@@ -11,7 +11,7 @@
+ export PATH="/usr/local/bin:$PATH"
+
+ # Locate XSLT directory
+-xslt_path=`dirname "$0"`
++xslt_path="/usr/share/peg-multimarkdown/XSLT/"
+
+ if [ $# = 0 ]
+ then
+diff --git a/Support/bin/opml2tex b/Support/bin/opml2tex
+index 6c460b4..3a81bd5 100755
+--- a/Support/bin/opml2tex
++++ b/Support/bin/opml2tex
+@@ -11,7 +11,7 @@
+ export PATH="/usr/local/bin:$PATH"
+
+ # Locate XSLT directory
+-xslt_path=`dirname "$0"`
++xslt_path="/usr/share/peg-multimarkdown/XSLT/"
+
+ if [ $# = 0 ]
+ then
+--
+1.7.3.4
+
diff --git a/app-text/peg-multimarkdown/metadata.xml b/app-text/peg-multimarkdown/metadata.xml
new file mode 100644
index 0000000..a2fff38
--- /dev/null
+++ b/app-text/peg-multimarkdown/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>wuodan@hispeed.ch</email>
+ <name>Stefan Kuhn</name>
+ </maintainer>
+ <longdescription lang="en">
+ MultiMarkdown, or MMD, is a tool to help turn minimally marked-up plain text into well formatted documents, including HTML, PDF (by way of LaTeX), OPML, or OpenDocument (specifically, Flat OpenDocument or .fodt, which can in turn be converted into RTF, Microsoft Word, or virtually any other word-processing format).
+
+ MMD is a superset of the Markdown syntax, originally created by John Gruber. It adds multiple syntax features (tables, footnotes, and citations, to name a few), in addition to the various output formats listed above (Markdown only creates HTML). Additionally, it builds in ?smart? typography for various languages (proper left- and right-sided quotes, for example).
+
+ MultiMarkdown was originally a fork of the Markdown Perl code, but as of version 3.0 has been rewritten as a fork of peg-markdown by John MacFarlane, written in C. It can be compiled for any major operating system, and as a native binary runs much faster than the Perl version it replaces. Many thanks to John for creating a great program, and sharing the source with the github community. MultiMarkdown 3.0 would not be possible without his efforts!
+ </longdescription>
+ <use>
+ <!-- flags test and latex are general use flags, we can use that description there -->
+ <flag name="shortcuts">Adds a few utility scripts in the bin directory. </flag>
+ <!--
+ TODO:
+ Test if the latex flag should be recommended for better LaTex support with the perl-conversions flag.
+ latex flag is necessary to make docs in peg-mmd, so the created latex fiels might relly on the latex templates ...
+ -->
+ <flag name="perl-conversions">Adds perl-scripts for conversions to other formats (XHTML, LaTex, OPML, ODF) and MMD convenience scripts.</flag>
+ <flag name="latex">Adds default template files that can be used to create certain types of documents using LaTeX (typesetting package).</flag>
+ <flag name="xslt">Adds support for XSLT including utility scripts.</flag>
+ <flag name="doc">Adds HTML documentation. If used with latex flag, it also creates a more convenient PDF documentation.</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-text/peg-multimarkdown/peg-multimarkdown-3.6.ebuild b/app-text/peg-multimarkdown/peg-multimarkdown-3.6.ebuild
new file mode 100644
index 0000000..7e31be7
--- /dev/null
+++ b/app-text/peg-multimarkdown/peg-multimarkdown-3.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="MMD is a superset of the Markdown syntax (more syntax features & output formats)"
+HOMEPAGE="http://http://fletcherpenney.net/multimarkdown"
+SRC_URI="https://github.com/fletcher/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="shortcuts latex"
+
+DEPEND=""
+RDEPEND="latex? ( ${CATEGORY}/${PN}-latex-support )"
+
+# custom variables
+DEST_DIR_EXE="/usr/bin"
+DEST_DIR_XSLT_TEMPL="/usr/share/${PN}/XSLT/"
+
+# known file collision with sys-fs/mtools on file /usr/bin/mmd
+# this is not fatal, the script is only a simple shortcut, so we just skip the
+# file ... mmd2all mmd2pdf are also excluded (todo re-test them)
+SHORTCUTS_LIST="mmd2tex mmd2opml mmd2odf"
+
+src_prepare() {
+ # ./Makefile patches ./peg-0.1.4/Makefile
+ # this does not work if the Makefile was already patched
+ # so this step from Makefile is done here
+ # (easier then patching .patch file)
+ cp -r peg-0.1.4 peg
+ epatch -p1 peg-memory-fix.patch
+ epatch -p1 peg-exe-ext.patch
+ # now patch cflags
+ epatch "${FILESDIR}/${P}-cflags.patch"
+}
+
+src_install()
+{
+ insinto ${DEST_DIR_EXE}
+ einfo "Installing multimarkdown binary to ${DEST_DIR_EXE}/multimarkdown ..."
+ dobin multimarkdown || die "Install failed"
+
+ if use shortcuts ; then
+ einfo "Installing shortcuts for ${PN}"
+ exeinto ${DEST_DIR_EXE}
+ for file in ${SHORTCUTS_LIST}; do
+ # einfo "Installing ${file} to ${DEST_DIR_EXE}/${file} ..."
+ doexe scripts/${file} || die "Installation of script ${file} failed!"
+ done
+ fi
+}
+
+pkg_postinst()
+{
+ elog ""
+ elog "*** ${PN} was successfully installed. ***"
+ elog "Type \"multimarkdown -h\" or \"multimarkdown file.txt\" to start using it."
+ if use shortcuts; then
+ elog "The following additional shortcuts were also installed:"
+ elog "${SHORTCUTS_LIST}."
+ elog "The shortcut \"mmd\" was not installed due to known file"
+ elog "collision with sys-fs/mtools on file /usr/bin/mmd"
+ fi
+ elog ""
+}
+
+pkg_info()
+{
+ einfo "`${ROOT}${DEST_DIR_EXE}/multimarkdown -v`"
+}
diff --git a/app-text/peg-multimarkdown/peg-multimarkdown-9999.ebuild b/app-text/peg-multimarkdown/peg-multimarkdown-9999.ebuild
new file mode 100644
index 0000000..a01dd99
--- /dev/null
+++ b/app-text/peg-multimarkdown/peg-multimarkdown-9999.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit git-2 eutils
+
+DESCRIPTION="MMD is a superset of the Markdown syntax (more syntax features & output formats)"
+HOMEPAGE="http://http://fletcherpenney.net/multimarkdown"
+SRC_URI=""
+
+EGIT_REPO_URI="git://github.com/fletcher/${PN}.git"
+
+LICENSE="|| ( GPL-2 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="shortcuts doc perl-conversions latex xslt test"
+
+DEPEND="
+ doc? (
+ dev-lang/perl
+ latex? (
+ dev-tex/latexmk
+ )
+ )
+ test? (
+ dev-lang/perl
+ app-text/htmltidy
+ )"
+RDEPEND="
+ perl-conversions? ( dev-lang/perl )
+ xslt? ( dev-libs/libxslt )
+ latex? ( ${CATEGORY}/${PN}-latex-support )
+"
+# peg-multimarkdown-latex-support is is not included as git sub-module
+# it requires a separate git clone thus a separate pkg
+if use test || use xslt || use perl-conversions || use doc; then
+ EGIT_HAS_SUBMODULES="Y"
+fi
+
+# custom variables
+DEST_DIR_EXE="/usr/bin"
+DEST_DIR_XSLT_TEMPL="/usr/share/${PN}/XSLT/"
+
+# known file collision with sys-fs/mtools on file /usr/bin/mmd
+# this is not fatal, the script is only a simple shortcut, so we just skip the
+# file ... mmd2all mmd2pdf are also excluded (todo re-test them)
+SHORTCUTS_LIST="mmd2tex mmd2opml mmd2odf"
+
+# mmd2RTF.pl : not included. RTF support is not official
+# and would use "Apples textutil package" ...
+# MMD-Support/Utilities/{ table_cleanup.pl mmd_merge.pl}
+# also not added. Seem to be internal scripts, some tests for mmd_merge.pl
+# failed.
+PERLSCRIPTS_LIST="mmd2XHTML.pl mmd2LaTeX.pl mmd2OPML.pl mmd2ODF.pl"
+
+# prep_tufte.sh is not included, it would require perl and seems old
+XSLTSCRIPTS_LIST="mmd-xslt mmd2tex-xslt opml2html opml2mmd opml2tex"
+
+pkg_setup()
+{
+ # detect FEATURES with "nodoc" as this will prevent doc from being installed
+ if use doc && has nodoc $FEATURES; then
+ die "FEATURES contains \"nodoc\" thus the \"doc\" flag cannot be used"
+ fi
+}
+
+src_prepare()
+{ # ./Makefile patches ./peg-0.1.4/Makefile
+ # this does not work if the Makefile was already patched
+ # so this step from Makefile is done here
+ # (easier then patching .patch file)
+ cp -r peg-0.1.4 peg; \
+ epatch -p1 peg-memory-fix.patch; \
+ epatch -p1 peg-exe-ext.patch || die "Patching of ${PN} failed!"
+ # now patch cflags
+ epatch "${FILESDIR}/${P}-cflags.patch"
+
+ if use xslt; then
+ einfo "XSLT support requires patching of some scripts (path to XSLT templates)"
+ epatch "${FILESDIR}/${P}-xslt.patch" || die "Patching of XSLT scripts for ${PN} failed!"
+ fi
+
+ if use doc; then
+ epatch "${FILESDIR}/${P}-doc.patch" || die "Patching of Makefile for ${PN} failed!"
+ fi
+ # rename a file to avoid an error when testing
+ if use test && [ -f "MarkdownTest/MultiMarkdownTests/BibTex.text" ]; then
+ einfo "Renaming file BibTex.text to BibTeX.text ..."
+ mv "MarkdownTest/MultiMarkdownTests/BibTex.text" "MarkdownTest/MultiMarkdownTests/BibTeX.text"
+ fi
+}
+
+src_compile() {
+ if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
+ emake || die "emake failed"
+ # compile documentation
+ if use doc; then
+ einfo "Compiling documentation ..."
+ emake docs || die "emake docs failed!"
+ if use latex; then
+ emake docs-latex || die "emake docs-latex failed!"
+ fi
+ einfo "Done compiling documentation."
+ fi
+ fi
+}
+
+src_test()
+{
+ einfo "Now running tests for package ${PN}"
+ einfo "It is considered \"normal\" for some tests to fail, but at least one should pass ..."
+ for test_phase in test mmd-test compat-test latex-test ; do
+ # only run the latex test with latex use flag
+ if [ "$test_phase" != "latex-test" ] || use latex ; then
+ if emake -j1 $test_phase -n &> /dev/null; then
+ einfo ">>> Test phase 2 [${test_phase}]: ${CATEGORY}/${PF}"
+ if ! emake -j1 $test_phase; then
+ has test $FEATURES && die "Make ${test_phase} failed. See above for details."
+ fi
+ fi
+ fi
+ done
+ einfo "Done running tests for package ${PN}"
+}
+
+src_install()
+{
+ insinto ${DEST_DIR_EXE}
+ einfo "Installing multimarkdown binary to ${DEST_DIR_EXE}/multimarkdown ..."
+ dobin multimarkdown || die "Install failed"
+
+ # USE flag based installation
+ # install shortcuts
+ if use shortcuts ; then
+ einfo "Installing shortcuts for ${PN}"
+ exeinto ${DEST_DIR_EXE}
+ for file in ${SHORTCUTS_LIST}; do
+ # einfo "Installing ${file} to ${DEST_DIR_EXE}/${file} ..."
+ doexe scripts/${file} || die "Installation of script ${file} failed!"
+ done
+ fi
+
+ #install documentation
+ if use doc; then
+ einfo "Installing documentation for ${PN}"
+ dohtml manual/*.html || die "Installation of documentation failed!"
+ if use latex; then
+ dodoc manual/*.pdf || die "Installation of LaTeX documentation failed!"
+ fi
+ fi
+
+ # install perl-conversion scripts
+ if use perl-conversions ; then
+ einfo "Installing perl-conversion scripts for ${PN}"
+ exeinto ${DEST_DIR_EXE}
+ for file in ${PERLSCRIPTS_LIST}; do
+ local file_path=`find Support/ -name "${file}"`
+ # einfo "Installing ${file} to ${DEST_DIR_EXE}/${file} ..."
+ doexe "${file_path}" || die "Installation of script ${file} failed!"
+ done
+ fi
+
+ # install latex support
+ # nothing to do, it's all in the plugin pkg
+
+ # install xslt support
+ if use xslt ; then
+ einfo "Installing XSLT templates for ${PN} to ${DEST_DIR_XSLT_TEMPL}"
+ insinto ${DEST_DIR_XSLT_TEMPL}
+ doins Support/XSLT/* || die "Installation of XSLT templates failed!"
+ einfo "Installing XSLT scripts for ${PN}"
+ exeinto ${DEST_DIR_EXE}
+ for file in ${XSLTSCRIPTS_LIST}; do
+ local file_path=`find Support/ -name "${file}"`
+ einfo "Installing ${file} to ${DEST_DIR_EXE}/${file} ..."
+ doexe ${file_path} || die "Installation of script ${file} failed!"
+ done
+ fi
+}
+
+pkg_postinst()
+{
+ elog ""
+ elog "*** ${PN} was successfully installed. ***"
+ elog "Type \"multimarkdown -h\" or \"multimarkdown file.txt\" to start using it."
+ if use shortcuts; then
+ elog "The following additional shortcuts were also installed:"
+ elog "${SHORTCUTS_LIST}."
+ elog "The shortcut \"mmd\" was not installed due to known file"
+ elog "collision with sys-fs/mtools on file /usr/bin/mmd"
+ fi
+ if use perl-conversions; then
+ elog "The following additional conversion shortcuts were also installed:"
+ elog "${PERLSCRIPTS_LIST}"
+ fi
+ if use xslt; then
+ elog "The following additional XSLT conversion shortcuts were also installed:"
+ elog "${XSLTSCRIPTS_LIST}."
+ fi
+ if use doc; then
+ elog "The html documentation was installed, normally it goes to:"
+ elog "/usr/share/doc/${PF}/html/"
+ if use latex; then
+ elog "The pdf documentation was also installed, normally it goes to:"
+ elog "/usr/share/doc/${PF}/"
+ fi
+ fi
+ elog ""
+}
+
+pkg_info()
+{
+ einfo "`${ROOT}${DEST_DIR_EXE}/multimarkdown -v`"
+}
diff --git a/profiles/repo_name b/profiles/repo_name
new file mode 100644
index 0000000..f5301b9
--- /dev/null
+++ b/profiles/repo_name
@@ -0,0 +1 @@
+wuodan