aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2018-01-25 09:12:38 +0000
committerStuart Shelton <stuart@shelton.me>2018-01-25 09:12:38 +0000
commitfac1ed03aa85353f1bfe97a19e712cc8f41b57a0 (patch)
treebce653359da0c797c660350ff0d19ee2713f9927 /dev-python
parentAdd dev-python/nodeenv-1.2.0, update README.md (diff)
downloadsrcshelton-fac1ed03aa85353f1bfe97a19e712cc8f41b57a0.tar.gz
srcshelton-fac1ed03aa85353f1bfe97a19e712cc8f41b57a0.tar.bz2
srcshelton-fac1ed03aa85353f1bfe97a19e712cc8f41b57a0.zip
Add dev-python/pathspec-0.5.5, update README.md
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pathspec/Manifest2
-rw-r--r--dev-python/pathspec/pathspec-0.5.5.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pathspec/Manifest b/dev-python/pathspec/Manifest
new file mode 100644
index 00000000..e9b50130
--- /dev/null
+++ b/dev-python/pathspec/Manifest
@@ -0,0 +1,2 @@
+DIST pathspec-0.5.5.tar.gz 22795 SHA256 7144457e8754df2b93de29d5e9b4d4e54a10b8761ca8a1409aab5de2b9d608b6 SHA512 43f1e050fe208e6f3fdd24fe734534318120709de67297f0a47305c1a418a6cb269811fe2c311cb05183b1fe3cb1b4944538f7c67e058a5b963b88e761309e62 WHIRLPOOL 9a1ce3fe648c8f795c9a78e555e898ea2b7f7009c69835eaf565d6d0125279742e9c428b4414902f055d227bc1ebeee9967c933fd41583adbc29bd887b25bacc
+EBUILD pathspec-0.5.5.ebuild 766 SHA256 b106fb189d139cf6b625489f824bc70395c863b11c9ee368100599a229f0cc69 SHA512 0d4d433e14ad3c41bfa1898d45da7166ac1dee716907678da0baacafa7ffb1d8e8f448115f448cc9e17e6308198afe532d1c2b643106f9df160366aa6af81e85 WHIRLPOOL 1ac90f68e631eb616b86a7fa642602ce61248703352a1db35685a33c75b69abf8e8c3a660462ee97b1e583dd64fa407a64ee6d6f46a241585af6b502e6709cec
diff --git a/dev-python/pathspec/pathspec-0.5.5.ebuild b/dev-python/pathspec/pathspec-0.5.5.ebuild
new file mode 100644
index 00000000..423da41a
--- /dev/null
+++ b/dev-python/pathspec/pathspec-0.5.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Stuart Shelton
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+# No branches, no tags, no releases - ugh :(
+commit='636a35204c80ed3e505c8d3dfac370b59821c7e6'
+
+DESCRIPTION="Utility library for gitignore style pattern matching of file paths"
+HOMEPAGE="https://github.com/cpburnz/python-path-specification"
+SRC_URI="https://github.com/cpburnz/python-path-specification//archive/${commit}.tar.gz -> ${P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="MPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux x64-macos"
+#IUSE="doc"
+
+S="${WORKDIR}/python-path-specification-${commit}"
+
+python_install_all() {
+ local DOCS=( README.rst )
+ distutils-r1_python_install_all
+}