aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2015-03-01 23:55:54 +0000
committerStuart Shelton <stuart@shelton.me>2015-03-01 23:55:54 +0000
commita4d9373945602ae6ea846151348664b5d4579758 (patch)
tree7f7158d87b4049f457bc8e8fb6e45cd41ded01b1 /dev-python
parentUpdate www-servers/lighttpd-1.4.35-r1 (diff)
downloadsrcshelton-a4d9373945602ae6ea846151348664b5d4579758.tar.gz
srcshelton-a4d9373945602ae6ea846151348664b5d4579758.tar.bz2
srcshelton-a4d9373945602ae6ea846151348664b5d4579758.zip
Add dev-python/raspberrypi-gpio-0.5.11, update README.md
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/raspberrypi-gpio/Manifest2
-rw-r--r--dev-python/raspberrypi-gpio/raspberrypi-gpio-0.5.11.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/raspberrypi-gpio/Manifest b/dev-python/raspberrypi-gpio/Manifest
new file mode 100644
index 00000000..4e46740d
--- /dev/null
+++ b/dev-python/raspberrypi-gpio/Manifest
@@ -0,0 +1,2 @@
+DIST RPi.GPIO-0.5.11.tar.gz 24165 SHA256 69d1892c44c09d651f1d1524bdea07a57873ba7ba019407eeb9f7c7db36fd7c6 SHA512 be973666e3155388d2bbf0061289c9c07f97aff38d2ebfe30b1d9e1003886c40222dea58365077003b80a97a6710a41782df122216cc0a971ac31af3df4e3fb4 WHIRLPOOL 3da12ef5ca23deb20a85224605b4edd0aa4925bf7077ca782c4163e7c02b92989d8123cf9156d0e437f8f42d2d5781ed5be5862fb54a294cb50bcd11aab47746
+EBUILD raspberrypi-gpio-0.5.11.ebuild 747 SHA256 51b3e8bc8f60eb622b328729eaa1693269cdfffe56c9abe2cbe40a86b52c1160 SHA512 6fd6a76392447949a5fe1534db400638c4116922c2d5a0b2815699d8b6d6067c6c2b362883df6a4d6d866c657b4911e0c0a840c6293fe8789d0107b825fe1a27 WHIRLPOOL f0424e7b198d8f45cde3f25f2b5fbed352a7e036c3e74edacf08ddeb58fed6b47ae4825270e3e302b829529fbcabf3c2e1aed8ae3c505f03a65eb9f0c38ae90f
diff --git a/dev-python/raspberrypi-gpio/raspberrypi-gpio-0.5.11.ebuild b/dev-python/raspberrypi-gpio/raspberrypi-gpio-0.5.11.ebuild
new file mode 100644
index 00000000..9dcf54ed
--- /dev/null
+++ b/dev-python/raspberrypi-gpio/raspberrypi-gpio-0.5.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2015 Stuart Shelton
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 eutils
+
+MY_P=${P/raspberrypi-gpio/RPi.GPIO}
+
+DESCRIPTION="A collection of libraries to process XML with Python"
+HOMEPAGE="http://pyxml.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/project/raspberry-gpio-python/RPi.GPIO-0.5.11.tar.gz"
+RESTRICT="mirror
+ test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="arm"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc README.txt
+ dodoc CHANGELOG.txt
+ fi
+}